用户无法在 Outlook 或 Outlook 网页版 中创建新规则

症状

用户无法在 Microsoft Outlook 或 Outlook 网页版 (OWA) 中创建新规则。 此外,用户会收到以下错误消息:

一个或多个规则无法上传到 Microsoft Exchange,并且已停用。 这可能是因为不支持某些参数,或者没有足够的空间来存储所有规则。

原因

出现此问题的原因是,默认情况下,邮箱中规则的大小限制设置为 64 KB。 如果规则的大小达到此限制,用户将收到错误消息。

解决方案

若要解决此问题,请增加邮箱中规则的大小限制。 为此,请按照下列步骤操作:

  1. 若要确定邮箱中规则的大小限制,请在 Exchange 命令行管理程序中运行以下命令:

    get-mailbox -identity <mailbox> | fl *rulesquota*  
    
  2. 如果当前大小限制小于 256 KB,请运行以下命令,将大小限制增加到 256 KB:

    set-mailbox -identity <mailbox> -RulesQuota 256kb
    

注意

这是一个 Active Directory 缓存属性,更改它可能需要长达两个小时才能生效。

更多信息

租户管理员还可以在 Microsoft 365 环境中增加其用户的规则大小限制。 有关详细信息,请参阅 询问 Microsoft 社区

如果你位于专用或 ITAR Microsoft 365 环境中并遇到此问题,受限收件人管理自助服务组的成员可以使用 (12.3 版服务及更高版本) 的“解决方法”部分中的命令来增加规则配额。 你还可以升级到 Microsoft Online Services 支持。