Outlook 2007 或 Outlook 2010 中的邮件记录管理 (MRM) 策略不会处理或删除“同步问题”文件夹中的项目

原始 KB 编号: 2686541

症状

在缓存 Exchange 模式下使用 Microsoft Office Outlook 2007 或Microsoft Outlook 2010时,系统会在“同步问题”文件夹中创建邮件。 Exchange 管理员可以 (“同步问题”文件夹的 RPT) 创建保留策略标记,然后将该 RPT 添加到现有保留策略。

将邮件记录管理 (MRM) 策略应用到邮箱时,“同步问题”文件夹中的项目可能带有过期日期标记。 但是,MRM 不会处理或删除项目。

原因

MRM 不会处理“同步问题”文件夹,因为该文件夹仅是客户端文件夹。 如果使用 Microsoft Exchange Server 消息 API (MAPI) 编辑器 来查看“同步问题”文件夹,则可以注意到该文件夹中的项目上未标记 MRM 策略标记。 当托管文件夹助理处理邮箱时,不会处理此文件夹中的项目。

项目列为过期的原因是 Outlook 在缓存 Exchange 模式下拉取文件夹的策略标记信息,然后自行计算过期时间。

解决方法

若要解决此问题,请不要为“同步问题”文件夹实现 RPT,因为不会对“同步问题”文件夹本身的内容执行任何操作。 此保留标记会自动应用于“同步问题”文件夹下的子文件夹的内容。

此外,如果要自动清空“同步问题”文件夹,则必须使用 Outlook 中的“自动存档”功能。

更多信息

同步错误文件夹

下面是同步错误文件夹网页的摘录:

(The Sync Issues folder) contains all of the synchronization logs. In previous releases of Microsoft Outlook, these logs were stored in the Deleted Items folder. This folder is helpful if Outlook is having trouble synchronizing—for example, there is an item that you see in Outlook Web Access, but not in Outlook—or you are not getting new mail in some folders when using Cached Exchange Mode.

此文件夹中的信息可帮助组织的支持团队或 Microsoft Exchange 服务器管理员确定问题所在。 “同步问题”文件夹的内容不会复制到服务器,并且无法从任何其他计算机查看“同步问题”文件夹中的项目。

重要

尽管“同步问题”文件夹本身不会根据应用 RPT 的时间进行操作,但请注意,应用 RPT 时,标记将自动应用于“同步问题”文件夹的子文件夹。 子文件夹包括冲突、本地故障和服务器故障。 MRM 将处理包含存储在 Exchange Server 上的内容的任何子文件夹。 应用此 RPT 时请谨慎,因为子文件夹中可能存在指示问题的项。 自动删除此内容可能会导致数据丢失,或者可能掩盖特定客户端的更严重问题。

邮件项过期日期属性

有关邮件项到期日期属性的详细信息,请转到以下 Microsoft 开发人员网络 (MSDN) 网站:

MailItem.RetentionExpirationDate 属性

如果 Outlook 处于缓存模式或脱机模式,Microsoft Outlook 会根据项目保留开始日期和保留期计算此属性的值。 如果 Outlook 处于联机模式,Exchange Server 将指定该值。

有关保留策略和保留标记的详细信息,请转到以下Microsoft Exchange Server网站:

了解保留标记和保留策略