在直接转换迁移中迁移邮箱时,已存在不同类型的 Active Directory 对象错误

原始 KB 编号: 2968722

症状

执行直接转换迁移以将邮箱从本地 Microsoft Exchange 组织迁移到Microsoft Exchange Online时,不会迁移一个或多个用户,并且你会收到以下错误消息:

目标林中“<user>@<domainname>.com”已存在不同类型的 Active Directory 对象。 请验证 SMTP 地址是否正确。

原因

出现此问题是因为尚未迁移的用户对象已位于目标Exchange Online组织中。

解决方案

若要解决此问题,请删除 Exchange Online 中的用户对象。 为此,请按照下列步骤操作:

  1. 以管理员身份登录 Microsoft 365 门户:
  2. 选择 “用户和组”,然后搜索未迁移的用户。
  3. 永久删除用户。 可以在 Microsoft 365 门户中执行此操作,也可以使用用于Windows PowerShell的 Microsoft Azure Active Directory 模块。

重要

删除用户帐户还会删除关联的 SharePoint Online 和 Skype for Business Online (以前 Lync Online) 该用户的信息。

若要使用用于Windows PowerShell的 Azure Active Directory 模块删除用户,请执行以下步骤:

  1. 连接到Microsoft Entra ID。 有关如何执行此操作的详细信息,请参阅 Microsoft Entra Cmdlet

  2. 运行以下命令:

    Remove-MSOL -UserPrincipalName User@domain.com -RemoveFromRecycleBin
    

执行这些步骤后,请确保门户中不再列出用户,然后执行迁移。

更多信息

有关直接转换 Exchange 迁移的详细信息,请参阅 使用 Exchange 直接转换方法迁移电子邮件

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