现象
将邮箱从 Microsoft Exchange Server 远程迁移到混合 Exchange 环境中的 Microsoft Exchange Online 后,迁移的用户会报告其中一个或多个Microsoft Outlook 文件夹中缺少数据。 例如,其 Notes 文件夹为空。
原因
在远程移动迁移期间,由于暂时性网络错误或文件夹损坏,数据可能无法迁移到 Exchange Online。
注意:有关如何检测和修复邮箱损坏问题的信息,请参阅 New-MailboxRepairRequest。
解决方法
重要
对于数据恢复,当你将用户迁移到 Exchange Online 时,用户的本地邮箱只会 软删除。 Exchange Server 在保留期到期时永久删除软删除邮箱(如果邮箱未保留)。 软删除邮箱的默认保留期为 30 天。
如果保留期尚未过期,并且迁移用户的软删除邮箱仍然存在,请使用以下步骤还原用户云邮箱中的任何缺失数据。
注意
在 Exchange 命令行管理程序(EMS)中运行所有 PowerShell cmdlet。
运行以下 PowerShell cmdlet 以获取有关用户软删除邮箱的信息:
Get-MailboxDatabase| ForEach-Object { Get-MailboxStatistics -Database $_.DistinguishedName } | Where-Object { ($_.DisconnectReason -match "SoftDeleted") -and ($_.DisplayName -match "<migrated mailbox name>") } | FL DisplayName, Database, DisconnectDate, MailboxGUID
请注意 PowerShell 输出中的以下信息:
- 托管软删除邮箱的数据库的名称
- 软删除邮箱的 GUID
运行以下 PowerShell cmdlet 以创建临时本地邮箱(将其命名方式与迁移的邮箱不同):
$password = Read-Host "Enter password" -AsSecureString New-Mailbox -Name "<temp mailbox name>" -UserPrincipalName <UPN> -Password $password | FL ExchangeGuid
请注意 PowerShell 输出中临时邮箱的 GUID。
运行 New-MailboxRestoreRequest PowerShell cmdlet 以创建还原请求,将数据从软删除邮箱中的文件夹复制到临时邮箱中的文件夹:
New-MailboxRestoreRequest -Name "<request name>" -SourceDatabase "<name of database that contains soft-deleted mailbox>" -SourceStoreMailbox "<GUID of soft-deleted mailbox>" -SourceRootFolder "<folder name>" -TargetMailbox "<GUID of temporary mailbox>" -TargetRootFolder "<folder name>" -AllowLegacyDNMismatch
运行此命令时,传入前面步骤中记录的信息以及缺少数据的文件夹的名称。 例如,若要还原 Notes 文件夹,请将“备注 ”文件夹的值
SourceRootFolder
和TargetRootFolder
参数设置为Notes
。注意
若要还原整个邮箱,请运行不带
SourceRootFolder
和TargetRootFolder
参数的 New-MailboxRestoreRequest cmdlet。等待还原请求完成。 若要检查请求状态,请使用 Get-MailboxRestoreRequest PowerShell cmdlet,如下所示:
Get-MailboxRestoreRequest -Name "<request name>"
将临时邮箱中的还原数据导出 到 PST 文件。
指示受影响的用户 将步骤 5 中创建的 PST 文件 导入到其 Outlook 应用中,以还原丢失的数据。