症状
尝试从 Microsoft Outlook 客户端中删除公用文件夹时,即使具有适当的权限,也会收到以下错误消息之一:
在 Outlook for Windows 中
无法删除此文件夹。 右键单击文件夹,然后单击“属性”以检查对此文件夹的权限。 请与文件夹所有者或管理员联系以更改权限。 某些项目无法删除。 它们已被移动或已删除,或者访问被拒绝。
在 Outlook for Mac
由于 Exchange 服务器上的错误,Outlook 无法完成该操作。
HTTP 错误。 尚未授权访问资源。
原因
出现此问题的原因是公用文件夹已启用邮件。 必须先禁用公用文件夹,然后才能将其删除。
解决方案
若要解决此问题,请使用以下步骤通过邮件禁用公用文件夹。
注意: 必须具有管理员权限才能执行这些步骤。
使用以下命令删除公用文件夹:
Remove-PublicFolder <identity of PF>
在输出中,你会看到一条错误消息,指示应先禁用公用文件夹,然后才能继续操作。
使用以下命令邮件禁用公用文件夹:
Disable-MailPublicFolder <identity of PF>
当系统提示确认此操作时,请输入 Y。
完成这些步骤后,可以从 Exchange Online PowerShell 中删除公用文件夹,或者用户可以将其从 Outlook 客户端中删除。