联合用户尝试登录到 Microsoft 365、Azure 或 Intune 时出现错误80048163
问题
当联合用户尝试从 URL 以开头https://login.microsoftonline.com的登录网页登录到 Microsoft 云服务(如 Microsoft 365、Microsoft Azure 或 Microsoft Intune),该用户的身份验证将失败。 用户收到以下错误消息:
Sorry, but we're having trouble signing you in
Please try again in a few minutes. If this doesn't work, you might want to contact your admin and report the following error:
80048163
原因
如果满足以下条件之一,则可能会出现此问题:
- 用户的 UPN 已更新,旧登录信息缓存在 Active Directory 联合身份验证服务 (AD FS) 服务器上。 更改用户的 SAM 帐户时,在用户下次尝试访问服务时,缓存的登录信息可能会导致问题。
- 在信赖方信任中设置的声明Microsoft Entra ID返回意外数据。 手动编辑或删除与信赖方信任关联的声明时,可能会出现此行为。
解决方案
解决方法 1:在 AD FS 服务器上禁用本地安全机构 (LSA) 凭据缓存
可以更新 AD FS 服务器上的 LSA 缓存超时设置,以禁用 Active Directory 凭据信息的缓存。 请谨慎使用此方法。 它可能会给服务器和 Active Directory 带来额外的负载。
重要
此方法包含说明如何修改注册表的步骤。 但是,注册表修改不当可能会出现严重问题。 因此,请务必严格按照这些步骤操作。 为了加强保护,应先备份注册表,再进行修改。 如果出现问题,可以还原注册表。 有关如何备份和还原注册表的详细信息,请单击以下文章编号以查看 文章如何在 Windows 中备份和还原注册表。
若要解决此问题,请按照下列步骤操作:
确保通过目录同步对用户的 UPN 所做的更改。
指示用户注销计算机,然后再次登录。
如果步骤 1 和 2 无法解决问题,请执行以下步骤:
打开注册表编辑器,然后找到以下子项:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
右键单击 Lsa,单击“ 新建”,然后单击“ DWORD 值”。
键入 LsaLookupCacheMaxSize,然后按 Enter 为新值命名。
右键单击“ LsaLookupCacheMaxSize”,然后单击“ 修改”。
在 “值数据 ”框中,键入 0,然后单击“ 确定”。
退出注册表编辑器。
LsaLookupCacheMaxSize 重新配置可能会影响登录性能,在症状消退后,不需要此重新配置。 此方法应仅暂时使用,强烈建议在问题解决后删除 LsaLookupCacheMaxSize 值。 为此,请按照下列步骤操作:
打开注册表编辑器,然后找到以下子项:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
右键单击“ LsaLookupCacheMaxSize”,然后单击“ 删除”。
退出注册表编辑器。
解决方法 2:使用 Microsoft Entra ID 更新信赖方信任
若要更新信赖方信任,请参阅以下 Microsoft 文章的“如何更新 Microsoft 365 联合域的配置”部分:
如何更新或修复 Microsoft 365、Azure 或 Intune 中联合域的设置
更多信息
仍然需要帮助? 转到 Microsoft 社区或Microsoft Entra论坛网站。