原始 KB 数: 4459263
现象
假设出现了下面这种情景:
- 用户在 Microsoft 365 中拥有邮箱。
- 为邮箱启用就地保留或诉讼保留。
- 用户尝试从 Microsoft Outlook Web App (OWA) 或 Microsoft Outlook 编辑日历项目。
在此方案中,用户会收到以下错误消息:
无法更新以下事件:
<EventName>
原因
出现此问题的原因是“版本”文件夹(属于“可恢复项目”文件夹的一部分)已满。
注意
若要检查“可恢复项目”文件夹统计信息,请运行以下命令:
Get-MailboxFolderStatistics -Identity cloudtest -FolderScope recoverableitems | ft name,*size*
解决方法
由于用户的邮箱处于保留状态,因此“版本”文件夹中的项目非常重要。 若要解决此问题,必须为受影响的用户启用存档邮箱,然后将“版本”文件夹的所有项目移动到存档邮箱。 为此,请按照下列步骤进行操作:
启用存档邮箱。 为此,请运行
Enable-Mailbox -IdentityUserName-Archive
。启用自动扩展存档功能。 为此,请运行
Enable-Mailbox <UserMailbox> -AutoExpandingArchive
。注意
- 为邮箱启用自动扩展存档会将用户主邮箱中“可恢复邮件”文件夹的存储配额增加 10 GB(从 100 GB 增加到 110 GB)。 此外,此步骤将存档邮箱大小增加到 无限制。
- 必须先启用用户的存档邮箱,然后才能启用自动扩展存档。 必须为用户分配 Exchange Online 计划 2 许可证才能启用存档邮箱。 如果用户分配了 Exchange Online 计划 1 许可证,则必须为其分配单独的 Exchange Online Archiving 许可证才能启用其存档邮箱。
为保留的邮箱创建自定义保留策略,然后将项目从“版本”文件夹移动到存档邮箱。 为此,请遵循步骤 1 中 提到的步骤:为以下 Docs 文章的“可恢复项目”文件夹 部分创建自定义保留标记:
详细信息
当用户的邮箱处于就地保留或诉讼保留状态时,原始项目和已更改的项目将复制到“版本”文件夹。 如果“版本”文件夹已满,则无法将原始项的更改副本存储在文件夹中。 因此,用户无法保存对原始项所做的更改。
有关可能阻止保留策略删除电子邮件的问题的信息,请参阅 使用保留策略时解决电子邮件存档和删除问题。