解决Microsoft Purview 邮件加密问题

现象

组织中的用户遇到以下一个或多个问题:

  • 他们无法在 outlook 或 Outlook 网页版 中打开Microsoft加密的电子邮件。
  • 他们无法发送加密的电子邮件。
  • Outlook 和 Outlook 网页版 中缺少“加密”按钮。

原因

这些问题可能由于多种原因而发生,例如:

  • 组织的 Microsoft 365 订阅不支持Microsoft Purview 邮件加密。
  • 组织使用的租户配置不正确。
  • 受影响的用户用来登录 Outlook 或Outlook 网页版的帐户未分配有效的许可证以使用Microsoft Purview 邮件加密(Office 365 邮件加密)功能。

解决方法

若要解决问题,请按给定顺序执行以下步骤。 完成每个步骤后,检查问题是否仍然存在。

步骤 1:运行Microsoft Purview 邮件加密的诊断

注意

若要运行诊断,你必须是 Microsoft 365 全局管理员。

按照以下步骤运行诊断:

  1. 选择以下按钮以在Microsoft 365 管理中心中打开诊断。

  2. 选择“ 运行测试”。

如果运行了诊断,但其发现没有帮助解决问题,请转到步骤 2。

步骤 2:验证Microsoft 365 订阅

若要使用Microsoft Purview 邮件加密,组织必须具有支持此功能的订阅。 有关订阅要求的信息,请参阅我需要使用哪些订阅Microsoft Purview 邮件加密

步骤 3:验证租户配置

  1. 使用 Exchange Online PowerShell 验证是否已为Microsoft Purview 邮件加密正确配置租户

  2. 运行以下 cmdlet,检查在Outlook 网页版中是否启用了信息权限管理(IRM)功能:

    Get-OwaMailboxPolicy | FL *IRMEnabled*
    

    如果 IRMEnabled 的值False,请运行以下 cmdlet:

    Set-OwaMailboxPolicy -Identity OwaMailboxPolicy-Default -IRMEnabled $true
    
  3. 如果Outlook 网页版中缺少“加密”按钮,请运行以下 cmdlet:

    Set-IRMConfiguration -SimplifiedClientAccessEnabled $true
    

步骤 4:验证受影响的用户的帐户许可证

受影响的用户必须确保他们用于登录 Outlook 或Outlook 网页版的帐户分配适当的许可证才能使用Microsoft Purview 邮件加密功能。 如果他们无法确定这一点,用户应在其设备上执行以下步骤:

  1. 注销 Office。

  2. 从 Windows 凭据管理器中删除缓存的凭据:

    1. 打开 >>凭据管理器。
    2. 选择“Windows 凭据”
    3. 展开每个凭据并选择“ 删除”,删除所有 Outlook 或 Office 凭据。
  3. 如果设备未Microsoft已加入 Entra,请从设备中删除未经许可的帐户:

    1. 选择“>访问工作或学校”。
    2. 选择要删除的帐户,然后选择“ 断开连接”。
  4. 使用授权使用Microsoft Purview 邮件加密功能的用户帐户登录到 Office。

步骤 5:验证与 Azure Rights Management 服务的连接

若要确定受影响的用户的邮件客户端是否可以连接到 Azure Rights Management 服务,请运行以下 PowerShell 命令:

$request = [System.Net.HttpWebRequest]::Create("https://admin.na.aadrm.com/admin/admin.svc")
$request.GetResponse()
$request.ServicePoint.Certificate.Issuer

输出应显示颁发证书颁发机构(CA)是Microsoft CA。 例如:

CN=Microsoft Secure Server CA 2011, O=Microsoft Corporation, L=Redmond, S=Washington, C=US.

如果看到不是来自Microsoft的 CA,则安全客户端到服务连接可能已终止,必须在防火墙上重新配置。 有关详细信息,请参阅 防火墙和网络基础结构

步骤 6:检查敏感度标签

如果敏感度标签应用于电子邮件,则必须正确分配权限,以便收件人可以访问邮件。 有关详细信息,请参阅 使用敏感度标签限制对内容的访问。

如果在完成所有这些步骤后问题仍然存在,请联系Microsoft 支持部门进一步进行故障排除。

详细信息

  • 如果组织中的用户向组织外部人员发送加密消息或接收加密消息时遇到问题,请检查两个组织中的条件访问策略和来宾帐户配置。 有关详细信息,请参阅外部收件人无法打开加密电子邮件Microsoft加密内容的 Entra 配置,以及 Azure 信息保护的条件访问策略。
  • 用户可以打开发送到共享邮箱的加密电子邮件。 如果邮件是从同一组织发送的,则用户可以在登录到受支持的 Outlook 客户端时将其打开。 如果邮件是从外部组织发送的,则用户必须使用Outlook 网页版。 有关详细信息,请参阅 消息加密常见问题解答