新的 Teams 桌面应用无法呈现视频

症状

你在安装了 Nahimic 音频驱动程序的计算机上使用新的 Microsoft Teams 桌面应用。 在 Teams 会议期间,应用不会在以下任何方案中呈现视频:

  • 视频内容在会议期间呈现。
  • 在未启用视频的情况下加入会议,然后在会议中启用视频。
  • 在加入会议之前,检查“加入会议”窗口中的视频预览屏幕,以验证视频是否正常工作。

原因

出现此问题的原因是新 Teams 应用与 Nahimic 音频驱动程序之间存在冲突。

解决方法

若要解决此问题,请执行以下步骤:

  1. 退出 Teams 桌面应用。

  2. 在 文件资源管理器中搜索 %PROGRAMDATA% 文件夹中名为 BlackApps.dat 的文件。 此文件是 Nahimic 应用使用的排除列表。

  3. 使用文本编辑器(如记事本)打开BlackApps.dat文件。

    注意: 如果无法打开该文件,请按照以下步骤更改对文件的权限:

    1. 右键单击该文件,然后选择“属性”。
    2. 选择“ 安全性 ”选项卡,然后选择“ 编辑” 按钮。
    3. “权限” 屏幕上的“ 组或用户名 ”框中,选择所属的相应组。
    4. 在“权限”框中的列表中,为“完全控制”权限选择“允许”。
    5. 选择“ 应用”,然后选择“ 确定 ”以关闭 “权限” 屏幕。
    6. 关闭“属性”对话框。
  4. 在 BlackApps.dat 文件中,添加以下可执行文件:

    • ms-teams.exe
    • msedgewebview2.exe
  5. 保存文件,然后退出文本编辑器。

  6. 重启 Teams 桌面应用。

第三方信息免责声明

本文中提到的第三方产品由 Microsoft 以外的其他公司提供。 Microsoft 不对这些产品的性能或可靠性提供任何明示或暗示性担保。