登录到 Microsoft 365 应用时,错误代码80070520、-2147023584或2147943712

症状

尝试登录到 Microsoft 365 应用时,身份验证会失败。 出现此问题时,登录窗口中会显示以下错误代码之一,并可能在 Microsoft 365 Apps 登录日志中记录:

  • 80070520
  • -2147023584
  • 2147943712

登录窗口中 -2147023584 错误代码的屏幕截图。

这些错误代码指示指定的登录会话不存在。

原因

此问题可能因下列原因所致:

  • 用户模拟

    使用改变用户上下文的冒充方法启动 Microsoft 365 应用,例如:

    • 以管理员身份运行
    • 以其他用户身份运行
    • 以特权用户身份运行

    这些方法会干扰应用的身份验证流。 在大多数情况下,它们是不受支持的。

    注释

    如果当前登录的用户帐户和管理员帐户相同,则支持使用“以管理员身份运行”。

  • 身份验证令牌无效或不匹配

    身份验证令牌通常包括特定于设备的声明,并绑定到用户会话。 当用户在具有漫游配置文件的环境中切换设备或使用共享设备时,令牌可能会失效或不匹配。 这会导致身份验证失败。

    重要

    建议不要手动删除令牌。

决议

若要防止此问题,请遵循以下准则: