Microsoft 365 组在 Outlook 中不同步

症状

在 Microsoft Outlook 中配置的Exchange Online邮箱中,部分或全部 Microsoft 365 组不会自动同步。

在 Outlook 的状态栏中,同步状态显示消息“此文件夹尚未更新”。

原因

在以下情况中可能会出现此问题:

  • 未为租户启用新式身份验证。
  • 已启用新式身份验证,受影响的 Microsoft 365 组具有 10 万个或更多项。

解决方案

若要解决此问题,请使用解决方法 1 或解决方法 2,具体取决于问题的原因。

解决方法 1:如果未为租户启用新式身份验证,请使用以下步骤:

  1. 在 Exchange Online 中为 Outlook 启用新式身份验证,并等待复制完成,这需要几分钟时间。
  2. 创建 Outlook 配置文件
  3. 打开 “Outlook 连接状态 ”对话框。
  4. 验证 Authn 列中的条目是否显示 Bearer*。 此值确认 Outlook 正在使用新式身份验证。
  5. 检查 Outlook 状态栏中的同步状态是否已更新为显示“此文件夹是最新的”。

解决方法 2:如果某些 Microsoft 365 组有 10 万个或更多项,请使用以下信息。

如果为租户启用了新式身份验证,并且某些受影响的组中的项目计数为 100K 或更多,则可能需要缩短 Outlook 缓存 Microsoft 365 组中项目的时间段。 默认时间段为 12 个月。

若要缩短此时间段并解决问题,请使用以下步骤:

  1. 创建以下注册表项:

    HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Cached Mode DWORD = GroupsSyncWindowSetting
    值 = 3

    该值是一个数字,指定 Outlook 在 Microsoft 365 组中缓存内容的时间段(以月为单位)。

  2. 重新启动 Outlook。

  3. 检查 Outlook 状态栏中的同步状态是否已更新为显示“此文件夹是最新的”。