Outlook 中的外出功能在 Microsoft 365 中无法正常工作

症状

尝试在 Microsoft 365 中使用 Outlook 中的“外出 (OOF) ”功能时,会遇到以下症状:

  • 无法保存 OOF 消息。
  • 发送旧或重复的 OOF 消息。
  • 即使启用 OOF 消息,也不会发送 OOF 消息。

原因

此问题由以下原因之一导致:

  • 原因 1:仅) Exchange 2010 (邮箱助手事件积压。
  • 原因 2:OOF 规则模板格式不正确或损坏。
  • 原因 3:超出 OOF 规则配额,无法创建新规则。
  • 原因 4:默认 (或特定) 域的远程域设置未设置为允许 OOF 消息。

解决方案

注意

这四个原因中的任何一个都可能导致 OOF 回复失败。 因此,必须一次排除每个原因。

警告

使用 Microsoft Exchange Server MAPI 编辑器 (MFCMapi) 可能会损坏Microsoft Exchange Server和 Exchange 服务器邮箱。 从 github 下载 MFCMAPI (向下滚动,然后选择“最新版本) ”。

若要解决此问题,请执行特定原因的步骤。

解决方法 1

  1. 配置 OOF 功能。 为此,请根据需要在 Windows PowerShell 中运行以下 cmdlet 之一:

    Set-MailboxAutoReplyConfiguration <identity> -AutoReplyState Disabled
    Set-MailboxAutoReplyConfiguration <identity> -AutoReplyState Enabled

  2. 使用 MFCMapi 检查PR_OOF_STATE值。 为此,请按照下列步骤操作:

    1. 在 MFCMapi 的“main”窗口中,选择“会话”,然后选择“登录并显示存储表”以打开邮箱。

    2. 选择要访问的配置文件,然后在底部窗格中向下滚动,直到看到 PR_OOF_STATE 值。 如果在 Windows PowerShell 中启用了 OOF 功能,此值应为 True;如果禁用了 OOF 功能,则此值应为 False。 例如,如果禁用了 OOF 功能,请考虑以下屏幕截图:

      PR_OOF_STATE值的屏幕截图。

  3. PR_OOF_STATE如果值不是预期结果,请联系Microsoft 支持部门,让他们检查队列事件, (Exchange 2010 仅) 。

解决方法 2

注意

你的病例的症状可能与这些略有不同。 例如,OOF 消息无法按预期发送,尽管可以设置 OOF 消息而不出错。 但是,这些步骤仍将适用。

若要解决此问题,请从邮箱中删除 OOF 规则和 OOF 规则模板。 然后,重新启用 OOF 功能,并测试该行为。 为此,请按照下列步骤操作。

注意

执行这些步骤时,无需备份 OOF 消息。

  1. 在 MFCMapi 的“main”窗口中,选择“会话”,然后选择“登录并显示存储表”以打开邮箱。

  2. 展开根容器和信息存储的顶部。

  3. 删除 OOF 规则。 为此,请按照下列步骤操作:

    1. 右键单击“ 收件箱”,然后选择“ 显示规则表”。

      • 如果禁用 OOF 功能,则会在规则表中列出 OOF 规则以及以下规则名称:
        MSFT:TDX OOF 规则

      • 如果启用了 OOF 功能,规则表中会列出两个不同的 OOF 规则。 列出哪些规则取决于规则是仅在内部启用还是同时在内部和外部启用。 例如,请考虑以下屏幕截图:

        “规则表”对话框详细信息的屏幕截图。

      • 如果 OOF 模板损坏或格式不正确,则规则表中会列出这些 OOF 模板。 如果用户启用了其他规则,则可以看到其他条目。

    2. 右键单击 OOF 规则,然后选择“ 删除”。

      注意

      请勿删除除引用的 OOF 规则之外的任何 OOF 规则。

    3. 关闭“规则表”窗口。

  4. 删除 OOF 模板。 为此,请按照下列步骤操作:

    • 右键单击“ 收件箱”,然后选择“ 打开关联的内容表”。
    • 滚动到右侧,然后展开 “消息类 ”列。
    • 若要对项目进行排序,请选择“ 消息类 ”列。
    • 查找 其 Message 类 为以下值之一的项:
      • Ipm。Note.Rules.ExternalOofTemplate.Microsoft
      • Ipm。Note.Rules.OofTemplate.Microsoft

例如,请考虑以下屏幕截图:

可删除的 OOF 规则的屏幕截图。

  • 右键单击属于这两个邮件类之一的项,然后选择“ 删除邮件”。

    注意

    请勿删除任何项目,但引用的项除外。

    可删除的 OOF 规则的屏幕截图。

  • “删除项目”对话框中,选择“删除样式”下的“永久删除传递DELETE_HARD_DELETE (不可恢复) ”,然后选择“确定”。

    选择“删除样式”下的“永久删除传递DELETE_HARD_DELETE (不可恢复) ”选项。

  • 使用以下命令禁用并重新启用 OOF 功能:

    Set-MailboxAutoReplyConfiguration \<identity> -AutoReplyState Disabled
    Set-MailboxAutoReplyConfiguration \<identity> -AutoReplyState Enabled

  • 检查 OOF 功能是否按预期工作,并且症状不再出现。

解决方法 3

如果不再返回 OOF 回复,则可能超出了规则配额。 因此,无法创建内部和外部 OOF 规则。 若要解决此问题,请按照下列步骤操作:

  1. 增加规则配额。 为此,请按照以下文章中的步骤操作:

    用户无法在 Outlook 或 Outlook Web App 中创建新规则

  2. 由于在信息存储中缓存配额信息,更新后的配额值可能需要长达两个小时才能生效。

  3. 重复解决方法 2。

解决方法 4

如果远程域的 AllowedOFFType 值为 None,则 OOF 消息不会在外部触发。 此值必须设置为 External 才能允许外部 OOF。 默认情况下,此值设置为 “无”。 请记住,搜索远程域时,默认值将被特定条目重写。 因此,如果用户正在向用户 @contoso.com 发送,并且远程域设置中有一个 Contoso.com 条目,则 AllowedOOFType 值将用于该特定条目。 如果没有 条目 Contoso.com,则使用默认 (*) 远程域。

Get-RemoteDomain | select Name,AllowedOOFType