RSS 源未列出,或者无法在 Internet Explorer 中订阅 RSS 源

警告

已停用、不受支持的 Internet Explorer 11 桌面应用程序在某些版本的 Windows 10 上已通过 Microsoft Edge 更新永久禁用。 有关详细信息,请参阅 Internet Explorer 11 桌面应用停用常见问题解答

本文提供了解决 Internet Explorer 中简易信息聚合 (RSS) 源未列出或无法订阅问题的步骤。

原始产品版本: Internet Explorer
原始 KB 数: 926448

现象

在 Internet Explorer 中,你可以订阅 RSS 源。 然后,可能会遇到以下一个或多个问题:

  • 你订阅的 RSS 源未在 Internet Explorer 中列出。
  • 无法在 Internet Explorer 中订阅 RSS 源。

原因

出于以下原因之一,可能会出现这些问题:

  • 源存储文件已损坏。
  • 用户资料出现了问题。
  • 浏览器加载项存在问题。
  • 尝试订阅源时,代理服务器可能会重定向表单验证页面。

决议

要解决订阅源缺失或在尝试订阅新源时遇到的问题,请执行以下步骤:

  1. 启动 Internet Explorer。

  2. 从另一个受信任的网站添加信息流。

  3. 以其他用户身份登录并测试信息流。 如果问题得到解决,可以使用新的用户配置文件以处理 RSS 源。

  4. 如果问题仍然存在,请在 Internet Explorer(无加载项)模式下进行测试。 为此,请按照下列步骤进行操作:

    1. 单击“开始”,指向“所有程序”,指向“附件”,然后指向“系统工具”。
    2. 单击 Internet Explorer(无加载项)。

    注意

    如果此问题在此模式下得到解决,请使用“工具”菜单中可用的“管理加载项选项来隔离导致该问题的特定浏览器加载项。

  5. 如果问题仍然存在,请删除并重新导入 RSS 源。 为此,请按照下列步骤进行操作:

    1. 将计算机上的源导出到文件。 有关如何导出 RSS 源的详细信息,请参阅 “如何导入或导出 RSS 源 ”部分。

    2. 关闭 Internet Explorer。

    3. 要删除 RSS 源,请从以下文件夹中删除文件:
      %userprofile% \Local Settings\Application Data\Microsoft\Feeds

    4. 打开 Internet Explorer,然后从受信任的网站添加一个订阅源。

    5. 验证受信任的网站的 RSS 源是否正常工作。

    6. 从本部分第 5a 步导出的文件中导入数据流。 您之前订阅的订阅源如下。 有关如何导入 RSS 源的详细信息,请参阅 “如何导入或导出 RSS 源 ”部分。

  6. 如果您确定代理服务器正在重定向表单身份验证页面,您可以更改代理设置以获取推送信息。

    注意

    Internet Explorer 的 RSS 订阅源功能不支持用于源请求的表单身份验证页面。

如何导入或导出 RSS 源

若要在 Internet Explorer 中导出或导入 RSS 源,请执行以下步骤:

  1. “文件 ”菜单上,单击“导入”和“ 导出”。

  2. 在“导入/导出向导”中,单击“ 下一步”。

  3. 在“选择要执行列表的操作”中,根据需要单击“导出源”或“导入源”,然后单击“下一步”。

  4. 按照导入/导出向导中的步骤将源导入或导出到文件。