从 Internet Explorer 9 及更高版本中的安全网站下载文件时出现“无法下载”错误

警告

已停用、不受支持的 Internet Explorer 11 桌面应用程序在某些版本的 Windows 10 上已通过 Microsoft Edge 更新永久禁用。 有关详细信息,请参阅 Internet Explorer 11 桌面应用停用常见问题解答

本文提供有关解决 尝试使用 Internet Explorer 9 或更高版本下载文件时出现的“无法下载 ”错误的信息。

原始产品版本: Internet Explorer 9 及更高版本
原始 KB 数: 2549423

现象

使用 Internet Explorer 9 或更高版本通过 HTTPS(安全站点)连接到站点时,无法从网站下载文件或查看文件。 例如,访问安全网站(如银行或其他金融机构),并尝试下载或查看 PDF 文件。 该文件未显示在 Internet Explorer 中,你可能会看到如下所示的错误消息:

错误消息 1

Internet Explorer 无法下载

错误消息 2

<无法下载文件名>

如果选择了 Internet Explorer 中的 “未将加密页面保存到磁盘 ”选项,则会出现此问题。

注意

对于 Internet Explorer 8,使用 HTTPS URL 打开 Office 文档或 PDF 文件时,请参阅“Internet Explorer 无法下载”错误消息。

原因

若要下载文件,Internet Explorer 必须创建缓存或临时文件。 在 Internet Explorer 9 或更高版本中,如果文件通过 HTTPS 传递,并且将任何响应标头设置为防止缓存,并且 设置了“不将加密页保存到磁盘 ”选项,则不会创建缓存文件。 因此,下载失败。

解决方法 - 方法 1

若要解决此问题,请先尝试方法 1。 如果方法 1 失败,请转到方法 2。

  1. Internet Explorer 9 或更高版本中的“工具 ”菜单上,单击“ Internet 选项”,然后单击“ 高级 ”选项卡。
  2. 单击以取消选中位于安全区域内的不将加密页保存到磁盘复选框,然后单击确定。 (这是默认的 Internet Explorer 设置。

Internet 选项窗口的屏幕截图。在“安全性”下,清除“不要将加密页保存到磁盘”复选框。

解决方法 - 方法 2

  1. 启动“注册表编辑器”。

  2. 对于每个用户的设置,请找到以下注册表项:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

    对于每台计算机的设置,请找到以下注册表项:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

  3. “编辑”菜单上,单击“添加值,然后添加以下值:
    BypassSSLNoCacheCheck=Dword:00000001

  4. 退出注册表编辑器。