单击 Internet Explorer 中的链接时不会发生任何情况

警告

已停用、不受支持的 Internet Explorer 11 桌面应用程序在某些版本的 Windows 10 上已通过 Microsoft Edge 更新永久禁用。 有关详细信息,请参阅 Internet Explorer 11 桌面应用停用常见问题解答

本文有助于解决在 Internet Explorer 中单击超链接时无法打开网页的问题。

原始产品版本: Internet Explorer 9
原始 KB 数: 175775

现象

在网页或电子邮件中单击超链接时,不会发生任何情况。 Internet Explorer 不会打开网页。

注意

此信息适用于 Internet Explorer 9、Internet Explorer 8 和 Internet Explorer 7。

原因

以下一个或多个原因可能会导致出现此问题:

  • 选择要使用的 Web 浏览器的设置已损坏。 这可能会导致 Windows 曲解将哪个浏览器设置为计算机上的默认浏览器。
  • 安装软件后,设置被更改,这可能会导致网页链接无法正常工作。
  • 以前安装的浏览器或加载项可能会干扰计算机上的其他软件。
  • 注册表项已更改或损坏。

解决方法

本部分面向初级到中级计算机用户。 如果这些方法无法解决问题,则可以尝试“高级疑难解答”部分中的方法。 要解决此问题,请按出现的顺序使用下列方法。

方法 1:检查默认 Web 浏览器设置

在 Microsoft Windows 中,可以选择要使用的 Web 浏览器。 要将 Internet Explorer 设置为默认 Web 浏览器,请按照以下步骤操作:

  1. 要打开 Internet Explorer,单击“开始”,然后单击“Internet Explorer”
  2. 如果系统提示确认将 Internet Explorer 设为默认浏览器,请单击“是”
  3. 在“工具”菜单上,单击“Internet 选项”
  4. 单击“程序”>“设为默认浏览器”>“确定”,然后关闭 Internet Explorer。

注意

更改将在下次启动 Internet Explorer 时生效。

检查问题是否已解决。 如果问题已解决,则不用再往下看了。 如果问题未解决,请尝试下一个方法。

方法 2:更改 Internet Explorer 默认打开的文件类型

对于 Windows 7 和 Windows Vista。

  1. 关闭所有 Internet Explorer 窗口。
  2. 单击「开始」,然后单击“控制面板”
  3. 单击“程序”,然后单击“设置默认程序”
  4. 在“程序”菜单上,单击“Internet Explorer”,然后单击“选择此程序的默认值”
  5. 确保选中 .htm.htmlurls 复选框,然后单击“保存”
  6. 单击 “确定” 。

注意

更改将在下次启动 Internet Explorer 时生效。

用于 Windows XP

  1. 要打开 Windows 资源管理器,右键单击“开始”,然后单击“我的计算机”

  2. 在“工具”菜单上,单击“文件夹选项”,然后单击“文件类型”选项卡。

  3. 找到并选择 HTM 文件类型。

  4. 确保将 Internet Explorer 选择为“使用程序打开”。 如果未选择 Internet Explorer,请单击“更改”,将“Internet Explorer”选择作为“建议的程序”,然后单击“确定”

  5. 对以下文件类型重复步骤 3 和 4:

    • HTML
    • ITS
    • MHT
    • MTHML
    • XML
    • XSL

检查问题是否已解决。 如果问题已解决,则不用再往下看了。 如果问题未解决,请转到下一种方法。

方法 3:使用 Internet Explorer 无加载项模式

尽管加载项可以改善在线体验,但它们有时可能会对计算机上其他软件造成干扰或冲突。 但请注意,如果禁用某个加载项,某些网页或 Internet Explorer 本身可能无法正确显示。 首先,在暂时禁用加载项的情况下启动 Internet Explorer,查看问题是否已解决。 (仅在以通常方式重启 Internet Explorer 之后,加载项才会被禁用)。 为此,请按照下列步骤进行操作:

  • 单击“开始”,在“搜索”框中键入 Internet Explorer,然后单击“Internet Explorer”(无加载项)。

    注意

    对于 Windows XP,单击“开始”,右键单击“Internet Explorer”图标,然后单击“在没有加载项的情况下浏览”

如果 Internet Explorer 无加载项模式解决了问题,请按照以下步骤确定导致问题的浏览器加载项:

  1. 要启动 Internet Explorer,单击“开始”,然后单击“Internet Explorer”
  2. 单击“工具”按钮,然后单击“管理加载项”
  3. 单击“名称”列表中的“加载项” ,然后单击“禁用”。 测试 Internet Explorer。
  4. 重复步骤 3,直到确定导致问题的加载项。

检查问题是否已解决。 如果问题已解决,则不用再往下看了。 如果问题未解决,请尝试下一个方法。

方法 4:重置 Internet Explorer 设置

如果问题是由损坏或不兼容的 Internet Explorer 设置或加载项引起的,通常可以通过将 Internet Explorer 设置重置为默认设置来解决此问题。

重置 Internet Explorer 设置时,所有以前的设置都将丢失,且无法恢复。 还原 Internet Explorer 默认设置时,某些依赖于存储的 cookie、表单数据、密码或以前安装的浏览器加载项的网页可能无法正常工作。 但是,将 Internet Explorer 重置为默认设置不会删除收藏夹、源和其他一些个人设置。

要重置 Internet Explorer 设置,请按照下列步骤操作:

  1. 关闭所有 Internet Explorer 窗口。

  2. 单击“开始”,在“搜索”框中键入“inetcpl.cpl”,然后单击“程序”列表中的“inetcpl.cpl”。 将显示“Internet 选项”对话框。

    注意

    对于 Windows XP,依次单击“开始”、“运行”,在“打开”框中键入“inetcpl.cpl”,然后单击“确定”

  3. 单击“高级” 选项卡。

  4. 在“重置 Internet Explorer 设置”下,单击“重置”。 然后,再次单击“重置”

  5. Internet Explorer 完成重置后,单击“重置 Internet Explorer 设置”对话框中的“关闭”

  6. 再次启动 Internet Explorer。 更改将在下次打开 Internet Explorer 时生效。

方法 5:重新注册必要的 Internet Explorer DLL 文件

注意

此信息适用于 Windows XP

要重新注册 DLL 文件,请按照下列步骤操作:

  1. 依次单击“开始”、“所有程序”、“附件”,右键单击“cmd”,然后选择“以管理员身份运行”。 如果系统提示你输入管理员密码或进行确认,请输入密码或进行确认。

  2. 在“打开”框中键入“regsvr32 urlmon.dll”,然后单击“确定”

  3. 收到确认信息后单击“确定”

  4. 对以下命令重复步骤 2 和 3:

    • regsvr32 mshtml.dll
    • regsvr32 shdocvw.dll
    • regsvr32 browseui.dll
    • regsvr32 msjava.dll

检查问题是否已解决。 如果问题已解决,则不用再往下看了。 如果问题未修复,请转到下一部分。

高级故障排除

本部分面向更高级的计算机用户。

方法 1:新建用户帐户

有关用户配置文件的更多信息,请参阅关于用户配置文件

有关方法的详细信息,请转到以下 Microsoft 网站:

方法 2:使用系统还原

系统还原使用还原点将系统文件和设置返回到更早的时间点,而不会影响个人文件。 还原点每周都会在发生重大系统事件之前自动创建,例如安装程序、设备或驱动程序。

在启动系统还原之前,请保存任何打开的文件并关闭所有程序。 确认还原点后,系统还原会重启计算机。 要执行系统还原,请按照下列步骤操作:

对于 Windows 7 和 Windows Vista

  1. 依次单击“开始”、“所有程序”、“附件”、“系统工具”和“系统还原”。 如果系统提示你输入管理员密码或进行确认,请输入密码或进行确认。

  2. 单击“系统还原”页上的“下一步”

  3. 选择所需的“系统还原日期”或“说明”

    注意

    如果未看到你要查找的特定日期,请选择“显示更多日期”,然后选择所需的日期。

  4. 在确认窗口中,单击“完成”。 计算机将重启。 完成此过程后,你将收到一条确认消息。

用于 Windows XP

  1. 使用拥有管理员权限的帐户登录到 Windows。
  2. 依次单击“开始”、“所有程序”、“附件”、“系统工具”和“系统还原”
  3. 在“欢迎使用系统还原”页上,选择“将我的计算机还原到更早的时间”选项,然后单击“下一步”
  4. 在“选择还原点”页上,单击此列表中最新的系统还原点,单击“还原点”列表,然后单击“下一步”
  5. 在“确认还原点选择”页上,单击“下一步”。 “系统还原”将还原以前的 Windows XP 配置,然后重启计算机。
  6. 以管理员身份登录计算机。 然后,在系统还原页面的“还原完成”页面上单击“确定”。 计算机将重启。 完成此过程后,你将收到一条确认消息。

如果使用系统还原,但问题仍然存在,或出现其他问题,则可以撤消还原操作。 撤消操作后,可以尝试使用其他还原点。 若要撤消系统还原操作,请执行以下步骤:

  1. 依次单击“开始”、“所有程序”、“附件”、“系统工具”和“系统还原”
  2. 单击“撤消系统还原”,然后单击“下一步”
  3. 查看你的选择,然后单击“完成”

计算机将重启。 完成此过程后,你将收到确认。

其他资源

检查问题是否已解决。 如果问题已解决,则不用再往下看了。 如果问题没有得到解决,你还可以使用 Microsoft 客户支持服务来查找其他解决方案。 Microsoft 支持服务包括以下方法: