由于 TokenLifetime 的长度,Microsoft Dynamics CRM 适用于手机和平板电脑版本无法连接到 Dynamics CRM 组织。

本文提供了解决 Microsoft Dynamics CRM 手机和平板电脑因TokenLifetime属性长度问题无法连接到 Dynamics CRM 组织的方法。

适用于: Microsoft Dynamics CRM 2013,Microsoft Dynamics CRM 2013 Service Pack 1
原始 KB 数: 3034570

现象

尝试在任何 Microsoft Dynamics CRM 移动客户端应用程序中设置 Microsoft Dynamics CRM 组织时,身份验证将进入永无止境的循环,其中应用程序似乎尝试执行某些身份验证,但未完成。

原因

在 AD FS 中,信赖方的 TokenLifetime 属性大于默认值可能会导致此身份验证循环。

解决方法

建议的值 TokenLifetime 应设置为默认值 0,这意味着 600 分钟或 10 小时。 改用联合身份验证服务中的 SSOLifetime 选项可以防止用户在这些 Microsoft Dynamics CRM 移动应用程序中经常引入其凭据。 SSOLifetime 的默认值为 480 分钟或 8 小时。

详细信息

如何更改 ADFS 的 SSO Lifetime 属性,请参阅 Set-ADFSProperties

如何通过 PowerShell 更改 TokenLifetime ADFS 信赖方的属性,请参阅基于声明的身份验证和安全令牌过期。