由于 TokenLifetime 的长度,手机和平板电脑Microsoft Dynamics CRM无法连接到 Dynamics CRM 组织
本文解决了手机和平板电脑Microsoft Dynamics CRM由于 属性长度TokenLifetime
而无法连接到 Dynamics CRM 组织的问题。
适用于:Microsoft Dynamics CRM 2013、Microsoft Dynamics CRM 2013 Service Pack 1
原始 KB 编号: 3034570
症状
尝试在任何Microsoft Dynamics CRM移动客户端应用程序中设置Microsoft Dynamics CRM组织时,身份验证会进入一个永无止境的循环,其中应用程序似乎正在尝试执行某些身份验证,但未完成。
原因
大于信赖方 AD FS 中 属性的默认值 TokenLifetime
可能会导致此身份验证循环。
解决方案
建议的 TokenLifetime
值应设置为默认值 0,这意味着 600 分钟或 10 小时。 改为在联合身份验证服务中使用 SSOLifetime 选项可以防止用户过于频繁地在这些Microsoft Dynamics CRM移动应用程序中引入其凭据。 SSOLifetime 的默认值为 480 分钟或 8 小时。
更多信息
如何更改 ADFS 的 SSO Lifetime
属性,请参阅 Set-ADFSProperties。
如何通过 PowerShell 更改 TokenLifetime
ADFS 信赖方的属性,请参阅 基于声明的身份验证和安全令牌过期。