Microsoft Dynamics CRM 预览/窗体区域在 Outlook 中不显示任何数据

本文提供了一个解决方案,针对在窗口底部的 Microsoft Dynamics CRM 预览/窗体区域中不显示任何信息的问题。

适用于: Microsoft Dynamics CRM
原始 KB 数: 2617456

现象

使用 Microsoft 办公室 Outlook 时,并且安装了适用于 Outlook 的 Microsoft Dynamics CRM 客户端,窗口底部的 Microsoft Dynamics CRM 预览/窗体区域不会显示任何信息。

原因

此问题可能是由以下条件之一引起的。

原因 1

早期版本的Microsoft 办公室留下了对旧对象库 (OLB) 文件的引用。 这通常包括主互操作程序集的早期版本。

原因 2

用户配置文件临时目录包含超过 65,535 个文件。 Outlook 将临时文件用于存储窗体区域。 但是,如果用户的临时目录包含超过 65,535 个文件,Outlook 无法初始化窗体区域。

原因 1 的解决方法

重要

此部分(或称方法或任务)介绍了修改注册表的步骤。 但是,注册表修改不当可能会出现严重问题。 因此,按以下步骤操作时请务必谨慎。 作为额外保护措施,请在修改注册表之前先将其备份。 如果之后出现问题,您就可以还原注册表。 有关如何备份和还原注册表的详细信息,请参阅:如何备份和还原 Windows 中的注册表

  1. 依次选择“开始”、“所有程序”、“附件”,然后选择“运行”

  2. “运行 ”对话框中,输入 regedit,然后选择“ 确定”。

  3. 在注册表编辑器中,找到以下注册表节点:

    HKEY_CLASSES_ROOT\TypeLib\{00062FFF-0000-0000-C000-000000000046}\9.3

  4. 找到 PrimaryInteropAssemblyName 字符串值,然后确定版本,如以下示例中的加粗元素所示:

    PrimaryInteropAssemblyName“=”Microsoft.Office.Interop.Outlook,Version =12.0.0.0,Culture=neutral,PublicKeyToken=71E9BCE111E9429C

如果版本为 12.0.0.0,则必须删除 9.3 文件夹树,这对应于 2007 Microsoft Office 系统。

原因 2 的解决方法

  1. 依次选择“开始”、“所有程序”、“附件”,然后选择“运行”
  2. “运行 ”对话框中,输入 %localappdata%,然后选择“ 确定”。
  3. 打开 Temp 文件夹。
  4. 删除以 .. 开头 Olk的任何.tmp文件。