无法收到邮箱的电子邮件,因为关联的用户没有有效的 Microsoft Dynamics 365 许可证

本文为您提供解决方法,当您在 Microsoft Dynamics 365 中尝试测试和启用邮箱时出现“无法接收邮箱电子邮件”错误,这是因为关联用户没有有效的 Microsoft Dynamics 365 许可证。

适用于: Microsoft Dynamics CRM
原始 KB 数: 4053825

现象

尝试在 Microsoft dynamics 365 中测试和启用邮箱时,将记录以下警报之一:

无法收到邮箱邮箱 <名称> 的电子邮件,因为关联的用户没有有效的Microsoft Dynamics 365 许可证。 邮箱未同步。 有关此信息的通知已张贴在电子邮件服务器配置文件类型为 Microsoft Exchange Online 的所有者的警报墙上。
电子邮件服务器错误代码:IncomingEmailNoLicenseAssigned

无法为邮箱“测试邮件”发送电子邮件,因为关联用户没有有效的Microsoft Dynamics 365 许可证。 邮箱未同步。 有关此信息的通知将发布到电子邮件服务器配置文件所有者的警报墙上。
电子邮件服务器错误代码:OutgoingEmailNoLicenseAssigned

原因

用户没有分配Microsoft Dynamics 365 许可证,或者拥有用户的访问权限模式设置为“管理”。

决议

验证用户是否具有 Microsoft Dynamics 365 许可证

向用户分配Microsoft Dynamics 365 许可证。 请参阅“创建用户并分配安全角色”一文的“将许可证添加到用户帐户”部分。

注意

将 Microsoft Dynamics 365 许可证分配给用户后,此更改可能需要几分钟时间才能从 Office 365 同步到 Microsoft Dynamics 365。

验证用户是否未处于管理访问模式

  1. 以具有系统管理员角色的用户身份登录到 Microsoft Dynamics 365 组织。
  2. 导航到 “设置” ,然后选择“ 电子邮件配置”。
  3. 选择邮箱
  4. 将所选视图从“我的活动邮箱”更改为 “活动邮箱”。
  5. 打开用户的邮箱记录。
  6. 选择在“ 所有者 ”字段中选择的用户以打开用户记录。
  7. 展开“ 管理 ”选项卡。
  8. 验证访问模式是否设置为“读写”。

再次测试和启用邮箱

  1. 打开邮箱记录(如果尚未打开)。
  2. 选择“测试和启用邮箱”按钮。
  3. 等待“测试和启用”进程完成。 如果测试结果不成功,请查看 邮箱记录中的“警报 ”区域。