Outlook 的自动发现(AutoDiscover)功能出现故障,错误代码为 0x80004005(适用于 Outlook 2013)或 0x8004010F(适用于 Outlook 2010)

原始 KB 数: 2785498

症状

Microsoft Outlook 未能自动成功配置账户。 当您使用测试电子邮件自动配置工具时,您会在“日志”选项卡上看到类似以下的输出:

  • Outlook 2013

本地自动发现服务正在启动:Contoso.com
Contoso.com 的本地自动发现失败 (0x8004005)

  • Outlook 2010

本地自动发现服务正在启动:Contoso.com
本地自动发现 Contoso.com 失败 (0x8004010F)

原因

可能发生此问题的原因是以下注册表子项存在但为空:

HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\AutoDiscover\Boot

注意

在此子项中,x.0 在 Outlook 2013 中为 15.0,在 Outlook 2010 中为 14.0。

决议

重要

此部分、方法或任务包含指导您如何修改注册表的步骤。 如果您错误地修改注册表,可能会出现严重问题。 因此,请确保仔细遵循这些步骤。 为了增加保护,在修改注册表之前,请备份注册表。 然后,如果出现问题,您可以恢复注册表。 有关如何备份和恢复注册表的更多信息,请参见如何在 Windows 中备份和恢复注册表

请按照以下步骤删除\Boot子项:

  1. 如果 Outlook 正在运行,请退出。

  2. 选择开始,然后选择运行。 将 regedit 命令复制并粘贴(或输入)到 打开 框中,然后按 Enter。

  3. 找到以下注册表位置:

    HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\AutoDiscover\Boot

    注意

    在此子项中,x.0 在 Outlook 2013 中为 15.0,在 Outlook 2010 中为 14.0。

    如果注册表项存在,请按照以下步骤将其删除:

    1. 选择以下注册表子项:HKEY_CURRENT_USER\Software\Microsoft\Office\c.0\Outlook\AutoDiscover\Boot

      注意

      在此子项中,x.0 在 Outlook 2013 中为 15.0,在 Outlook 2010 中为 14.0。

    2. “编辑” 菜单上,选择“ 删除”。

    3. 当出现提示要求确认删除时,选择

    4. 退出注册表编辑器。

    5. 启动 Outlook。

更多信息

使用“测试电子邮件自动配置工具”来帮助确定为什么在 Outlook 中 AutoDiscover 失败。 为此,请执行以下步骤:

  1. 启动 Outlook。
  2. 按住 Ctrl 键,右键单击通知区域中的 Outlook 图标,然后选择“ 测试电子邮件自动配置”。
  3. 请核实电子邮件地址框中是否是正确的邮箱地址。
  4. “测试电子邮件自动配置 ”窗口中,清除“ 使用猜测市场 ”复选框和 “安全猜测市场身份验证 ”复选框。
  5. 选择使用自动发现复选框,然后选择测试

注意

在某些情况下,客户报告称,AppSense 软件会在特定条件下重新创建 \Boot 注册表子项。 然而,这不一定会发生。 如果在虚拟环境中使用 AppSense 软件,并且管理员认为该软件可能导致重新创建\Boot注册表子项,管理员应联系 AppSense 寻求支持。

第三方联系免责声明

微软提供第三方联系信息,帮助您找到关于此主题的更多信息。 此联系信息可能会在没有通知的情况下更改。 微软不保证第三方联系信息的准确性。