OneDrive 或 SharePoint 中的“错误:找不到 404 文件/页面”

症状

尝试访问 Microsoft SharePoint 或 OneDrive 中的网站、文件或组时,会收到以下错误消息:

错误 404:找不到文件/页

原因

发生此错误的原因是站点、文件或组已重命名、移动或删除。

解决方案

如果找不到要查找的内容,请与 SharePoint 管理员检查。 有关详细信息,请参阅如何实现查找我的 Microsoft 365 管理员?

管理员的操作

尝试使用以下方法查找站点或文件:

还原已删除的主页

如果删除了网站主页,请执行以下步骤:

  1. 通过将以下 URL 粘贴到浏览器中,浏览到网站回收站: https://<tenantname>.sharepoint.com/sites/<sitename>/_layouts/15/RecycleBin.aspx?view=5

    重要提示:在路径中,将 tenantname 替换为组织的名称,将 sitename 替换为缺少主页的网站的名称。

    注意: 页面的默认名称为 Home.aspx。 但是,如果已替换默认主页,则可能有所不同。

  2. 突出显示文件,然后选择“ 还原”。

如果在回收站中找不到该文件,则它可能已移动到 第二阶段回收站

  1. 应看到 “找不到要查找的内容?检查回收站 页面底部的第二阶段回收站。 选择“ 第二阶段回收站”。
  2. 突出显示文件,然后选择“ 还原”。

如果在第二阶段回收站中找不到该页面,则表示它已被永久删除。

对于可能已删除的文件或其他页面,请参阅 还原从 SharePoint 或 Teams 中删除的回收站中的项目

有关详细信息,请参阅以下页面:


检查站点是否已删除

对于 SharePoint

站点可能已被删除。 如果是这样,请从新的 SharePoint 管理中心还原已删除的网站。

  1. 转到已删除网站页面。
  2. 选择要还原的站点。
  3. 选择 “还原”。

重要提示:如果已删除的网站是根 (顶级) SharePoint 网站,则必须首先还原网站,然后使用 替换根网站中的步骤替换它。

对于 OneDrive

有关详细信息,请参阅 还原已删除的 OneDrive


检查站点是否已重定向

如果用户尝试从已保存的站点 URL 或指向特定网站 URL 的链接访问网站,则可能是网站 URL 已更改,或者网站已被移动或删除。

如果网站 URL 已更改,则应已创建网站重定向页面。 有关详细信息,请参阅 管理站点重定向

重要提示:

  • 如果使用删除 重定向中的步骤删除了站点,则可能会出现“404”错误。
  • 若要确定哪些网站具有新 URL,请参阅 管理网站重定向的“获取所有重定向的列表”部分。

如果网站已删除,可以从 SharePoint 管理中心还原它。 有关详细信息,请参阅 还原已删除的网站