来自共享事件的电子邮件通知不会传送给收件人

现象

在某些操作触发电子邮件通知的情况下,邮件不会传递到预期收件人。

此类方案的示例包括以下情况:

  • 在 Microsoft SharePoint 中共享文档或文件夹
  • 在 OneDrive 中共享文件或文件夹
  • 在 Microsoft 365 应用中共享文档或协作处理文件
  • 在 Microsoft Planner 中分配任务
  • 在 Microsoft Viva Connections 中发布新闻或评论新闻项目

原因

此问题可能是由以下条件之一引起的:

  • Microsoft Entra ID 中的用户配置文件没有分配给 Email 属性的值。
  • 你的电子邮件地址被收件人的电子邮件提供商标记为垃圾邮件。

解决方法

要求收件人检查其垃圾邮件文件夹。 如果电子邮件地址被垃圾邮件筛选器阻止,则收件人应 将电子邮件地址添加到“安全发件人”列表中 ,以避免将来出现问题。

如果电子邮件通知不在“垃圾邮件”文件夹中,则你的电子邮件地址未在用户配置文件中指定。 在 Microsoft Entra 中分配用户管理员角色或 Microsoft 365 中的用户管理员角色的用户必须使用以下方法之一将 值分配给用户配置文件中的电子邮件 属性。

方法 1:从 Microsoft Entra 管理中心更新

  1. 以Microsoft Entra 中的用户管理员身份登录到 Microsoft Entra 管理中心

  2. 导航到“标识>用户>所有用户”。

  3. 选择受影响的用户。

  4. 验证用户类型是否已设置为成员

    注意:如果将“用户类型”属性设置为“来宾”,请选择“编辑属性”,将“用户类型”设置为“成员”,然后选择“保存”。

  5. 选择“ 编辑属性”,选择 “联系人信息 ”选项卡,将 “电子邮件 ”属性更新为正确的电子邮件地址,然后选择“ 保存”。

方法 2:从Microsoft 365 管理中心更新

  1. 以 Microsoft 365 中的用户管理员身份登录到Microsoft 365 管理中心。
  2. 导航到“用户活动用户>”。
  3. 选择受影响的用户。
  4. “帐户”选项卡上的“用户名和电子邮件”下,选择“管理用户名和电子邮件”。
  5. 在“主电子邮件地址和用户名”下,选择“编辑”图标,在“用户名”字段中输入正确的用户名,从“域”中选择正确的域,选择“完成,然后选择“保存更改”。