OneDrive 同步错误“抱歉,OneDrive 无法立即添加文件夹”

症状

尝试同步 OneDrive 或 SharePoint 团队网站时,会出现以下错误:

很抱歉,OneDrive 现在无法添加你的文件夹。

原因

以下是导致此错误的一些可能原因:

  • 库上启用了“ 需要签出 ”选项。

  • 库有 “必需”列 条目。

  • “草稿项目安全性”选项设置为“仅限可编辑项目的用户”

  • 使用 OneDrive 的外部或来宾帐户进行同步。

解决方案

若要解决此问题,请根据适当的原因使用解决方法。

将“需要签出”更改为“否”

  1. 在库的“经典”视图中,选择“设置 (齿轮) ”图标,然后打开功能区 ((如果尚未) )。

  2. 选择“ ”选项卡。

  3. 选择 “库设置”,然后选择“ 版本控制设置”。

  4. “需要签出”“是” 更改为 “否”。

删除任何必需的列

  1. 转到 “库设置”。

  2. 在“必需”下检查每列是否有检查标记。

  3. 对于具有检查标记的任何列,请将“需要此列包含信息”值更改为“否”。

确保“草稿项安全性”设置为“可以读取项目的任何用户”

  1. 转到 “库设置”。

  2. 选择“ 版本控制设置”。

  3. “草稿项安全性 ”设置为 “可以读取项目的任何用户”。

使用内部帐户同步内容

不支持使用来宾或外部帐户同步内容。 请改用组织内部的帐户。

有关详细信息,请参阅 OneDrive 和 SharePoint 中的限制和限制下的“具有特定列或元数据的库”部分。