登录到 OneDrive 时出现错误0x8004de85或0x8004de8a

症状

尝试登录到 Microsoft OneDrive 时,无法登录,并且收到错误代码0x8004de85或0x8004de8a。

原因

如果问题正在影响 OneDrive 帐户(例如缺少帐户),或者尝试使用工作或学校帐户的凭据登录到个人 Microsoft 帐户,则可能会出现此问题 (,反之亦然,) 。

若要解决此问题,请尝试以下解决方案。

解决方案 1:确保使用正确的 OneDrive 帐户

登录到 个人 Microsoft 帐户Microsoft 365 帐户 ,验证是否存在身份验证问题。 然后,按照以下步骤检查 OneDrive 帐户:

  1. 选择任务栏通知区域中的 OneDrive 图标 ( ) 。

    注意

    可能需要选择通知区域旁边的 “显示隐藏图标” 箭头 ( ) 才能看到 OneDrive 图标。 如果未显示该图标,则表示 OneDrive 可能未运行。 若要启动 OneDrive,请选择“ 开始”,在搜索框中键入 “OneDrive ”,然后在搜索结果中选择“ OneDrive ”。

  2. 选择“ 帮助 & 设置 ( ) ”,然后选择“ 设置”。

    OneDrive 窗口的屏幕截图,其中突出显示了设置图标和设置。

  3. 在“ 帐户 ”选项卡上,确保显示正确的或预期的帐户。 否则,请使用正确的帐户登录到 OneDrive。

解决方案 2:重置 OneDrive

若要重置OneDrive 同步应用,请执行以下步骤:

  1. 在任务栏通知区域中,右键单击 OneDrive 图标 ( ) 。
  2. 选择“ 帮助 & 设置 ( ) ”,然后选择“ 退出 OneDrive”。
  3. 选择 “开始” 图标,输入 cmd,在搜索结果中右键单击“ 命令提示符 ”,然后选择“ 以管理员身份运行”。
  4. 运行 %localappdata%\Microsoft\OneDrive\onedrive.exe /reset 命令。
  5. 重启OneDrive 同步应用,并使用工作或学校帐户登录。

解决方案 3:确保帐户分配有有效的许可证

根据组织为用户购买 OneDrive 的方式,你可能不再拥有分配的 OneDrive 许可证,或者许可证可能已过期。

注意 以下步骤必须由组织的 Microsoft 365 管理员完成。

  1. Microsoft 365 管理中心,选择“用户>”“活动用户”。
  2. 选择遇到此问题的用户。
  3. 在用户窗格中,选择“ 许可证和应用”。
  4. 展开“许可证”部分,确保向用户分配了OneDrive for Business许可证。

注意

如果多个用户遇到此问题,订阅可能已过期。 若要检查订阅状态,请打开Microsoft 365 管理中心,然后选择“计费>产品”。