登录到 OneDrive 同步 应用时出现错误AADSTS50020

症状

无法登录到 Microsoft OneDrive 同步 应用,并收到以下错误消息:

AADSTS50020标识提供者的用户帐户不存在于租户中,并且无法访问应用程序 (OneDrive SyncEngine) 。

原因

此问题可能是由来自上一个租户的缓存标识引起的。 它最常发生在租户到租户迁移期间。

有关其他潜在原因的详细信息,请参阅 错误AADSTS50020 - 租户中不存在标识提供者的用户帐户

解决方案

若要解决此问题,请从注册表中删除缓存的 Microsoft Office 帐户标识。

重要

请仔细遵循本部分中的步骤进行操作。 对注册表修改不当可能会导致严重问题。 修改之前,备份注册表以便在发生问题时进行还原

  1. 启动注册表编辑器。

  2. 找到以下注册表项:

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Common\Identity

  3. 右键单击“ 标识”,然后选择“ 删除”。

注意: 如果已启用 共享计算机激活 ,则还要从 HKEY_USERS\<The user SID>\SOFTWARE\Microsoft\Office\16.0\Common中删除标识注册表项。 若要获取当前已登录用户的 SID,请在 whoami /user 命令提示符窗口中运行 命令。 如果问题仍然存在,请在手动清除以前的激活信息中展开“A 部分:删除 Office 许可证 & 缓存的帐户”,然后按照第 1 部分:删除以前的 Office 激活和第 3 部分:删除 Windows 凭据管理器中存储的 Office 凭据中的步骤进行操作。

如果仍然遇到此问题,请执行以下步骤:

  1. 注销OneDrive for Business。 

  2. 删除以下位置中的所有文件夹:

    • %localappdata%/Microsoft/OneAuth
    • %localappdata%/Microsoft/IdentityCache