症状
在 Microsoft 365 应用中打开和编辑 Microsoft OneDrive 同步的文件,例如 Microsoft Word、Microsoft PowerPoint 或 Microsoft Excel。 尝试保存文件时,会收到以下错误消息:
上传已阻止:我们无法验证你是否具有上传文件所需的权限。
原因
如果使用无权将文件上传到 OneDrive 的帐户登录到 Microsoft 365 应用,则会出现此问题。
例如,使用该帐户将 user@fabrikam.onmicrosoft.com 文件同步到 OneDrive。 但是,你使用该 user@contoso.onmicrosoft.com 帐户登录到 Microsoft 365 应用,并且此帐户无权将文件上传到 OneDrive。 在这种情况下,尝试将文件保存到 OneDrive 时,会收到错误消息。
解决方案
若要解决此问题,请按给定的顺序尝试以下方法。 如果一种方法无法解决问题,请尝试下一种方法。
方法 1:使用相同的帐户登录到 Microsoft 365 应用和 OneDrive
选择任务栏通知区域中的 OneDrive 图标 (
) 。
选择“ 帮助 & 设置 (
) >设置”。
在“ 帐户 ”选项卡上,记下已登录帐户。
打开受影响的 Microsoft 365 应用,然后选择“ 文件>帐户”。
在 “连接的服务”下,选择“ 删除 ”以删除步骤 3 中记下的帐户以外的所有帐户。
选择 OneDrive 图标,选择 “帮助 & 设置 (
) >暂停同步”,然后选择要暂停的时间: 2 小时、 8 小时或 24 小时。
选择“ 帮助 & 设置 ” (
) >退出 OneDrive。
关闭所有 Microsoft 365 应用。
重启 OneDrive 和受影响的 Microsoft 365 应用。
请重试,将文件保存到 OneDrive。
方法 2:删除与 OneDrive 和 Microsoft 365 应用相关的凭据
打开受影响的 Microsoft 365 应用,然后选择“ 文件>帐户”。
在“ 用户信息”下,选择“ 注销 所有帐户”。
关闭所有 Microsoft 365 应用。
选择“ 开始 (
) ”,输入 凭据,然后选择“ 凭据管理器”。
选择“Windows 凭据”。
在“ 通用凭据”下,选择与 OneDrive、MicrosoftOffice16 和 MicrosoftOffice15 相关的凭据,然后选择“ 删除”。
重启 OneDrive 和受影响的 Microsoft 365 应用,然后使用同一帐户再次登录它们。
请重试,将文件保存到 OneDrive。
方法 3:取消链接并重新链接 OneDrive
此方法可以修复 OneDrive 配置问题。 有关详细步骤,请参阅 取消链接并重新链接 OneDrive。 然后,再次尝试将文件保存到 OneDrive。
方法 4:安装可用的 Windows 更新
若要检查和安装所有可用更新,请参阅更新 Windows。 安装所有更新后,重启受影响的 Microsoft 365 应用,然后重试将文件保存到 OneDrive。