Azure 虚拟机错误:“首次登录之前必须更改密码”

适用于:✔️ Windows VM

症状

使用远程桌面协议(RDP)连接连接到 Azure 虚拟机(VM)时,遇到错误:

首次登录之前,必须更改密码。 请更新密码或联系系统管理员或技术支持。

在首次登录之前,必须更改密码的远程桌面连接

原因

尝试在 RDP 连接上使用的帐户将被标记为更改第一个登录名的密码。

解决方法

重要说明 在遵循以下故障排除步骤之前,请通过创建快照来备份 VM OS 磁盘,并按照磁盘快照中的步骤操作。 如果需要还原故障排除时所做的更改,可以使用快照重新创建磁盘。

故障排除

使用此选项之前,请确保 VM 代理正在运行。 可以通过转到虚拟机、VM>设置>属性>代理状态来检查Azure 门户中的 Azure 来宾代理的状态。 如果 VM 代理运行正常,可以使用 Azure VM 的远程故障排除工具中所述的运行命令。

如果 VM 未运行代理,可以按照 Azure VM 脱机重置本地 Windows 密码中的步骤操作。 当可以连接到 VM 时,可以使用以下说明来解决需要密码重置的帐户的问题。

  1. 打开“运行命令”并输入以下命令:

    • 对于本地帐户:

      net user <USERNAME> *

    • 对于域帐户:

      net user <USERNAME> * /domain

    请注意 ,这将请求密码。 键入新密码以设置帐户。

  2. 更改密码后,应解决此问题,可以使用帐户登录到 VM。 无需重启 VM。

联系我们寻求帮助

如果你有任何疑问或需要帮助,请创建支持请求联系 Azure 社区支持。 你还可以将产品反馈提交到 Azure 反馈社区