本文为用户或管理员提供了一种解决方法,用于解决在Microsoft Dynamics 365 Field Service 中保存记录的问题,在映射提供程序面临服务降级的极少数情况下。
现象
用户无法保存记录,例如工作订单、帐户、联系人或具有更新地址信息的系统用户。
原因
此问题源自通用资源计划解决方案用于获取地址的纬度和经度信息的位置 API 中的服务降级。
解决方法
作为用户,请尝试再次保存记录,以确保它不是临时问题。
作为管理员:
若要取消阻止在发生一致失败时创建或更新记录等操作,可以暂时禁用字段服务设置中的“自动地理代码地址”设置。 重新启用设置后,用户需要手动对中断期间更新的记录进行地理编码。
注意
禁用自动地理编码不会更新具有更新地址的记录的地理编码信息。 记录可能没有位置信息或过时的纬度和经度值,这可能会影响依赖位置坐标的计划活动。 建议在禁用设置时跟踪更新的记录,以追溯方式解决数据差距问题。
如果你的组织使用直接从其任何进程调用位置 API 的自定义应用,请调整进程以停止调用它们,直到服务降级得到解决。