本文提供了在 Microsoft Dynamics 365 中尝试测试和启用邮箱时发生的错误的解决方案。
适用于: Microsoft Dynamics 365
原始 KB 数: 4463808
现象
尝试 在 Dynamics 365 中测试和启用邮箱 时,会收到以下错误:
无法收到邮箱 <邮箱名称> 的电子邮件,因为关联的电子邮件服务器配置文件 <名称> 中指定的电子邮件服务器位置或传入电子邮件端口不正确。 邮箱未同步。 已通知电子邮件服务器配置文件的所有者。
电子邮件服务器错误代码:套接字返回异常 - 无效的接收电子邮件服务器配置文件,主机未找到。
如果选择“ 详细信息”,将显示以下附加信息:
ActivityId: <GUID>
>错误:System.Net.Sockets.SocketException (0x80004005):未知此类主机
at System.Net.Dns.GetAddrInfo(字符串名称)
在 System.Net.Dns.InternalGetHostByName(String hostName, Boolean includeIPv6)
at System.Net.Dns.GetHostAddresses(String hostNameOrAddress)
at System.Net.Sockets.TcpClient.Connect(String hostname, Int32 port)
at Microsoft.Crm.Asynchronous.EmailConnector.Pop3Client.Connect()
原因
如果电子邮件服务器配置文件中的服务器位置或端口不正确,则可能会出现此错误。
决议
注意
若要管理安全角色和邮箱设置,需要以具有“系统管理员”角色的用户身份登录到 Dynamics 365 组织。
导航到>,然后选择“电子邮件服务器配置文件”。
打开遇到错误的邮箱所使用的电子邮件服务器配置文件。
提示
您还可以在错误消息中选择电子邮件服务器配置文件的名称。 它作为超链接存在,将打开正确的电子邮件服务器配置文件。
验证传入服务器位置值是否正确。
注意
有关正确地址,请参阅电子邮件提供商的文档。 例如,对于 Gmail,用作
pop.gmail.com
传入服务器位置和smtp.gmail.com
传出服务器位置。选择“高级”。
验证传入端口值是否正确,然后选择“保存”。
注意
在连接到 SMTP 服务时,请参阅电子邮件提供商提供的文档,了解正确的端口。 对于 Gmail,将端口 995 用于传入 POP3 连接,将端口 587 用于传出 SMTP 连接。
选择 “邮箱”,然后选择收到错误的邮箱。
选择“测试和启用邮箱”按钮。
测试完成后,打开邮箱记录,如果结果未显示为“成功”,则查看“警报”部分。
第三方信息免责声明
本文中提到的第三方产品由 Microsoft 以外的其他公司提供。 Microsoft 不对这些产品的性能或可靠性提供任何明示或暗示性担保。