尝试将解决方案导入 Microsoft Dynamics 365 时,出现错误代码80040203 (参数无效) 错误
本文提供了在尝试将解决方案导入 Microsoft Dynamics 365 时发生的错误的解决方案。
适用于:Microsoft Dynamics 365 Customer Engagement Online
原始 KB 编号: 4514229
症状
尝试在 Dynamics 365 中导入解决方案时,会收到以下错误消息:
“解决方案的导入: <解决方案名称> 失败。
错误代码80040203。”
原因
此错误的原因有多种。 如果错误对话框引用了以下类型的对象,请查看本文的其余部分以获取可能的解决方案:
类型:关系
名称:bpf_<entity>_<publisher>_<BPF 名称>
下载“日志文件”,打开“组件”页时会显示:
ItemType:实体关系
名称:bpf_<entity>_<publisher>_<BPF 名称>
ErrorCode: 0x80040203
ErrorText:ID 的属性显示名称: <GUID,objectcolumn>:DisplayName 和 labelTypeCode:未指定属性
实体关系的名称将是实体和业务流程流 (BPF) 的串联。 实体以前已从 BPF 阶段中删除,并替换为其他实体,然后 BPF 在仍然激活时进行了更新。 实体已从 BPF 中删除,但关系仍存在于架构中。 因此,它随源中的解决方案一起导出。 此关系导致显示错误。
解决方案
Microsoft 已意识到此问题,并正在进行一项更改,以在删除后删除此关系,然后更新。
此问题有两种解决方法:
选项 1 - 更新解决方案文件
如果需要导入解决方案,但无法重新创建解决方案包,请从解决方案中删除关系。
解压缩解决方案。
编辑 customization.xml。
搜索错误中提到的关系: bpf_<entity>_<publisher>_<BPF 名称>
删除 EntityRelationship 的所有 XML:
<EntityRelationship Name="bpf_<entity>_<publisher>_<BPF Name>"> ... </EntityRelationship>
保存文件。
压缩整个目录。
再次导入解决方案。
选项 2 - 从源中删除关系并重新创建解决方案
这是一个长期解决方案,将解决下一次导出解决方案的问题。
打开源组织。
选择“设置 / ”“自定义 / ”“自定义系统”
在关系中选择实体:
bpf_<entity>_<publisher>_<BPF Name>
展开 1:N 关系。
找到关系:
bpf_<entity>_<publisher>_<BPF Name>
选择并删除关系。
发布 所有自定义项。
导出解决方案并将其导入目标。