尝试将解决方案导入 Microsoft Dynamics 365 时,会发生错误代码80040203(参数无效) 错误
本文提供了在尝试将解决方案导入 Microsoft Dynamics 365 时发生的错误的解决方案。
适用于: Microsoft Dynamics 365 Customer Engagement Online
原始 KB 数: 4514229
现象
尝试在 Dynamics 365 中导入解决方案时,会收到以下错误消息:
“解决方案导入: <解决方案名称> 失败。
错误代码80040203。”
原因
此错误的原因有多种。 如果错误对话框引用了以下类型的对象,请查看本文的其余部分以获取潜在的解决方案:
类型:关系
名称:bpf_<entity>_<publisher>_<BPF 名称>
下载打开“组件”页时显示的日志文件:
ItemType:实体关系
名称:bpf_<entity>_<publisher>_<BPF 名称>
ErrorCode:0x80040203
ErrorText:ID 的属性显示名称: <GUID>、objectcolumn:DisplayName 和 labelTypeCode:未指定属性
实体关系的名称将是实体和业务流程(BPF)的串联。 该实体以前已从 BPF 阶段中删除,并替换为其他实体,然后在仍激活时更新 BPF。 实体已从 BPF 中删除,但关系仍存在于架构中。 因此,它随解决方案从源导出。 此关系导致显示错误。
解决方法
Microsoft知道此问题,并且正在处理在删除后删除此关系的更改,然后更新。
对于此问题有两种解决方法:
选项 1 - 更新解决方案文件
如果需要导入解决方案,并且无法重新创建解决方案包,请从解决方案中删除关系。
解压缩解决方案。
编辑customization.xml。
搜索错误中提到的关系:bpf_<entity>_publisher>_<<BPF 名称>
删除 EntityRelationship 的所有 XML:
<EntityRelationship Name="bpf_<entity>_<publisher>_<BPF Name>"> ... </EntityRelationship>
保存文件。
压缩整个目录。
再次导入解决方案。
选项 2 - 从源中删除关系并重新创建解决方案
这是一项长期解决方案,将解决解决方案的下一次导出问题。
打开源组织。
选择“设置 / 自定义 / ”自定义系统
选择关系中的实体:
bpf_<entity>_<publisher>_<BPF Name>
展开 1:N 关系。
找到关系:
bpf_<entity>_<publisher>_<BPF Name>
选择并删除关系。
发布 所有自定义项。
导出解决方案并将其导入目标。