本文提供了设置步骤,以确保在 Microsoft Dynamics 365 供应链管理中更改工作订单生命周期状态时生成预期的故障原因或故障补救错误。
症状
更改设置为验证故障原因和故障补救措施的工作订单生命周期状态时,你期望生成的错误不会因故障原因或故障补救而发生。 这允许生命周期状态更改,尽管存在验证设置。
原因
预期错误不存在的一个可能原因是无法验证错误原因和故障补救措施,因为它们没有 错误注册。
解决方案
若要确保生成预期的错误,请按照以下步骤设置生命周期状态和工作订单类型,并创建错误注册。
设置生命周期状态和工作订单类型
设置生命周期状态以启用故障原因和故障补救措施的验证:
- 转到“资产管理”模块>“设置>工作订单>生命周期状态。
- 选择有问题的工单生命周期状态,然后选择“ 编辑”。
- 在 “验证 FastTab”下,将消息类型设置为 “错误”,并将 “故障原因”、“ 故障补救”和其他相关选项设置为 “是”。
设置工作订单类型,以启用故障原因和故障补救措施的验证,方法是强制工作订单:
- 转到“资产管理”模块>“设置>工作订单>工作订单类型。
- 选择有问题的工单类型,然后选择“ 编辑”。
- 在“常规 FastTab”下,将故障原因、故障补救和其他相关选项设置为“强制”部分中的“是”。
创建错误注册
若要确保收到预期的错误消息,请按照以下步骤创建错误注册:
转到“资产管理>工作”订单>“所有工作订单。
选择有问题的工单。 为简单起见,假设它是一个新的工作订单 ,当前生命周期状态 为 “新建”。
在“作窗格”中,转到 “资产 ”组,然后选择“ 资产错误”。
展开“症状 FastTab”,然后选择“添加行”。
在 “故障症状 ”字段中,从下拉列表中选择相关症状。 选择“保存”,然后返回到工作订单。
在“作窗格”中,转到 生命周期状态 组,然后选择“ 更新工作顺序”状态。
在 “更新工作订单状态 ”窗口中,选择 具有验证设置的生命周期状态 (请参阅 “设置生命周期状态”和“工作订单类型”)。 为简单起见,假定 生命周期状态 为 “已发布”。 然后,选择“确定”。
选择右上角的 “作中心/通知钟 ”,然后选择“ 消息详细信息”。 消息 详细信息 窗口显示“资产 Y 上出现症状 X 的错误原因缺失。 更新已取消。”关闭“ 消息详细信息 ”窗口。 在工作顺序的右上角, 生命周期状态 仍显示为 “新建”。
在工作订单的作窗格中,转到 “资产 ”组,然后选择“ 资产错误”。
展开所选症状的“原因”FastTab,然后选择“添加行”。
在 “故障原因 ”字段中,从下拉列表中选择相关原因。 选择“保存”,然后返回到工作订单。
在“作窗格”中,转到 生命周期状态 组,然后选择“ 更新工作顺序”状态。
在 “更新工作订单状态 ”窗口中,选择 具有验证设置的生命周期状态 (请参阅 “设置生命周期状态”和“工作订单类型”)。 为简单起见,假定 生命周期状态 为 “已发布”。 然后,选择“确定”。
选择右上角的作 中心/通知钟 声,然后选择新的 消息详细信息 (步骤 8 中提及)。 “ 消息详细信息 ”窗口显示“资产 Y 上出现症状 X 时 Z 的故障补救措施。 更新已取消。”关闭“ 消息详细信息 ”窗口。 在工作顺序的右上角, 生命周期状态 仍显示为 “新建”。
在工作订单的作窗格中,转到 “资产 ”组,然后选择“ 资产错误”。
展开所选症状 FastTab 的补救措施,然后选择“添加行”。
在 “故障补救 ”字段中,从下拉列表中选择相关补救措施。 选择“保存”,然后返回到工作订单。
在“作窗格”中,转到 生命周期状态 组,然后选择“ 更新工作顺序”状态。
在 “更新工作订单状态 ”窗口中,选择 具有验证设置的生命周期状态 (请参阅 “设置生命周期状态”和“工作订单类型”)。 为简单起见,假定其 生命周期状态 为 “已发布”。 然后,选择“确定”。
选择右上角的作 中心/通知铃 。 前两次尝试更新工作订单状态会导致错误消息,并且 生命周期状态 不会更新。 第三次尝试时,不会生成错误消息, 生命周期状态 已正确更新为 “已发布”。