无法根据维护计划创建工作订单

本文提供了安装步骤,以确保将维护计划线转换为工作订单不会失败,因为Microsoft Dynamics 365 供应链管理中与编号顺序设置相关的错误。

症状

尝试使用资产管理中的“打开维护计划”行为所选计划项创建工作订单时,在“创建工作订单”对话框中选择“确定”后,会收到以下错误消息。

已超出数字序列号 <序列> 。
取消数字选择。

原因

此问题是由设置数字序列引起的。 具体而言,实际编号序列超出了工作订单编号序列的配置范围。

解决方案

若要解决此问题并确保将维护计划线成功转换为工作订单,请按照以下步骤正确设置编号序列:

  1. 转到“资产管理”模块>设置>资产管理参数

  2. 选择 数字序列 FastTab。

  3. 在“引用”列中选择“工作顺序”,然后在“数字序列代码”列中选择相应的链接

  4. 转到 “段 FastTab”。 查找 Segment 列等于字母数字行。 确保“值”列中的相应字段具有足够的哈希标记,以匹配工作订单编号序列中变量数字部分的所需长度。

  5. 转到 常规 FastTab。 在 “数字分配 ”字段组中,确保 “最大 数字”与之前设置的工作订单编号序列号序列集的可变数字部分的长度匹配(但包含在内)。 换句话说,如果步骤 4 中的字母数字值等于 ######,则可以将最大数字设置为 999999。 此外,请确保“下一步”字段中的数字包含在步骤 4 和步骤 5 中提到的数字序列范围内。

  6. 选择“保存”以保存对数字序列所做的更改。

通过正确配置工单编号序列,将维护计划行转换为工作订单可以继续,而不会因错误而阻止。

详细信息

根据单个顺序设置数字序列