你的组织已删除与此应用关联的数据

本文可帮助你修复以下问题:当你打开由 Microsoft Intune 应用保护策略(APP)管理的 Outlook for Android 应用时,你收到 组织已删除与此应用 错误消息关联的数据。

现象

打开由 Intune APP 管理的 Outlook for Android 应用时,会收到以下消息:

你的组织删除了与此应用关联的数据,因为删除了Microsoft Intune 公司门户数据或应用程序。 若要重新连接,必须使用工作或学校帐户登录。

组织的屏幕截图已删除了与此应用错误消息关联的数据。

原因

此问题由以下原因之一导致:

  • Outlook 已长时间处于脱机状态。 因此,你已根据现有的应用保护策略注销 Outlook。
  • Outlook 无法检测系统更新后是否安装了公司门户应用。 由于 Outlook 无法获取预期的访问令牌,因此它将脱机。 因此,你已根据现有的应用保护策略注销 Outlook。

解决方案

若要避免将来出现此问题,请在 Android 设备上完成以下步骤:

  1. 关闭 Outlook 和公司门户的电池优化。
  2. 将 Outlook 和公司门户的应用启动设置从“自动”更改为“手动管理”。 然后,启用以下“ 手动 管理”选项:
    • 自动启动
    • 辅助启动
    • 在后台运行
  3. 如果已启用数据保存器,请选择 Outlook 并公司门户以使用不受限制的数据。
  4. 为 Outlook 和公司门户启用通知。

注意

我们还建议对 Intune APP 管理的其他应用执行这些步骤。

如果问题仍然存在,请按照以下步骤获取支持:

  1. 收集 Outlook 诊断日志信息:

    1. 在 Outlook for Android 设置中,点击“ 帮助和反馈”。
    2. 点击“ 收集诊断”。
    3. 点击“开始”。
    4. 点击“ 收集日志”。
    5. 提供事件 ID 以Microsoft 支持部门。
  2. 收集 Android 调试日志信息。

  3. 创建服务请求。 为此,请遵循如何在 intune 管理中心Microsoft获取支持的步骤操作。