在 Exchange Server 中更改主电子邮件地址时,用户配置文件中的 SMTP 地址不会更改

症状

当用户的主 SMTP 电子邮件地址在 Microsoft Exchange Server 2013、Exchange Server 2016 或 Exchange Online 中更改时,Microsoft Outlook 中用户配置文件中显示的地址不会更改。

例如,假设用户的主要 SMTP 电子邮件地址为 alias@domain.com,如图 1 所示:

图 1 图 2
图 1 的屏幕截图,其中显示了 Outlook 中显示的主 SMTP 电子邮件地址。alias@domain.com
图 2 的屏幕截图,其中显示了 Outlook 中显示的主 SMTP 电子邮件地址,如果用户的主 SMTP 电子邮件地址已更改,则预期会更改为 alias@subdomain.domain.com 。

但是,如果用户的主 SMTP 电子邮件地址更改为 alias@subdomain.domain.com,Outlook 中显示的主 SMTP 电子邮件地址不会按预期更改。 您希望 Outlook 中的主要 SMTP 电子邮件地址能够反映出更改,如图 2 所示。

原因

这是预期的行为。 Outlook 中的主要电子邮件地址将在几天内更改。 这种延迟是由于在 Exchange 中更新脱机通讯簿(OAB)所需的时间以及 Outlook 下载 OAB 所需的时间造成的。 只会更新主电子邮件地址。 如果没有新的 Outlook 配置文件,共享邮箱的 SMTP 地址将不会更改。

解决方法

若要解决共享邮箱的此行为,请为用户重新创建 Outlook 配置文件。

注意: OAB 更新的时间段仍适用。

了解如何 在 Outlook 中创建 Outlook 配置文件 和设置电子邮件帐户。