Copilot for Sales 中的“无法访问 Dynamics 365”错误

本文可帮助你排查和解决用户无法访问 Dynamics 365 Microsoft Microsoft Copilot for Sales 外接程序 for Outlook 时出现的问题。

备注

Microsoft Sales Copilot 在 2024 年 1 月被改名为 Microsoft Copilot for Sales。 本文中的屏幕截图将很快更新为新名称。

谁受影响?

要求类型 Description
客户端应用 Copilot for Sales Outlook 加载项
平台 Web 和桌面客户端
操作系统 Windows 和 Mac
部署 用户管理和管理员管理
CRM Dynamics 365
用户 尝试从 Copilot for Sales 登录到 Dynamics 365 环境的用户

现象

用户通过适用于 Outlook 的 Copilot for Sales 外接程序登录到 Dynamics 365 后,将显示以下错误消息:

你似乎无权访问 Dynamics 365。 请联系管理员,或使用其他Microsoft帐户登录。

显示用户尝试登录时发生的错误的屏幕截图。

原因

用户没有分配所需的安全角色。

若要使用 Copilot for Sales,用户必须具有有效的 Dynamics 365 许可证,并分配相应的安全角色。 这些角色具有 Copilot for Sales 正常工作所需的权限。

解决方法

必须使用 Copilot for Sales 将以下安全角色分配给每个用户:

  • Salesperson
  • 基本用户
  • Sales Copilot 用户

有关如何为用户分配安全角色的信息,请参阅为用户分配安全角色

详细信息

如果你的问题仍未解决,请转到 Copilot for Sales - Microsoft社区中心 与我们的专家联系。