Salesforce CRM 用户无法在 Copilot for Sales 中看到数据

本文可帮助你排查和解决用户无法在 Microsoft Copilot for Sales 中查看数据的问题。

注意

Microsoft Sales Copilot 于 2024 年 1 月更名为 Microsoft Copilot for Sales。 本文中的屏幕截图将很快更新为新名称。

谁受到影响?

要求类型 说明
客户端应用 Copilot for Sales Outlook 加载项
平台 Web 和桌面客户端
操作系统 Windows 和 Mac
部署 用户托管和管理员托管
CRM Salesforce
用户 无权查看 Copilot for Sales 窗体中添加的字段的用户

症状

当用户在 Outlook 中打开 Copilot for Sales 时,将显示以下错误消息:

发生了错误

显示“出错”错误的详细信息的屏幕截图。

原因

字段的字段级安全性在 Salesforce CRM 中设置为不可见。 因此,Copilot for Sales 无法在配置中按预期引用该字段。

解决方法 1:修复 Salesforce CRM 中的字段级安全性

  1. 以管理员身份登录到 Salesforce CRM 并打开 安装程序

  2. 打开 对象管理器

  3. 选择引发错误的实体。

  4. 在左侧导航栏中,选择“ 字段 & 关系”。

  5. 选择引发错误的字段。

  6. 选择顶部 的“设置 Field-Level 安全性 ”。

    显示 Salesforce CRM 中的对象管理器的屏幕截图。

  7. 确保为正确的配置文件设置了 Visible

  8. 验证自定义权限集的相同。

有关 Salesforce CRM 中字段级安全性的详细信息,请参阅 字段级别安全性

解决方法 2:更改 Copilot for Sales 中的设置以隐藏字段或删除编辑功能

更改 Microsoft Teams 中 Copilot for Sales 管理员设置中的管理员设置,以隐藏字段或删除编辑功能。

  1. 使用管理员凭据登录到 Microsoft Teams。

  2. 在左侧导航栏中,选择 “Copilot for Sales”。

  3. “设置” 选项卡上,选择“ 窗体”。

  4. 选择看到其错误的实体。

  5. “管理字段”下,执行以下操作之一:

    • 如果问题与编辑字段有关,请关闭“ 允许编辑 相应字段”。

      显示如何在“管理字段”页上关闭对几个字段的编辑的屏幕截图。

    • 如果问题与查看字段有关,请将鼠标悬停在该字段上,然后选择“ 删除字段 ( ) ”。

  6. 选择“发布”以保存所做的更改。

更多信息

如果问题仍未解决,请转到 Copilot for Sales - Microsoft 社区中心 与我们的专家联系。

第三方信息免责声明

本文中提到的第三方产品由 Microsoft 以外的其他公司提供。 Microsoft 不对这些产品的性能或可靠性提供任何明示或暗示性担保。