登录到 Dynamics 365 时出现“需要访问”错误

本文可帮助你排查和解决 Microsoft Copilot for Sales 中出现“需要访问”错误,当用户在 Microsoft Dynamics 365 中禁用或不是任何业务部门的成员时。

注意

Microsoft Sales Copilot 在 2024 年 1 月被改名为 Microsoft Copilot for Sales。 本文中的屏幕截图将很快更新为新名称。

谁受影响?

要求类型 Description
客户端应用 Copilot for Sales Outlook 加载项
平台 Web 和桌面客户端
操作系统 Windows 和 Mac
部署 用户管理和管理员管理
CRM Dynamics 365
用户 被禁用或不是 Dynamics 365 中任何业务部门成员的用户

现象

当 Dynamics 365 用户尝试登录到 Copilot for Sales 时,将显示以下错误消息:

所需的访问权限

显示 Access 所需错误的屏幕截图。

原因

错误消息需要访问会由于以下原因之一显示:

  • 用户要么被禁用,要么不是 Dynamics 365 中任何业务部门的成员。
  • 用户不是Microsoft Entra ID 安全组的成员。

解决方法 1:在 Dynamics 365 中启用用户

  1. 使用系统管理员凭据登录 Dynamics 365。

  2. 转到设置>高级设置

  3. 在命令栏上,选择设置>安全性

  4. 选择用户,然后将视图更改为禁用用户

    如果受影响的用户显示为禁用,启用该用户。

解决方法 2:将用户添加为 Microsoft Entra ID 安全组的成员

  1. 使用系统管理员凭据登录到 Power Platform 管理中心

  2. 在左侧导航窗格中的管理中心下,选择 Microsoft Entra ID

    Microsoft Entra 管理中心将打开。

  3. 在左侧导航窗格的标识下,选择>所有组

  4. 找到需要为用户分配的安全组,然后选择将其打开。

  5. 管理下,选择成员,然后选择添加成员

  6. 查找用户并将其添加到安全组。

详细信息

如果你的问题仍未解决,请转到 Copilot for Sales - Microsoft社区中心 与我们的专家联系。