登录到 Salesforce 时输入的自定义域不正确
本文可帮助你排查和解决用户在登录 Salesforce CRM 时输入错误的自定义域时出现的问题。
注意
Microsoft Sales Copilot 于 2024 年 1 月更名为 Microsoft Copilot for Sales。 本文中的屏幕截图将很快更新为新名称。
谁受到影响?
要求类型 | 说明 |
---|---|
客户端应用 | Copilot for Sales Outlook 加载项 |
平台 | Web 和桌面客户端 |
操作系统 | Windows 和 Mac |
部署 | 用户托管和管理员托管 |
CRM | Salesforce |
用户 | 尝试登录 Salesforce 的用户 |
症状
通过 适用于 Outlook 的 Copilot for Sales 加载项登录到 Salesforce CRM 后,无法访问 Salesforce 环境,并显示以下错误消息:
服务“Salesforce”的 OAuth2 授权流失败。 OAuth 2 登录无法交换访问令牌的代码。 在表单正文中发送的客户端 ID 和机密。 响应状态代码-BadRequest。 响应正文:{“error”:“invalid_grant”,“error_description”:“身份验证失败”} 在基本授权标头中发送的客户端 ID 和机密。 响应状态代码=BadRequest。 REsponse 正文:{“error”:“invalid_grant”,“error_description”:“authentication failure”}
原因
登录到 Salesforce CRM 时输入了错误的自定义域。
解决方案
输入正确的自定义域,然后再次登录到 Salesforce CRM。 例如,在下图中, correct.my.salesforce.com
是主机,表示 /login
自定义登录页的路径。
更多信息
如果问题仍未解决,请转到 Copilot for Sales - Microsoft 社区中心 与我们的专家联系。
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