“请求 CRM 管理员权限以使用 API 访问 Salesforce”错误

本文可帮助你排查并解决在 Microsoft Copilot for Sales 中连接到 Salesforce CRM 并登录后显示错误消息时出现的问题。

注意

Microsoft Sales Copilot 于 2024 年 1 月更名为 Microsoft Copilot for Sales。 本文中的屏幕截图将很快更新为新名称。

谁受到影响?

要求类型 说明
客户端应用 Copilot for Sales Outlook 加载项
平台 Web 和桌面客户端
操作系统 Windows 和 Mac
部署 用户托管和管理员托管
CRM Salesforce
用户 尝试将 Copilot for Sales 与 Salesforce CRM 配合使用的用户

症状

通过 适用于 Outlook 的 Copilot for Sales 加载项登录到 Salesforce CRM 后,将显示以下错误消息:

使用 API 请求 CRM 管理员权限以访问 Salesforce

显示 API 权限错误的屏幕截图。

原因

在 Salesforce 中没有 API 权限时,会出现此问题。 如果日志中出现以下错误,可以确认这是否是问题的根本原因:

Exception thrown in VivaSalesContacts/GetContactsByEmailAddress - 
Microsoft.SalesProductivity.Common.Base.SPServiceException: Salesforce failed to complete task: Message: entity is deleted clientRequestId: {CLIENT REQUEST ID HERE}-self ---> 
System.Exception: { 
    "error": { 
        "code": 502, 
        "source": "{APIM SOURCE}", 
        "message": "BadGateway", 
        "innerError": { 
            "status": 502, 
            "message": "Salesforce failed to complete task: Message: **API is disabled for this User**\r\nclientRequestId: {CLIENT REQUEST ID HERE}", 
            "error": null, 
            "source": "Salesforce.Common", 
            "errors": [] 
        } 
    } 
} 

解决方案

管理员可以通过执行以下步骤,向用户或受影响用户的配置文件授予 “启用 API” 权限:

  1. 以管理员身份登录到 Salesforce。

  2. 在搜索框中,输入 “用户”。

  3. 在左侧导航窗格中,选择“ 配置文件”,然后选择受影响的用户配置文件。

  4. “管理权限” 部分中,选择“ API 已启用”。

  5. 选择“保存”。

    显示“配置文件”页上的“启用 API”选项的屏幕截图。

更多信息

如果问题仍未解决,请转到 Copilot for Sales - Microsoft 社区中心 与我们的专家联系。

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