本文可帮助解决裸机恢复(BMR)备份因Microsoft Azure 备份服务器或 System Center Data Protection Manager(DPM)中的高输入/输出(I/O)延迟而失败的问题。
原始产品版本: System Center 2016 Data Protection Manager
原始 KB 数: 4512842
现象
使用 Azure 备份 服务器或 System Center Data Protection Manager 执行 BMR 备份时,备份会失败。 DPM 服务器上收到以下错误消息之一:
DPM 无法创建备份,因为受保护计算机上的 Windows Server 备份(WSB)遇到错误(WSB 事件 ID:517、WSB 错误代码:0x6B48C3A0)。 (ID 30229 详细信息:内部错误代码:0x80990ED0)
日志名称:DPM 警报
源:DPM-EM
日期: <日期><时间>
事件 ID:3106
任务类别:无
级别: 错误
关键字:经典
用户:无
计算机: <servername>
说明:服务器名称>上的<非 VSS 数据源编写器的副本与受保护的数据源不一致。 在副本与一致性检查同步之前,数据源的所有保护活动都将失败。 (ID:3106)
无法读取或写入涉及当前操作的存储。 (ID: 40003)
以下错误条目记录在受保护的服务器上:
日志名称:Microsoft-Windows-Backup
源:Microsoft-Windows-Backup
日期: <日期><时间>
事件 ID:5
任务类别:无
级别: 错误
关键字:
用户: 系统
计算机: <Servername>
说明:
在“时间>”启动的备份操作失败,错误代码为“<0x8078015B”(Windows 备份访问远程共享文件夹时遇到错误。请确保远程共享文件夹可用且可访问后重试该操作。 请查看解决方案的事件详细信息,然后在问题解决后重新运行备份操作。
日志名称:Microsoft-Windows-SmbClient/Connectivity
来源:Microsoft-Windows-SMBClient
日期: <日期><时间>
事件 ID:30809
任务类别:无
级别: 错误
关键字:(64)
用户:无
计算机: <servername>
说明:
请求超时,因为服务器没有响应。服务器名称: <Servername>
会话 ID: <会话 ID>
树 ID:0x1
消息 ID:0x4000015
命令:刷新
指导:
服务器通过 TCP 进行响应,而不是通过 SMB 进行响应。 确保服务器服务正在运行且响应迅速,并且磁盘没有高每个 IO 延迟,这使得磁盘对 SMB 无响应。 此外,请确保服务器整体响应且未暂停;例如,请确保可以登录到它。
日志名称:Microsoft-Windows-SMBServer/Operational
来源:Microsoft-Windows-SMBServer
日期: <日期><时间>
事件 ID:1020
任务类别:(1020)
级别: 警告
关键字:(8)
用户: 系统
计算机: <ServerName>
说明:
文件系统操作花费的时间比预期长。
客户端名称: <IP>
客户端地址: <IP:Port>
用户名: <用户名>
会话 ID: <会话 ID>
共享名称: <sharename>
文件名:WINDOWSIMAGEBACKUP\<Servername>\<Backupdate>\<GUID>。VHDX
命令:7
持续时间(以毫秒为单位):353151
警告阈值(以毫秒为单位):120000
指导:
基础文件系统花费的时间太长,无法响应操作。 这通常表示存储问题,而不是 SMB。
原因
Windows 备份服务器在备份期间直接写入 DPM 或 Azure 备份 服务器共享。 如果输入/输出(I/O)延迟大于标准 SMB 超时(60 秒),则会出现此问题。
解决方法
重要
此部分(或称方法或任务)介绍了修改注册表的步骤。 但是,注册表修改不当可能会出现严重问题。 因此,按以下步骤操作时请务必谨慎。 作为额外保护措施,请在修改注册表之前先将其备份。 如果之后出现问题,您就可以还原注册表。 有关如何备份和还原注册表的详细信息,请参阅:如何备份和还原 Windows 中的注册表。
要解决该问题,请执行以下步骤:
在受保护的服务器上,打开注册表编辑器,然后添加
SessTimeout
注册表项,如以下子项所示:subkey 名称 类型 数据 HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters
SessTimeout REG_DWORD 1200 注意
建议使用 1,200 秒(20 分钟)超时值。 根据需要调整值。 可以在 DPM 或 Azure 备份 服务器服务器上查看可复原文件系统(ReFS)事件日志,以查找任何可疑的 I/O 延迟。
重启受保护的服务器。
如果无法重启受保护的服务器,请停止并重启工作站(Lanmanworkstation)服务。
注意
请确保检查工作站(Lanmanworkstation)服务的依赖项列表。 还必须重启依赖于此服务的服务。
详细信息
使用 BMR 备份时,请确保满足以下先决条件:
已安装 DPM 或 Azure 备份 服务器的最新更新。
正确设置副本大小。 有关详细信息,请参阅 如何使用新式备份存储(MBS)提高 DPM 2016 副本。