Microsoft应用商店应用无法启动(如果用户配置文件或 ProgramData 目录从其默认位置移动)

本文提供了Microsoft应用商店应用在用户目录、用户配置文件或 ProgramData 目录从其默认位置移动后无法启动的问题的解决方案。

适用于:Windows 10 - 所有版本
原始 KB 数: 2787623

现象

将用户目录、单个用户配置文件或 ProgramData 目录从其默认位置移动后,Microsoft应用商店应用将不再启动。 可能会注意到各种症状。 你可能会看到一些症状是:

  • 单击Microsoft应用商店应用的磁贴或Microsoft应用商店将开始启动应用,但会返回到开始屏幕。 不显示任何错误信息。

  • 单击Microsoft应用商店的磁贴将无法打开应用商店并返回错误:

    我们无法连接到应用商店。 这可能是由于服务器问题或网络连接超时而发生的。请等待几分钟,然后重试。 单击“重试”可能会或可能无法成功将你连接到应用商店。

  • 单击Microsoft应用商店的磁贴将打开应用商店,但尝试购买应用将返回错误:

    无法完成购买

  • 新式电脑设置应用不会打开,也不会从那里访问任何应用。

  • 新式Windows 更新不会打开,但通过 控制面板 访问的旧Windows 更新将打开。

原因

当用户目录、单个用户配置文件或 ProgramData 目录移动到其默认位置以外的其他位置时,Microsoft应用商店应用不再受支持或预期有效。

解决方法

不要更改用户目录的默认位置(默认情况下为 c:\users),也不会更改任何单个用户配置文件。 不要更改 ProgramData 目录的默认位置 (c:\ProgramData 默认)

详细信息

有关重新定位用户和 ProgramData 目录的方法的详细信息,请参阅下面的链接。 这些方法按原样提供,仅用于测试环境。 这些方法明确指出,如果使用Microsoft应用商店和Microsoft应用商店应用,则不支持这些应用。