重启计算机时,计算机停止响应,或“应用计算机设置”屏幕显示的时间超过预期

本文提供了一个解决方案,其中计算机停止响应或“应用计算机设置”屏幕显示的时间比预期长。

适用于: Windows Server 2003
原始 KB 数: 905716

现象

重启基于 Windows Server 2003 的计算机或基于 Windows 2000 Server 的计算机时,会遇到以下症状之一:

  • 在启动期间,将显示“应用计算机设置”屏幕,计算机停止响应。

  • 在启动期间,将显示“应用计算机设置”屏幕,并且会保留比预期更长的时间。

  • 在启动期间,在登录屏幕出现之前,将显示一个闪烁指针的蓝屏,计算机停止响应。

  • “网络连接”文件夹为空。

  • 无法在控制面板中打开“添加或删除程序”项。

  • APC 代理在启动时停止响应。

  • 无法启动或停止服务。

  • 服务器缓慢地响应图形用户界面(GUI)函数。

  • 尝试打开磁盘管理时,会收到以下消息之一:

    正在等待连接

    连接到逻辑磁盘管理器服务
    磁盘管理永远不会打开。

  • 应用安全修补程序时,无论是从Windows 更新还是手动应用,系统在“检查配置”时停止。

原因

出现此问题的原因是版本 6 出现问题。APC PowerChute Business Edition Software 的 x

APC 已就此问题发表了以下官方声明:

APC 6.x 软件使用 Sun Microsystems Java 加密扩展(JCE)1.2.1 包。 用于对 JCE 1.2.1 jar 文件进行签名的数字证书已于 2005 年 7 月 27 日过期。 因此,系统会导致上述详细症状。

解决方法

若要解决该问题,请执行以下步骤:

  1. 在安全模式下重启计算机:

    1. 重新启动计算机。 出现“请选择要启动的操作系统”消息时,按 F8。

    2. 在“Windows 高级选项”菜单,使用箭头键选择“安全模式”,然后按 Enter。

      注意

      数字键盘上的箭头键将正常工作之前,必须关闭 NUM LOCK。

    3. 如果在计算机上运行其他操作系统,请使用箭头键选择所需的操作系统,然后按 Enter。

  2. 以本地管理员身份登录到计算机。

  3. 禁用 APCPBEAgent 服务和 APCPBEServer 服务:

    1. 单击“开始”,指向程序”,指向“管理工具”,然后单击“服务”。
    2. 在右窗格中,右键单击 APCPBEAgent,然后单击“ 属性”。
    3. “启动类型 ”列表中,单击以选择“ 已禁用”,然后单击“ 确定”。
    4. 在右窗格中,右键单击 APCPBEServer,然后单击“ 属性”。
    5. “启动类型 ”列表中,单击以选择“ 已禁用”,然后单击“ 确定”。
  4. 重新启动计算机。

  5. 安装最新版本的 APC PowerChute 软件。 有关如何获取 PowerChute Business Edition 版本 6 的更新的详细信息。 x 软件,请访问 APC 网站

解决方法

若要解决此问题,请重新注册Msiexec.exe。 为此,请单击“开始”,单击运行”,键入msiexec /regserver,然后单击“确定”。

详细信息

本文中提到的第三方产品由 Microsoft 以外的其他公司提供。 Microsoft对这些产品的性能或可靠性不作任何默示或其他担保。

Microsoft 会提供第三方联系信息来帮助你查找技术支持。 此联系信息可能会更改,恕不另行通知。 Microsoft 不保证此第三方联系信息的准确性。

APC PowerChute Business Edition v6 使用 2005 年 7 月 27 日从服务过期的 Sun Java 运行时引擎。 APC 现在使用 PowerChute Business Edition 进行通信和管理 UPS(不间断电源和电池备份)系统。