本文介绍无法登录到系统的问题,并且系统会反复提示输入用户名和密码。
适用于: 支持的 Windows Server 版本
原始 KB 数: 555648
现象
尝试登录到 Windows 时,Windows 会立即登录并注销。 键入用户名和密码时,将再次显示“用户名和密码”对话框。 你努力进入, 但无济于事。
原因
不能使用正常模式或安全模式登录到系统。 仅当 Winlogon 服务尝试从注册表加载 Windows 默认 shell(explorer.exe)和用户 shell(userinit.exe)时,才会发生这种情况。 此服务在注册表的以下路径中搜索Explorer.exe和Userinit.exe:
HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon
解决方法
编辑这些值并键入 shell 的正确路径:
Shell = explorer.exe
Userinit = C:\windows\system32\userinit.exe
注意
这些文件也可能由间谍软件删除。 可能需要使用 Windows CD 提取它们。
纠正此问题的步骤
登录到网络计算机。
运行
Regedit.exe
。将光标
HKEY_LOCAL_MACHINE
指向 。选择“文件>连接远程注册表”。
键入计算机名称(受感染的计算机)。
导航到目标计算机或受感染计算机注册表中的以下位置:
HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon
在右窗格中编辑这两个值:
Shell
Userinit将这两个值更改为
Shell = explorer.exe
Userinit = C:\windows\system32\userinit.exe退出注册表。
重启受感染的计算机。
应该能够登录到计算机。
重要
如果上述步骤未解决问题,则应将计算机视为遭到入侵。
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