在重启后用户登录期间,登录前的 SSO 失败

本文提供了一个解决方案,其中单一登录(SSO)配置文件在重启后用户登录期间登录失败。

原始 KB 数: 3063910

现象

如果客户端系统配置为使用具有预登录的 SSO 配置文件,则无线和有线 802.1x 身份验证在系统重启后首次登录尝试失败。 在这种情况下,用户会收到以下错误消息:

目前没有可用于为登录请求提供服务的登录服务器。

消息窗口类似于以下屏幕截图。

屏幕截图显示无法为登录请求错误提供服务的登录服务器。

原因

此问题是由于在预登录身份验证提供程序(PLAP)登录筛选器和有线自动配置服务(用于有线连接)或 WLAN 自动配置服务(无线连接)之间的启动顺序期间发生的争用条件造成的。 SSO 配置文件的登录筛选器查询。 但是,如果在查询时未完全初始化相应的自动配置服务,则不会配置客户端 SSO。 因此,用户无法使用 SSO 登录。

解决方法

若要解决此问题,请通过非 802.1x 保护的网络将用户连接到第一次登录期间缓存其凭据。

Status

Microsoft已确认,本文开头列出的Microsoft产品中存在此问题。

详细信息

此问题通常不会发生。 但是,如果确实遇到此问题,建议打开支持案例并收集相关的日志信息。 为此,请按照下列步骤进行操作:

  1. 打开权限提升的命令提示符。

  2. 运行下面的命令:

    netsh trace start persistent=yes overwrite=yes maxsize=4096 tracefile=c:\net_plap.etl provider={2CF38663-F760-46AC-AAFA-2DDE7F9DB417} keywords=0xffffffffffffffff level=0xff provider="Microsoft-Windows-L2NACP" keywords=0xffffffffffffffff level=0xff
    
  3. 重新启动计算机。

  4. 重现登录问题。

  5. 连接到未受保护的网络以成功登录并停止跟踪。 为此,请运行以下命令:

    netsh trace stop
    

    这会生成跟踪文件:c:\net_plap.etl。