欢迎使用Visual Studio IDE |Visual Basic

集成开发环境(IDE)是一个功能丰富的程序,支持软件开发的许多方面。 Visual Studio IDE是一个创造性的启动板,可用于编辑、调试和生成代码,然后发布应用。 Visual Studio还包括编译器、代码完成工具、图形设计器和更多功能,以增强软件开发过程。

Visual Studio IDE 的截图,包含 Visual Basic 代码和主要功能。

Visual Studio 2022 IDE 的截图,其中包含 Visual Basic 代码和主要功能。

上图显示了在Visual Studio中打开了一个Visual Basic项目,展示了关键窗口及其功能。

  • 在 解决方案资源管理器 右上角,可以查看、导航和管理代码文件。 解决方案资源管理器通过将文件分组到 解决方案和项目来帮助组织代码。

  • 中央编辑器窗口是你可能大部分时间使用的地方,显示文件内容。 在编辑器窗口中,可以编辑代码或设计用户界面,例如带有按钮和文本框的窗口。

  • 在右下角的 Git Changes 中,可以使用版本控制技术(如 Git 和 GitHub)跟踪工作项并与他人共享代码。

Editions

Visual Studio可用于Windows。

有三个版本的Visual Studio:社区版、专业版和企业版。 若要了解每个版本支持哪些功能,请参阅 Compare Visual Studio 版本。

开发软件时,Visual Studio中的一些常用功能可提高工作效率,包括:

  • 波形曲线和快速操作

    波形曲线是波浪形下划线,它可以在键入时对代码中的错误或潜在问题发出警报。 这些视觉线索可帮助你立即解决问题,而无需等待在生成或运行时发现错误。 如果将鼠标悬停在波形曲线上,将看到关于此错误的更多信息。 灯泡也可能显示在左侧边距中,显示您可以采取的 快速操作 来修复错误。

    在 Visual Studio 中带有波形下划线的截图。

    Visual Studio 2022 中波浪线下划线的截图。

  • Refactoring

    重构包括诸如变量智能重命名、将一行或多行代码提取到新方法以及更改方法参数顺序等操作。

     Visual Studio 中重构菜单的截图。

    Visual Studio 2022 中重构菜单的截图。

  • IntelliSense

    IntelliSense 是一组功能,可在编辑器中直接显示有关代码的信息,在某些情况下为你编写少量代码。 这就像在编辑器中嵌入基本文档一样,因此无需在其他位置查找类型信息。

    下图显示了 IntelliSense 如何显示类型的成员列表:

    IntelliSense 成员列表的屏幕截图。

    Visual Studio 2022 中的 IntelliSense 成员列表截图。

    IntelliSense 功能因语言而异。 有关详细信息,请参阅 C# IntelliSense, Visual C++ IntelliSense、JavaScript IntelliSense 和 Visual Basic IntelliSense。

  • Visual Studio search

    Visual Studio菜单、选项和属性有时似乎压倒性。 Visual Studio搜索或 Ctrl+Q是快速查找 IDE 功能和代码的一种好方法。

    当您开始键入要查找的内容名称时,Visual Studio 会列出带您到达所需位置的结果。 如果需要添加功能(例如另一种编程语言),可以从搜索结果中打开 Visual Studio Installer 以安装工作负荷或组件。

    显示 Visual Studio 中快速启动搜索框的截图。

  • 实时共享

    无论应用类型或编程语言如何,都以实时方式与其他人协作编辑和调试。 可以立即安全地共享项目。 还可以共享调试会话、终端实例、 Web 应用、语音呼叫等。

  • 调用层次结构

    调用层次结构 窗口显示调用所选方法的方法。 在考虑更改或删除方法时,或者尝试跟踪 bug 时,此信息非常有用。

    Visual Studio 中显示“调用层次结构”窗口的屏幕截图。

    截图,显示 Visual Studio 2022 中的“调用层次结构”窗口。

  • CodeLens

    CodeLens 可帮助你查找代码引用、代码更改、链接的 bug、工作项、代码评审和单元测试,而无需离开编辑器。

    显示在 Visual Studio 中的 CodeLens 的屏幕截图。

    显示 Visual Studio 2022 中 CodeLens 的屏幕截图。

  • 转到定义

    “转到定义”功能可将你直接带到函数或类型定义的位置。

    显示 Visual Studio 中“转到定义”功能的截图。

    显示 Visual Studio 2022 中的

  • 速览定义

    速览定义 窗口显示方法或类型定义,而无需打开单独的文件。

    显示 Visual Studio 中的速览定义的截图。

    显示 Visual Studio 2022 中快速查看定义的截图。

  • 热重载

    热重载使你能够编辑应用程序的代码文件,并立即将代码更改应用到正在运行的应用程序。

    在 Visual Studio 中的热重载截图。

安装Visual Studio

在本部分中,您将创建一个简单的项目,以尝试使用 Visual Studio 可以完成的一些操作。 了解如何更改颜色主题、使用 IntelliSense 作为编码辅助,并调试应用,在应用执行期间查看变量值。

若要开始,download Visual Studio并将其安装在系统上。 在模块化安装程序中,选择并安装 工作负载,这些工作负载是所需编程语言或平台所需的一组功能。 若要使用以下步骤创建程序,请确保在安装过程中选择 .NET 桌面开发工作负荷。

在 Visual Studio Installer 中选择的 .NET 桌面开发工作负载的截图。

首次打开Visual Studio时,可以使用Microsoft帐户或工作或学校帐户登录。

自定义 Visual Studio

你可以个性化Visual Studio用户界面,包括更改默认颜色主题。

更改颜色主题

更改颜色主题:请按照以下步骤操作

  1. 打开Visual Studio。 在“开始”窗口中,选择“ 继续”而不使用代码。

    Visual Studio“开始”屏幕的截图,其中突出显示了“无代码继续”链接。

  2. 在Visual Studio菜单栏上,选择Tools>Options打开Options对话框。

  3. 在 “环境常规 ”选项页上,将 颜色主题 选择更改为 “蓝色 ”或“ 浅色”,然后选择“ 确定”。

    这是一个截图,显示如何在 Visual Studio 中将颜色主题更改为蓝色。

    整个 IDE 的颜色主题会相应地更改。 以下屏幕截图显示了蓝色主题:

    显示蓝色主题的 Visual Studio 截图。

  1. 打开Visual Studio。 在菜单栏上,选择 “工具选项 ”以打开 “选项 ”窗格。

  2. 在 “所有设置环境视觉体验 ”选项页上,将 颜色主题 选择更改为 “冷微风 ”或 “浅色”。

    屏幕截图,显示在 Visual Studio 中将颜色主题更改为“Cool Breeze”主题。

    整个 IDE 的颜色主题会相应地更改。 以下屏幕截图显示了“冷风”主题:

    显示清风主题的 Visual Studio 的截图。

选择环境设置

可以将Visual Studio配置为使用专为Visual Basic开发人员定制的环境设置。

  1. 在菜单栏上,选择 工具导入和导出设置。

  2. 在 导入和导出设置向导中,选择 重置所有设置,然后选择 下一。

  3. 在 “保存当前设置” 页上,选择是否在重置之前保存当前设置。 如果尚未自定义任何设置,请选择“不,只重置设置,同时覆盖我的当前设置”。 然后选择下一步。

  4. 在选择“设置的默认集合页上,选择Visual Basic,然后选择Finish。

  5. 在“重置完成”页上,选择“关闭”。

若要了解个性化 IDE 的其他方法,请参阅 Personalize Visual Studio。

创建程序

深入了解并创建一个简单的程序。

  1. 在Visual Studio菜单栏上,选择File>New>Project。 也可以按 CtrlShiftN。

    文件“新建>项目”在 Visual Studio 菜单栏中的截图>。

    “创建新项目”窗口随即打开,并显示多个项目 模板。 模板包含给定项目类型所需的基本文件和设置。

  2. 若要查找模板,可以在搜索框中键入或输入关键字。 可用模板列表根据输入的关键字筛选。 可以通过在 所有语言 列表中选择 Visual Basic,在 所有平台 列表中选择 Windows,以及在 所有项目类型 列表中选择 Console 来筛选模板结果。

    选择 Visual Basic Console App 模板,然后选择 Next。

    选择 Visual Basic 控制台应用程序的新建项目窗口的屏幕截图。

  3. 在 配置新项目 窗口中,输入 HelloWorld 作为 项目名称。 (可选)将项目目录位置从默认位置 C:\Users\用户名\source\repos更改,然后选择 “下一步”。

    “配置新项目”窗口的屏幕截图,其中输入了项目名称 HelloWorld。

  4. 在 Additional information 窗口中,验证 .NET 10.0是否显示在 Framework 菜单中。 然后选择“创建”。

    已选择 .NET 10.0 的“附加信息”窗口截图。

    Visual Studio创建项目。 该程序是一个简单的“Hello World”应用程序,它调用 Console.WriteLine() 方法,在控制台窗口中显示字符串Hello,World!。

    项目文件显示在Visual Studio IDE右侧,位于名为 解决方案资源管理器 的窗口中。 在 解决方案资源管理器 窗口中,选择 Program.vb 文件。 应用的Visual Basic代码将在中央编辑器窗口中打开,这将占用大部分空间。

    显示在 Visual Studio IDE 的编辑器中打开的 Program.vb 代码的屏幕截图。

    代码会自动着色以指示不同的部分,例如关键字和类型。 行号可帮助你查找代码。

    代码中的小型垂直虚线表示代码结构或一起排列的代码块。 还可以选择小右箭头符号以折叠或展开代码块。 此代码大纲显示功能允许隐藏不需要查看的代码,从而最大程度地减少屏幕上的杂乱无章。

    Screenshot,显示带有红色框的Visual Studio IDE。

    许多其他菜单和工具窗口都可用。

  5. 在 Visual Studio 顶部菜单中选择Debug>不带调试启动来启动应用。 还可以按 CtrlF5。

    显示“启动但不调试”菜单项的屏幕截图。

    Visual Studio生成应用,控制台窗口随即打开,消息Hello World!。 你现在有一个正在运行的应用!

    调试控制台窗口的屏幕截图,显示输出“Hello World!”,然后按任意键关闭此窗口。

  6. 若要关闭控制台窗口,请按任意键。

  7. 在Console.WriteLine("Hello World!")行前面添加以下Visual Basic代码:

    Console.WriteLine("What is your name?")
    Dim name = Console.ReadLine()
    

    此代码在控制台窗口中显示 你的姓名是什么?,然后等待用户输入一些文本。

  8. 将Console.WriteLine("Hello World!")的行更改为以下行:

    Console.WriteLine("Hello " + name + "!")
    
  9. 再次运行应用,可以选择 调试启动而不调试,或按 CtrlF5。

    Visual Studio重新生成应用,此时会打开控制台窗口并提示你输入名称。

  10. 在控制台窗口中键入名称,然后按 Enter。

    “调试控制台”窗口的屏幕截图,显示了名称提示、输入内容和输出结果:Hello Georgette。

  11. 按任意键关闭控制台窗口并停止正在运行的程序。

  1. 在Visual Studio菜单栏上,选择File>New>Project。 也可以按 CtrlShiftN。

    Visual Studio 2022 菜单栏中文件>新建>项目选择的屏幕截图。

    “创建新项目”窗口随即打开,并显示多个项目 模板。 模板包含给定项目类型所需的基本文件和设置。

  2. 若要查找模板,可以在搜索框中键入或输入关键字。 可用模板列表根据输入的关键字筛选。 可以通过从 所有语言 列表中选择 Visual Basic,从 All 平台 列表中选择 Windows,以及从 所有项目类型 列表中选择 Console 来进一步筛选模板结果。

    选择 Visual Basic Console Application 模板,然后选择 Next。

     在 Visual Studio 2022 中,新建项目窗口的截图,其中选择了 Visual Basic 控制台应用程序。

  3. 在 配置新项目 窗口中,输入 HelloWorld 作为 项目名称。 (可选)将项目目录位置从默认位置 C:\Users\用户名\source\repos更改,然后选择 “下一步”。

    截图:Visual Studio 2022 中的“配置您的新项目”窗口,项目名称为 HelloWorld。

  4. 在 Additional information 窗口中, 验证 .NET 8.0是否显示在 Framework 菜单中,然后选择 Create。

    选择了 dot NET 8.0 的“其他信息”窗口的屏幕截图。

    Visual Studio创建项目。 该程序是一个简单的“Hello World”应用程序,它调用 Console.WriteLine() 方法,在控制台窗口中显示字符串Hello,World!。

    项目文件显示在Visual Studio IDE右侧,位于名为 解决方案资源管理器 的窗口中。 在 解决方案资源管理器 窗口中,选择 Program.vb 文件。 应用的Visual Basic代码将在中央编辑器窗口中打开,这将占用大部分空间。

    显示具有Program.vb代码的编辑器中Visual Studio IDE的截图。

    代码会自动着色以指示不同的部分,例如关键字和类型。 行号可帮助你查找代码。

    代码中的小型垂直虚线表示代码结构或一起排列的代码块。 还可以选择框中的小减号或加号以折叠或展开代码块。 此代码大纲显示功能允许隐藏不需要查看的代码,从而最大程度地减少屏幕上的杂乱无章。

    Screenshot,显示带有红色框的Visual Studio IDE。

    许多其他菜单和工具窗口都可用。

  5. 通过从Visual Studio 顶部菜单中选择调试>不带调试启动来启动应用程序。 还可以按 CtrlF5。

    显示“调试”菜单项中的“开始但不调试”的屏幕截图。

    Visual Studio生成应用,控制台窗口随即打开,消息Hello World!。 你现在有一个正在运行的应用!

    调试控制台窗口的截图,显示输出Hello World!,按任意键关闭此窗口。

  6. 若要关闭控制台窗口,请按任意键。

  7. 在Console.WriteLine("Hello World!")行前面添加以下Visual Basic代码:

    Console.WriteLine("What is your name?")
    Dim name = Console.ReadLine()
    

    此代码在控制台窗口中显示 你的姓名是什么?,然后等待用户输入一些文本。

  8. 将Console.WriteLine("Hello World!")的行更改为以下行:

    Console.WriteLine("Hello " + name + "!")
    
  9. 再次运行应用,可以选择 调试启动而不调试,或按 CtrlF5。

    Visual Studio重新生成应用,此时会打开控制台窗口并提示你输入名称。

  10. 在控制台窗口中键入名称,然后按 Enter。

    “调试控制台”窗口的屏幕截图,其中显示了名称、输入和输出 Hello Georgette 的提示。

  11. 按任意键关闭控制台窗口并停止正在运行的程序。

使用重构和 IntelliSense

下面是 重构和 IntelliSense 可帮助你更高效地编码的几种方法。

首先,重命名 变量:

  1. 双击 变量,然后键入变量的新名称,用户名。

    变量周围会显示一个框,边距中会显示一个图标。

  2. 选择图标显示可用的快速操作。 选择 将“name”重命名为“username”。

    显示 Visual Studio 中重命名操作的截图。

    显示 Visual Studio 2022 中的重命名操作的屏幕截图。

    变量在整个项目中重命名,在本例中只有两个地方。

现在看看 IntelliSense。

  1. 在显示 的代码行下方,键入以下代码:

    Dim now = Date.
    

    一个框显示 类的成员。 当前所选成员的说明也会显示在单独的框中。

    显示 Visual Studio 2022 中 IntelliSense 列表成员的截图。

  2. 选择名为 Now 的成员,该成员是类的属性。 双击“ 立即”,或选择它,然后按 Tab。

  3. 在该行下方,输入以下代码行:

    Dim dayOfYear = now.DayOfYear
    Console.Write("Day of year: ")
    Console.WriteLine(dayOfYear)
    

    Tip

    与 不同。 它打印后不会添加行终止符。 发送到输出的下一段文本将会在同一行内打印。 可以将鼠标悬停在代码中的每个方法上以查看其说明。

接下来,再次重构代码,使其更简洁。

  1. 选择行 中的变量 。 该行的边距中会显示一个灯泡图标。

  2. 选择灯泡图标以查看来自Visual Studio的可用建议。 本案例展示了如何通过使用内联临时变量 重构,在不改变整体代码行为的情况下,删除一行代码。

    截图显示了 Visual Studio 中的内联临时变量建议。

  3. 选择 内联临时变量 重构代码。

  4. 通过按 Ctrl F5再次运行程序。 输出的内容与以下类似:

    “调试控制台”窗口的屏幕截图,显示了输入名称的提示,输入和输出。

  1. 选择行 中的变量 。 该行的边距中会显示一个灯泡图标。

  2. 选择灯泡图标以查看来自Visual Studio的可用建议。 本案例展示了如何通过使用内联临时变量 重构,在不改变整体代码行为的情况下,删除一行代码。

    截图显示 Visual Studio 2022 中的内联临时变量建议。

  3. 选择 内联临时变量 重构代码。

  4. 通过按 Ctrl F5再次运行程序。 输出的内容与以下类似:

    2022年Visual Studio中调试控制台窗口的截图,显示名称提示、输入和输出。

调试代码

当你编写代码时,你应该运行它并测试和检查错误。 Visual Studio的调试系统允许你一次单步执行代码并检查变量。 可以设置 断点 停止在特定行执行代码,并观察变量值在代码运行时的变化情况。

设置断点以查看程序运行时 变量的值。

  1. 通过单击代码行旁边最左边距(或装订线),在代码行上设置一个断点,该断点表示 。 也可以选择代码行,然后按 F9。

    装订线中会出现一个红色圆圈,并突出显示该行。

    &lcc1;&lcc0;&lbsb0;该截图显示了 Visual Studio 中代码行上的一个断点。&lbsb0;&lcc0;&lcc1;

    截图,显示 Visual Studio 2022 中代码行上的断点。

  2. 选择“调试”“启动调试”或按 F5,开始调试。

  3. 当控制台窗口出现并请求你的姓名时,请输入你的姓名。

    焦点返回到Visual Studio中的代码编辑器。 带断点的代码行以黄色突出显示。 接下来将执行的代码行用黄色突出显示。 断点使应用在此行暂停执行。

  4. 将鼠标悬停在 变量上以查看其值。 您还可以右键单击,并选择添加监视,以将变量添加到监视窗口,您还可以在其中查看其值。

    显示在 Visual Studio 中调试过程中的变量值的截图。

    在 Visual Studio 2022 中显示变量值的屏幕截图。

  5. 再次按 F5 以完成应用运行。

在应用运行时,可以通过选择“热重载”按钮将代码更改应用到正在运行的应用。

在 Visual Studio 2026 中的热加载屏幕截图。

Visual Studio 2022中热重载的屏幕截图。

有关在 Visual Studio 中进行调试的详细信息,请参阅 Visual Studio 调试器的 Overview。