針對 Privileged Identity Management 中存取 Azure 資源遭拒的問題進行疑難排解
您在 Microsoft Entra ID 中使用 Privileged Identity Management (PIM) 上有問題嗎? 後續資訊可協助您重新運作項目。
拒絕存取 Azure 資源
問題
作為 Azure 資源的作用中擁有者或使用者存取管理員,您可以在 Privileged Identity Management 中看到您的資源,但無法執行任何動作,例如進行合格指派,或從資源概觀頁面檢視角色指派清單。 任何這些動作都會導致授權錯誤。
原因
當 PIM 服務主體的使用者存取管理員角色意外地從訂用帳戶中移除時,就會發生此問題。 若要讓 Privileged Identity Management 服務能夠存取 Azure 資源,MS-PIM 服務主體應一律獲派使用者存取管理員角色。
解決方法
將使用者存取管理員角色指派給訂用帳戶層級的 Privileged Identity Management 服務主體名稱 (MS-PIM)。 此指派應允許 Privileged Identity Management 服務存取 Azure 資源。 您可以根據您的需求,在管理群組層級或訂用帳戶層級上指派角色。 如需服務主體的詳細資訊,請參閱將應用程式指派給角色。