適用於:✔️ Windows VM
本文提供在 Azure VM 中套用安全策略時,OS 停止回應並變得沒有回應的問題的步驟。
徵兆
當您使用 開機診斷 來檢視 VM 的螢幕快照時,您會看到螢幕快照顯示作業系統在開機時卡住的訊息:
「將安全策略套用至系統」。
原因
此問題的潛在原因有很多。 在執行記憶體傾印分析之前,您將無法知道來源。
解決方法
處理序概觀
提示
如果您有最近的 VM 備份,您可以嘗試 從備份 還原 VM,以修正開機問題。
建立和存取修復 VM
- 使用 VM 修復命令的步驟 1-3 準備修復 VM。
- 使用遠端桌面連線連線至修復 VM。
啟用序列主控台和記憶體傾印收集
若要啟用記憶體轉儲集合和序列主控台,請遵循下列步驟:
以系統管理員身分開啟提升許可權的命令提示字元會話。
使用 /ems 和 /emssettings 選項執行下列 BCDEdit 命令:
啟用序列主控台:
bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /ems {<boot-loader-identifier>} ON bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /emssettings EMSPORT:1 EMSBAUDRATE:115200
確認OS磁碟上的可用空間大於VM上的記憶體大小(RAM)。
如果 OS 磁碟上沒有足夠的空間,請變更建立記憶體轉儲檔案的位置,並將該位置參考連結至 VM 且有足夠的可用空間的任何數據磁碟。 若要變更位置,請將 取代
%SystemRoot%
為數據磁碟的驅動器號,例如F:
,在下列命令中。若要啟用 OS 傾印檔案,請使用 reg 工具執行下列載入、新增和卸除命令,以實作建議的組態:
從中斷的 OS 磁碟載入登錄區:
reg load HKLM\<broken-system> <volume-letter-of-broken-os-disk>:\windows\system32\config\SYSTEM
在 ControlSet001 上啟用:
reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
在 ControlSet002 上啟用:
reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
卸除中斷的 OS 磁碟:
reg unload HKLM\<broken-system>
重建 VM
使用 VM 修復命令的步驟 5 重新組裝 VM。
收集記憶體轉儲檔案
若要解決此問題,您必須先收集損毀的記憶體轉儲檔案,並連絡支持人員與記憶體轉儲檔案。 若要收集傾印檔案,請遵循下列步驟:
第 1 部分:將 OS 磁碟連結至復原 VM
擷取受影響 VM 的 OS 磁碟快照集以建立備份。 如需詳細資訊,請參閱 建立虛擬硬碟的快照集。
使用遠端桌面通訊協定 (RDP) 從遠端連線到復原 VM。
如果受影響 VM 的 OS 磁碟已加密,請先關閉加密,再移至下一個步驟。 如需詳細資訊,請參閱 解密加密的OS磁碟。
第 2 部分:找出傾印檔案並提交支援票證
在復原 VM 上,移至 連結 OS 磁碟上的 Windows 資料夾。 例如,如果指派給連結 OS 磁碟的驅動器號是 F,請移至 F:\Windows。
找出Memory.dmp檔案,然後提交支援票證並附加傾印檔案。
下一步
如果您在套用本機使用者和組策略時發生問題,請參閱 套用組策略本機使用者和組策略時 VM 沒有回應。
與我們連絡,以取得說明
如果您有問題或需要相關協助,請建立支援要求,或詢問 Azure community 支援。 您也可以向 Azure 意見反應社群提交產品意見反應。