WinML 儀錶板

WinML 儀錶板是檢視、編輯、轉換及驗證 Windows ML 推斷引擎機器學習模型的工具。 引擎內建於 Windows 10 中,並使用 CPU 和 GPU 的硬體優化在 Windows 裝置上對已訓練模型進行高效能推斷。

取得工具

您可以 在這裡下載 WinML 儀錶板,或遵循下列指示,從來源建置應用程式。

從來源建置

從來源建置應用程式時,您需要以下項目:

需求 版本 下載 檢查指令
Python3 3.4+ 這裡 python --version
紗線 最新 這裡 yarn --version
Node.js 最新 這裡 node --version
Git(分散式版本控制系統) 最新 這裡 git --version
MSBuild 最新 這裡 msbuild -version
Nuget 最新 這裡 nuget help

所有六個必要條件 都必須新增至環境路徑。 請注意,MSBuild 和 Nuget 將會包含在 Visual Studio 2017 安裝中。

建置和執行的步驟

若要執行 WinML 儀錶板,請遵循下列步驟:

  1. 在命令列中,複製存放庫: git clone https://github.com/Microsoft/Windows-Machine-Learning
  2. 在存放庫中,輸入下列命令以存取正確的資料夾: cd Tools/WinMLDashboard
  3. 執行 git submodule update --init --recursive 以更新 Netron。
  4. 執行 "yarn" 以下載依賴項。
  5. 然後,執行 yarn electron-prod 以建置並啟動桌面應用程式,這會啟動儀錶板。

您可以在 package.json看到所有可用的儀錶板命令。

檢視和編輯模型

儀錶板會使用 Netron 來檢視機器學習模型。 雖然 WinML 使用 ONNX 格式,但 Netron 查看器支援檢視數種不同的架構格式。

開發人員可能需要更新特定模型元數據,或修改模型輸入和輸出節點多次。 此工具支援修改 ONNX 模型的模型屬性、元數據和輸入/輸出節點。

選取 Edit 標籤(如下方螢幕快照中的正上方所示)會帶您到檢視和編輯面板。 面板中的左窗格允許編輯模型輸入和輸出節點,而右窗格則允許編輯模型屬性。 中央部分會顯示圖表。 目前,編輯支援僅限於模型輸入/輸出節點(而非內部節點)、模型屬性和模型元數據。

按鈕會 Edit/View 從 [編輯模式 ] 切換為 [僅限檢視] 模式,反之亦然。 僅限檢視模式 不允許編輯並啟用 Netron 檢視器的原生功能,例如查看每個節點的詳細資訊。

檢視和編輯模型

轉換模型

目前有數個不同的架構可用於定型和評估機器學習模型,這讓應用程式開發人員難以將模型匯入其產品。 Windows ML 使用 ONNX 機器學習模型格式 ,允許從某個架構格式轉換成另一種格式,而此儀錶板可讓您輕鬆地將模型從不同的架構轉換成 ONNX。

轉換標籤支援從下列來源架構轉換為 ONNX。

  • Apple Core 機器學習
  • TensorFlow (可轉換成 ONNX 的模型子集)
  • Keras
  • Scikit-learn (可轉換成 ONNX 的模型子集)
  • Xgboost
  • LibSVM

此工具也可藉由使用綜合數據(預設值)或 CPU 或 GPU 上的實際輸入數據,使用內建的 Windows ML 推斷引擎來評估模型,以驗證已轉換的模型。

轉換模型

驗證模型

擁有 ONNX 模型之後,您可以驗證轉換是否成功發生,而且可以在 Windows ML 推斷引擎中評估模型。 這是使用 Run 標籤頁完成的(請參閱下方的截圖)。

您可以選擇各種選項,例如 CPU(預設值)與 GPU、實際輸入與綜合輸入 (預設值) 等。模型評估的結果會出現在底部的控制台視窗中。

請注意,模型驗證功能僅適用於 Windows 10 2018 年 10 月更新 或更新版本的 Windows 10,因為此工具依賴內建的 Windows ML 推斷引擎。

驗證模型

除錯推理

您可以使用 WinML 儀錶板的偵錯功能,深入瞭解原始數據如何流經模型中的運算符。 您也可以選擇將此數據視覺化,以進行電腦視覺推斷。

若要對模型進行偵錯,請遵循下列步驟:

  1. 導航至 Edit 標籤,然後選取您想要擷取中間數據的運算符。 在左側面板上,會有一個 Debug 功能表,您可以在其中選取您想要擷取的元數據格式。 選項目前為 文字 和 PNG。 文字 會輸出文本檔,其中包含這個運算子所產生的維度、數據類型和原始張量數據。 PNG 會將此數據格式化為圖像檔,這對電腦視覺應用程式很有用。

對模型進行偵錯

  1. 導覽至 Run 索引標籤,然後選取您想要偵錯的模型。
  2. 針對Capture欄位,從下拉式清單中選取Debug。
  3. 選取輸入影像或 csv 檔案,以在執行過程中提供給您的模型。 請注意,擷取偵錯數據時,這是必要的。
  4. 選取輸出資料夾以匯出偵錯數據。
  5. 選取 Run。 執行完成後,您可以流覽至此選取的資料夾,以檢視您的偵錯擷取。

執行模型

您也可以使用下列其中一個選項,在電子應用程式中開啟偵錯檢視:

  • 使用 flag --dev-tools 執行
  • 或在應用程式選單中選取View -> Toggle Dev Tools
  • 或按 Ctrl + Shift + I。