Poznámka:
Přístup k této stránce vyžaduje autorizaci. Můžete se zkusit přihlásit nebo změnit adresáře.
Přístup k této stránce vyžaduje autorizaci. Můžete zkusit změnit adresáře.
V tomto rychlém zprovoznění vytvoříte v Azure prostředek Elastic a nakonfigurujete ho tak, aby začal shromažďovat protokoly z vašeho prostředí Azure.
Co očekávat
Po dokončení tohoto rychlého startu máte:
- Elastický prostředek (
Microsoft.Elastic/monitors) ve zvolené skupině prostředků - Elastické nasazení (bezserverové nebo hostované v cloudu) spuštěné ve vybrané Azure oblasti
- (Volitelné) Protokoly aktivit předplatného Azure a protokoly prostředků odesílané do Elastic
- (Volitelné) Azure OpenAI připojené pro funkce vyhledávání využívající AI
- Jednotné přihlašování je povolené automaticky pro všechny uživatele Azure ve vašem tenantovi.
Požadavky
- Vyžaduje se účet Azure s aktivním předplatným. Pokud ho nemáte, vytvořte si účet zdarma.
- Role vlastníka nebo přispěvatele pro vaše předplatné Azure. Integraci partnerských služeb pro vaše předplatné Azure můžou nastavit jenom uživatelé, kteří mají přiřazenou jednu z těchto rolí. Než začnete, ověřte, že máte odpovídající přístup.
Poznámka:
Daná e-mailová adresa může být současně jen součástí jedné elastické organizace. Když v Azure vytvoříte první prostředek Elastic pomocí nové e-mailové adresy, vytvoří se současně s vaším prvním nasazením nebo bezserverovým projektem také nová organizace. U dalších prostředků vytvořených pomocí stejné e-mailové adresy budou všechna nasazení a projekty patřit do stejné organizace.
Poznámka:
Jednotné přihlašování (SSO) mezi portálem Azure a elastickým cloudem je automaticky povolené pro všechny uživatele Azure. Nevyžaduje se žádná další konfigurace.
Important
Bezplatné kredity Azure a většinu bezplatných zkušebních nabídek Azure nelze použít k nákupu nabídek třetích stran v Azure Marketplace, včetně Elastic. Vaše elastické poplatky se účtují podle způsobu platby, který podporuje nákupy na Marketplace (například předplatné s průběžnými platbami nebo smlouva Enterprise). Podrobnosti najdete v článku Vysvětlení poplatků za Azure Marketplace.
Volba elastické služby
Elastic on Azure nabízí tři služby. Vyberte kartu, která odpovídá vašemu scénáři použití:
| Service | Nejlepší pro |
|---|---|
| Elastické vyhledávání | Fulltextové vyhledávání, vektorové vyhledávání, vyhledávání aplikací, analýza |
| Elastická pozorovatelnost | Log Analytics, APM, monitorování infrastruktury, upozorňování |
| Elastické zabezpečení | SIEM, detekce hrozeb, ochrana koncových bodů, dodržování předpisů |
Vytvoření Elastic prostředku
Pracovní postup vytváření můžete spustit z některého z vstupních bodů:
Azure Portal: otevřete stránku pro procházení prostředků Elastic a vyberte Vytvořit.
Azure Marketplace: otevřete nabídku, která odpovídá zvolené službě, a vyberte Get It Now.
Případně na globálním panelu vyhledávání portálu Azure portal vyhledejte Elastic Cloud a vyberte odpovídající službu.
Vyberte Elastic Search.
Záložka Základy
Na kartě Základy zadejte hodnoty pro nastavení:
Pole Činnost Předplatné V možnostech vyberte předplatné. Musíte být vlastníkem nebo přispěvatelem. Skupina zdrojů Použijte existující skupinu prostředků, nebo vytvořte novou. Název prostředku Zadejte jedinečný název prostředku. Typ hostingu Vyberte bezserverový server nebo hostovaný v cloudu. Pokyny najdete v tématu Bezserverové versus hostované v cloudu . Konfigurace (jenom bez serveru ) Vyberte Obecné účely nebo Optimalizováno pro vektory. Pokud plánujete použít vektorové vyhledávání nebo sémantické vyhledávání, zvolte Vektory. Región Vyberte oblast, do které chcete prostředek nasadit. Verze (pouze hostovaná v cloudu ) Vyberte verzi Elasticsearch. Velikost (pouze hostovaná v cloudu ) Zkontrolujte velikost a konfiguraci clusteru. Plán Pokud chcete zvolit jiný plán, vyberte Změnit plán. Fakturační období Vyberte měsíční nebo roční fakturaci. Cena a možnosti platby Projděte si podrobnosti o cenách vaší konfigurace. V dolní části stránky vyberte Další: Protokoly a metriky.
Karta Protokoly a metriky (volitelné)
Nakonfigurujte, které prostředky Azure odesílají protokoly do Elastic. Tato nastavení můžete kdykoli změnit po vytvoření.
| Setting | Jak funguje |
|---|---|
| Odesílání protokolů aktivit předplatného | Předává operace roviny správy (vytváření prostředků, odstraňování prostředků, přiřazování rolí) do Elastic. |
| Odeslat protokoly prostředků Azure pro všechny definované zdroje | Předává diagnostické protokoly z podporovaných Azure prostředků do Elastic. |
U typů prostředků pozorovatelnosti a zabezpečení je ve výchozím nastavení povolené předávání protokolů.
Můžete upřesnit, které prostředky odesílají protokoly, zadáním pravidel zahrnutí/vyloučení založených na značkách v části Protokoly. Další informace najdete v pravidlech značek pro odesílání protokolů.
Poznámka:
Automatické shromažďování metrik se zatím nepodporuje. Informace o tom, jak odesílat metriky služeb Azure do Elasticu, najdete v dokumentaci Elastic v části integrace metrik Azure.
V dolní části stránky vyberte Další: Konfigurace Azure OpenAI.
Karta Konfigurace Azure OpenAI
Připojte prostředek Azure OpenAI a povolte možnosti vyhledávání využívající umělou inteligenci, jako je sémantické vyhledávání a generování rozšířené o načítání (RAG).
Vyberte existující prostředek Azure OpenAI.
Vyberte nasazení Azure OpenAI, které již existuje.
Tip
Tento krok můžete přeskočit a nakonfigurovat Azure OpenAI později z prostředí pro správu. Viz Správa prostředku Elastic.
V dolní části stránky vyberte Další: Značky.
Záložka Štítky (volitelné)
Volitelně můžete pro své prostředky vytvořit tagy. Pak vyberte Zkontrolovat a vytvořit.
Záložka Zkontrolovat a vytvořit
Pokud kontrola nenajde žádné chyby, aktivuje se tlačítko Vytvořit . Vyberte Vytvořit.
Pokud kontrola identifikuje chyby, zobrazí se vedle každé části, kde existují chyby, červená tečka. Oprava chyb:
Otevřete každou část s chybami a opravte chyby.
Pole s chybami jsou zvýrazněná červeně.
Znovu vyberte Zkontrolovat a vytvořit .
Vyberte Vytvořit.
Zobrazí se zpráva "Probíhá nasazení". Po dokončení nasazení se v pravém horním rohu webu Azure Portal zobrazí zpráva Vaše nasazení je dokončené.
Po vytvoření prostředku vyberte Přejít k prostředku a zobrazte prostředek.
Vyberte Elastic Observabilita.
Záložka Základy
Na kartě Základy zadejte hodnoty pro nastavení:
Pole Činnost Předplatné V možnostech vyberte předplatné. Musíte být vlastníkem nebo přispěvatelem. Skupina zdrojů Použijte existující skupinu prostředků, nebo vytvořte novou. Název prostředku Zadejte jedinečný název prostředku. Typ hostingu Vyberte bezserverový server nebo hostovaný v cloudu. Pokyny najdete v tématu Bezserverové versus hostované v cloudu . Región Vyberte oblast, do které chcete prostředek nasadit. Verze (pouze hostovaná v cloudu ) Vyberte verzi Elasticsearch. Velikost (pouze hostovaná v cloudu ) Zkontrolujte velikost a konfiguraci clusteru. Plán Pokud chcete zvolit jiný plán, vyberte Změnit plán. Fakturační období Vyberte měsíční nebo roční fakturaci. Cena a možnosti platby Projděte si podrobnosti o cenách vaší konfigurace. V dolní části stránky vyberte Další: Protokoly a metriky.
Karta Protokoly a metriky (volitelné)
Nakonfigurujte, které Azure prostředky odesílají protokoly a metriky do Elastic. Tato nastavení můžete kdykoli změnit po vytvoření. Podrobnosti o tom, co se přeposílá, a příklady zahrnutí a vyloučení najdete v tématech pravidla značek pro odesílání metrik a pravidla značek pro odesílání logů v článku Monitorování a sledování prostředků Azure pomocí nativních integrací Azure.
| Setting | Jak funguje |
|---|---|
| Odesílání protokolů aktivit předplatného | Předává operace roviny správy do platformy Elastic. |
| Odeslat protokoly prostředků Azure pro všechny definované zdroje | Předává diagnostické protokoly z podporovaných Azure prostředků do Elastic (ve výchozím nastavení povoleno). |
Můžete upřesnit, které prostředky odesílají protokoly, zadáním pravidel zahrnutí/vyloučení založených na značkách v části Protokoly.
Poznámka:
Automatické shromažďování metrik se zatím nepodporuje. Informace o tom, jak odesílat metriky služeb Azure do Elasticu, najdete v dokumentaci Elastic v části integrace metrik Azure.
V dolní části stránky vyberte Další: Konfigurace Azure OpenAI.
Karta Konfigurace Azure OpenAI
Připojte prostředek Azure OpenAI a povolte analýzu dat pozorovatelnosti s asistencí umělé inteligence.
Vyberte existující prostředek Azure OpenAI.
Vyberte nasazení Azure OpenAI, které již existuje.
V dolní části stránky vyberte Další: Značky.
Záložka Štítky (volitelné)
Volitelně můžete pro své prostředky vytvořit tagy. Pak vyberte Zkontrolovat a vytvořit.
Záložka Zkontrolovat a vytvořit
Pokud kontrola nenajde žádné chyby, aktivuje se tlačítko Vytvořit . Vyberte Vytvořit.
Pokud kontrola identifikuje chyby, zobrazí se vedle každé části, kde existují chyby, červená tečka. Oprava chyb:
Otevřete každou část s chybami a opravte chyby.
Pole s chybami jsou zvýrazněná červeně.
Znovu vyberte Zkontrolovat a vytvořit .
Vyberte Vytvořit.
Zobrazí se zpráva "Probíhá nasazení". Po dokončení nasazení se v pravém horním rohu webu Azure Portal zobrazí zpráva Vaše nasazení je dokončené.
Po vytvoření prostředku vyberte Přejít k prostředku a zobrazte prostředek.
Vyberte elastické zabezpečení.
Záložka Základy
Na kartě Základy zadejte hodnoty pro nastavení:
Pole Činnost Předplatné V možnostech vyberte předplatné. Musíte být vlastníkem nebo přispěvatelem. Skupina zdrojů Použijte existující skupinu prostředků, nebo vytvořte novou. Název prostředku Zadejte jedinečný název prostředku. Typ hostingu Vyberte bezserverový server nebo hostovaný v cloudu. Pokyny najdete v tématu Bezserverové versus hostované v cloudu . Región Vyberte oblast, do které chcete prostředek nasadit. Verze (pouze hostovaná v cloudu ) Vyberte verzi Elasticsearch. Velikost (pouze hostovaná v cloudu ) Zkontrolujte velikost a konfiguraci clusteru. Plán Pokud chcete zvolit jiný plán, vyberte Změnit plán. Fakturační období Vyberte měsíční nebo roční fakturaci. Cena a možnosti platby Projděte si podrobnosti o cenách vaší konfigurace. V dolní části stránky vyberte Další: Protokoly a metriky.
Karta Protokoly a metriky (volitelné)
Nakonfigurujte, které prostředky Azure odesílají do Elastic protokoly související se zabezpečením. Tato nastavení můžete kdykoli změnit po vytvoření.
| Setting | Jak funguje |
|---|---|
| Odesílání protokolů aktivit předplatného | Přeposílá operace roviny správy pro účely bezpečnostního auditu. |
| Odeslat protokoly prostředků Azure pro všechny definované zdroje | Předává diagnostické protokoly pro analýzu zabezpečení (ve výchozím nastavení povoleno) |
Můžete upřesnit, které prostředky odesílají protokoly, zadáním pravidel zahrnutí/vyloučení založených na značkách v části Protokoly. Další informace najdete v pravidlech značek pro odesílání protokolů.
Poznámka:
Automatické shromažďování metrik se zatím nepodporuje. Informace o tom, jak odesílat metriky služeb Azure do Elasticu, najdete v dokumentaci Elastic v části integrace metrik Azure.
V dolní části stránky vyberte Další: Konfigurace Azure OpenAI.
Karta Konfigurace Azure OpenAI
Připojte prostředek Azure OpenAI a povolte analýzu zabezpečení s asistencí AI a šetření hrozeb.
Vyberte existující prostředek Azure OpenAI.
Vyberte nasazení Azure OpenAI, které již existuje.
V dolní části stránky vyberte Další: Značky.
Záložka Štítky (volitelné)
Volitelně můžete pro své prostředky vytvořit tagy. Pak vyberte Zkontrolovat a vytvořit.
Záložka Zkontrolovat a vytvořit
Pokud kontrola nenajde žádné chyby, aktivuje se tlačítko Vytvořit . Vyberte Vytvořit.
Pokud kontrola identifikuje chyby, zobrazí se vedle každé části, kde existují chyby, červená tečka. Oprava chyb:
Otevřete každou část s chybami a opravte chyby.
Pole s chybami jsou zvýrazněná červeně.
Znovu vyberte Zkontrolovat a vytvořit .
Vyberte Vytvořit.
Zobrazí se zpráva "Probíhá nasazení". Po dokončení nasazení se v pravém horním rohu webu Azure Portal zobrazí zpráva Vaše nasazení je dokončené.
Po vytvoření prostředku vyberte Přejít k prostředku a zobrazte prostředek.
Ověřte své nasazení
Po vytvoření prostředku:
- Na portálu Azure přejděte ke svému prostředku Elastic.
- V podokně Přehled potvrďte, že se Stav zobrazuje jako Aktivní.
- Výběrem odkazu na portál Elastic otevřete nasazení Elastic.
- Na elastickém portálu ověřte, že data přicházejí (počkejte několik minut na počáteční příjem dat).
Tip
Pokud se záznamy po 10 minutách stále nezobrazují, přečtěte si Řešení potíží, kde najdete běžné příčiny a jejich řešení.