Použijte Azure Digital Twins Explorer (náhled)

Azure Digital Twins Explorer (Preview) je nástroj pro vizualizaci a práci s Azure Digital Twins. Tento článek popisuje funkce Průzkumníka služby Azure Digital Twins a jejich použití ke správě dat v instanci služby Azure Digital Twins. S Průzkumníkem služby Azure Digital Twins můžete pracovat pomocí výběru obrazovky nebo klávesových zkratek.

Jak získat přístup

Hlavním způsobem, jak získat přístup k Průzkumníku služby Azure Digital Twins, je prostřednictvím webu Azure Portal.

Pokud chcete otevřít Průzkumníka služby Azure Digital Twins pro instanci Azure Digital Twins, přejděte nejprve na instanci na portálu tak, že vyhledáte jeho název na panelu hledání na portálu.

Pak vyberte tlačítko Otevřít Azure Digital Twins Explorer (Preview).

Snímek obrazovky portálu Azure ukazující stránku Přehled pro instanci Azure Digital Twins. Kolem tlačítka Otevřít Azure Digital Twins Explorer (náhled) je zvýraznění.

Tato akce otevře Průzkumníka služby Azure Digital Twins na nové kartě. Pokud používáte Průzkumníka poprvé, uvidíte uvítací okno s přehledem klíčových funkcí Exploreru.

Azure Digital Twins Explorer se může automaticky připojit k vaší instanci. Pokud ne, zobrazí se následující obrazovka s výzvou k zadání adresy URL služby Azure Digital Twins. (Pokud toto pole na obrazovce nevidíte, Azure Digital Twins Explorer tento krok dokončil automaticky.)

Snímek obrazovky Průzkumníka služby Azure Digital Twins. Modální dialog pro adresu URL služby Azure Digital Twins zobrazuje prázdné upravitelné pole pro zadání této adresy URL.

Pokud se zobrazí toto pole, zadejte do pole https:// a za ním název hostitele vaší instance (tuto hodnotu najdete zpět na stránce přehledu instance na portálu). Tyto hodnoty společně tvoří adresu URL instance. Vyberte Uložit, abyste se připojili k vaší instanci.

Důležité

Azure Digital Twins Explorer nepodporuje privátní koncové body. Pokud chcete použít Průzkumníka služby Azure Digital Twins s instancí Azure Digital Twins, která používá službu Private Link k zakázání veřejného přístupu, můžete nasadit základ kódu Azure Digital Twins Exploreru soukromě v cloudu. Návod, jak na to, najdete v článku Azure Digital Twins Explorer: Běh v cloudu.

Přepínání kontextů v aplikaci

Jakmile v aplikaci vyberete název instance z horního panelu nástrojů, můžete také změnit, která instance je aktuálně připojená k průzkumníkovi.

Snímek obrazovky s Průzkumníkem služby Azure Digital Twins Název instance na horním panelu nástrojů je zvýrazněný.

Tím se zobrazí modální adresa URL služby Azure Digital Twins, kde za předponu pro připojení k této instanci můžete zadat název hostitele jiné instance https:// služby Azure Digital Twins.

Snímek obrazovky Průzkumníka služby Azure Digital Twins. Modální okno s adresou URL služby Azure Digital Twins zobrazuje upravitelné pole obsahující https:// a název hostitele.

Poznámka:

V tuto chvíli není možnost přepínat kontexty v aplikaci pro osobní účty Microsoft (MSA). Uživatelé MSA potřebují získat přístup k průzkumníkovi z vybrané instance na webu Azure Portal nebo se můžou k určité instanci připojit přes přímý odkaz na prostředí.

Dotazování grafu digitálního dvojčete

Pomocí panelu Průzkumník dotazů můžete spouštět dotazy v grafu.

Snímek obrazovky Azure Digital Twins Explorer. Panel Průzkumník dotazů je zvýrazněn.

Zadejte dotaz, který chcete spustit. Pokud chcete zadat dotaz do více řádků, můžete do pole dotazu přidat nový řádek pomocí kombinace kláves SHIFT+ENTER.

Výběrem tlačítka „Spustit dotaz“ zobrazte výsledky dotazu v panelu Twin Graph.

Poznámka:

Výsledky dotazu obsahující relace lze vykreslit pouze na panelu Graf dvojčat, pokud výsledky obsahují alespoň jedno dvojče. I když dotazy, které vracejí jenom relace, jsou ve službě Azure Digital Twins možné, můžete je zobrazit jenom v Průzkumníku služby Azure Digital Twins pomocí panelu Výstup.

Překryvné výsledky dotazu

Před spuštěním dotazu můžete zaškrtnout políčko Výsledky překrytí, pokud chcete, aby byly zvýrazněny výsledky z toho, co se právě zobrazuje na panelu Dvojitý graf, místo aby byl obsah panelu úplně nahrazen novými výsledky dotazu.

Snímek obrazovky panelu Průzkumníka dotazů Azure Digital Twins Explorer. Políčko Překryvné výsledky je zaškrtnuté a ve větším grafu zobrazeném na panelu Graf dvojčat jsou zvýrazněná dvě dvojčata.

Pokud výsledek dotazu obsahuje něco, co se aktuálně nezobrazuje na panelu Twin Graph , přidá se prvek do existujícího zobrazení.

Uložení a opětovné spuštění dotazů

Dotazy je možné uložit v místním úložišti v prohlížeči, což usnadňuje jejich výběr a opětovné spuštění.

Poznámka:

Místní úložiště prohlížeče znamená, že uložené dotazy nejsou dostupné v jiných prohlížečích než v prohlížečích, ve kterých jste je uložili. Dotazy uložené v místním úložišti prohlížeče zůstanou po neomezenou dobu, dokud se místní úložiště nevymaže.

Pokud chcete dotaz uložit, zadejte ho do pole dotazu a vyberte ikonu Uložit v pravé části panelu. Po zobrazení výzvy zadejte název uloženého dotazu.

Snímek obrazovky s panelem Průzkumníka dotazů Azure Digital Twins Ikona Uložit je zvýrazněná.

Jakmile je dotaz uložený, můžete ho vybrat z rozevírací nabídky Uložené dotazy a snadno ho spustit znovu.

Snímek obrazovky s panelem Průzkumníka dotazů Azure Digital Twins Rozevírací nabídka Uložené dotazy je zvýrazněná a zobrazuje dva ukázkové dotazy.

Pokud chcete odstranit uložený dotaz, vyberte při otevření rozevírací nabídky Uložené dotazy ikonu X vedle názvu dotazu.

Návod

U velkých grafů doporučujeme dotazovat pouze omezenou podmnožinu a potom podle potřeby načíst zbytek grafu. Poklikáním na dvojici v panelu Graf dvojčat můžete načíst další související uzly.

Prozkoumejte Twin Graph

Panel Twin Graph umožňuje prozkoumat dvojčata a vztahy ve vaší instanci.

Snímek obrazovky Azure Digital Twins Explorer. Panel Twin Graph je zvýrazněný.

Pomocí tohoto panelu můžete zkoumat data dvojčat.

Panel Twin Graph nabízí také několik možností přizpůsobení zobrazení grafu:

Prozkoumání dat dvojčat

Spuštěním dotazu pomocí Průzkumníka dotazů zobrazíte dvojčata a relace ve výsledku dotazu zobrazeném na panelu Twin Graph.

Návod

Dotaz, který zobrazí všechna dvojčata a relace, je SELECT * FROM digitaltwins.

Zobrazení vlastností dvojčat a relací

Pokud chcete zobrazit hodnoty vlastností dvojčete nebo relace, vyberte dvojče nebo relaci v grafu dvojčete a pomocí tlačítka Přepnout zobrazení vlastností rozbalte panel Vlastnosti dvojčete nebo panel Vlastností relace. Tento panel zobrazí všechny vlastnosti přidružené k prvku spolu s jejich hodnotami. Obsahuje také výchozí hodnoty vlastností, které ještě nejsou nastavené.

Snímek obrazovky s panelem Twin Graph v Azure Digital Twins Explorer. Je vybrána dvojice FactoryA a je rozbalen panel Vlastnosti dvojice, který ukazuje vlastnosti dvojice.

Ikony datového typu

Vlastnosti zobrazené na panelech Vlastnosti dvojčat a Vlastnosti relací jsou každá zobrazena s ikonou, která označuje typ pole z modelu DTDL. Když najedete myší na ikonu, zobrazí se přidružený typ.

Následující tabulka ukazuje možné datové typy a jejich odpovídající ikony. Tabulka obsahuje také odkazy z každého datového typu na popis schématu v popisu jazyka DTDL v3.

Ikona Datový typ
logická ikona booleovský
Ikona komponenty komponenta
Ikona data datum
Ikona dateTime dateTime
Ikona doby trvání trvání
Ikona enum výčet
ikona mapy mapa
numerická ikona Číselné typy, včetně dvojitého, plovoucího, celočíselného a dlouhého
Ikona objektu objekt
Ikona řetězce řetězec
Ikona času Čas
Chyby

Panel Vlastnosti dvojčete zobrazí chybové zprávy, pokud dvojče nebo některé jeho vlastnosti již neodpovídají jeho modelu.

Existují dva možné chybové scénáře, které každá z nich poskytuje vlastní chybovou zprávu:

  • Chybí jeden nebo mnoho modelů používaných dvojčetem. V důsledku toho jsou všechny vlastnosti přidružené k danému modelu označeny jako "chybějící" na panelu Vlastnosti dvojčete. K této chybě může dojít, pokud byl model odstraněn poté, co bylo vytvořeno dvojče.
  • Některé vlastnosti dvojčete nejsou součástí modelu dvojčete. Na panelu Vlastnosti dvojčete se označí jako chybějící pouze tyto vlastnosti. K této chybě může dojít, pokud je model dvojčete nahrazen nebo změněn od nastavení vlastností a vlastnosti již neexistují v nejnovější verzi modelu.

Obě tyto chybové zprávy se zobrazují na následujícím snímku obrazovky:

Snímek obrazovky s panelem Vlastností dvojčete Azure Digital Twins Exploreru se dvěma chybovými zprávami Jedna chyba značí, že modely chybí, a druhá značí, že v modelu chybí vlastnosti.

Ověření a prozkoumání historizovaných vlastností

Pokud má vaše instance Azure Digital Twins povolenou historii dat, můžete ověřit a prozkoumat její historizovaná data v Průzkumníku služby Azure Digital Twins. Pomocí následujících kroků vizualizovat historizovaná data v grafu nebo zobrazit nezpracované hodnoty v tabulce.

  1. V prohlížeči Twin Graph vyberte dvojče, jehož historizované vlastnosti chcete zobrazit, aby se otevřela na panelu Vlastnosti dvojčete. V pravém horním rohu panelu výběrem ikony Časové řady otevřete Průzkumníka historie dat.

    Snímek obrazovky s panelem Vlastností dvojčete Azure Digital Twins Explorer, zvýrazněnou ikonou otevřít průzkumníka historie dat.

  2. Výběrem názvu dvojčete zleva zobrazíte možnosti pro výběr historických vlastností dvojčete, které se mají zobrazit. Pole ID dvojčete je předem vyplněno výběrem dvojčete. Vedle tohoto pole můžete výběrem ikony Zkontrolovat vlastnosti zobrazit data dvojčete nebo ikonu rozšířeného vyhledávání dvojčete a vyhledat další dvojčata dotazováním hodnot vlastností.

    Snímek obrazovky průzkumníka historie dat a modálního okna s dotazem na podrobnosti o dvojčeti a vlastnostech.

  3. V poli Vlastnost vyberte vlastnost, jejíž historizovaná data chcete zobrazit. Pokud tato vlastnost není číselná, ale skládá se z číselných hodnot, použijte možnost Přetypovat hodnotu vlastnosti na číslo k přetypování těchto dat na čísla, aby je bylo možné vizualizovat v grafu.

    Snímek obrazovky Průzkumníka historie dat se zvýrazněnými podrobnostmi o vlastnostech.

    Poznámka:

    Pokud nemůžete vybrat vlastnost z rozevíracího seznamu, protože seznam neodpovídá, může to znamenat, že v některém modelu ve vaší instanci došlo k chybě. Například neunikátní výčtové hodnoty ve výčtech atributů modelu naruší tuto vlastnost. Pokud k této chybě dojde, zkontrolujte definice modelu a ujistěte se, že jsou všechny vlastnosti platné.

  4. Zvolte popisek časové řady a vyberte Aktualizovat.

Tato akce načte zobrazení grafu historizovaných hodnot pro vybranou vlastnost. Pomocí karet nad grafem můžete přepínat mezi zobrazením grafu a zobrazením tabulky.

Pokud chcete do vizualizace přidat další vlastnosti, použijte tlačítko Přidat časová řada v levém podokně.

Snímek obrazovky s průzkumníkem historie dat, který zvýrazňuje možnost pro přidání další časové řady

Pokud chcete průzkumníka historie dat ukončit a vrátit se do hlavního Průzkumníka služby Azure Digital Twins, vyberte Zavřít.

Zobrazení historie v grafu

Grafový pohled historizovaných vlastností zobrazuje hodnoty vlastností jako body spojnicového grafu v průběhu času.

Snímek obrazovky Průzkumníka historie dat zobrazující graf historizovaných hodnot pro vlastnost

Pomocí ikon nad grafem můžete řídit nastavení grafu, včetně...

  • změna časového rozsahu dat zahrnutých v grafu.
  • výběr toho, zda se více časových řad zobrazuje nezávisle nebo na sdílené ose y. Výběr možnosti Nezávislá na osách znamená, že každá časová řada se škáluje podle grafu a udržuje vlastní osu pro měřítko. Výběr sdílených os znamená, že všechna data časových řad se škálují na stejnou osu.
  • výběr logiky agregace pro graf Pokud vlastnost obsahuje více datových bodů, než je možné zobrazit v grafu, data se agregují do konečného počtu datových bodů pomocí průměrných, minimálních nebo maximálních funkcí.

K dispozici je také tlačítko pro otevření dotazu v Azure Data Exploreru, kde můžete zobrazit a upravit aktuální dotaz, aby se data časových řad dále prozkoumala.

Snímek obrazovky s tlačítkem pro otevření dotazu v Azure Data Exploreru

Zobrazení historie v tabulce

Zobrazení tabulky historizovaných vlastností zobrazuje hodnoty vlastností a jejich časová razítka v tabulce.

Snímek obrazovky Průzkumníka historie dat zobrazující tabulku historizovaných hodnot pro vlastnost

Pomocí ikon nad tabulkou můžete řídit nastavení tabulky, včetně...

  • změna časového rozsahu dat zahrnutých v tabulce.
  • stažení dat tabulky pro nezávislou analýzu.

Zobrazení vztahů dvojčete

Můžete také rychle zobrazit kód všech relací, které zahrnují určité dvojče (včetně příchozích a odchozích relací).

Pravým tlačítkem myši klikněte na dvojče v grafu a zvolte Získat relace. Tím se zobrazí modální informace o relaci zobrazující reprezentaci JSON všech příchozích a odchozích relací.

Snímek obrazovky s panelem Azure Digital Twins Explorer Twin Graph. Uprostřed obrazovky se zobrazí modální okno informací o vztazích, které zobrazuje příchozí a odchozí vztahy.

Změna vlastnosti zobrazení dvojčete

Můžete nakonfigurovat, kterou vlastnost chcete zobrazit, abyste identifikovali dvojčata v grafu dvojčete. Výchozí hodnota je $dtId hodnota, ale můžete si vybrat z libovolných vlastností, které existují v sadě modelů (dokonce i ty, které nejsou přítomné u každého dvojčete).

Pokud chcete změnit vlastnost zobrazení, použijte rozevírací nabídku Vybrat vlastnost názvu displeje dvojčete. Rozevírací nabídka je seřazena podle počtu modelů, které obsahují vlastnost.

Snímek obrazovky s panelem Azure Digital Twins Explorer Twins Twin Graph Tlačítko Vybrat zobrazovaný název dvojčete je zvýrazněné a zobrazuje nabídku se seznamem různých vlastností dvojčat v grafu.

Pokud zvolíte vlastnost, která není k dispozici u každého dvojčete, zobrazí se všechna dvojčata v grafu, která tuto vlastnost nemají, hvězdičkou (*), za kterou následuje jejich $dtId hodnota.

Upravit rozložení dvojitého grafu

Dvojčata můžete přeuspořádat do různých konfigurací tak, že na ně kliknete a přetáhnete je po obrazovce grafu dvojčat.

Můžete také použít jeden z několika algoritmů rozložení na graf z možností v nabídce Zvolit rozložení .

Snímek obrazovky s panelem grafu dvojčat Azure Digital Twins Explorer. Tlačítko Výběr rozložení je zvýrazněno, což ukazuje nabídku s možnostmi rozložení.

Rozšíření grafu řídicí dvojče

Při zobrazení výsledku dotazu na panelu Dvojitý graf můžete poklikáním na dvojče načíst jeho relace a související dvojčata a zobrazit je, pokud ještě nejsou v zobrazení. Toto rozšíření můžete přizpůsobit nastavením velikosti a směru, abyste zjistili, kolik dvojčat se má načíst.

Chcete-li nastavit počet vrstev, které se mají rozbalit, použijte možnost Úroveň rozbalení. Toto číslo označuje, kolik vrstev relací se má načíst z vybraného dvojčete.

Snímek obrazovky s panelem Azure Digital Twins Explorer Twins Twin Graph Tlačítko Úroveň rozšíření je zvýrazněné.

Chcete-li určit, které typy relací se mají sledovat při rozšiřování, použijte tlačítko Směr rozšíření. Díky tomu můžete vybírat z příchozích, odchozích nebo příchozích i odchozích relací.

Snímek obrazovky panelu Azure Digital Twins Explorer Twin Graph. Tlačítko Směr rozšíření je zvýrazněno a zobrazuje nabídku s možnostmi Vstup, Výstup a Vstup/Výstup.

Zobrazení a skrytí prvků grafu dvojčat

Můžete zapnout nebo vypnout možnost skrýt dvojčata nebo relace v grafu.

Pokud chcete skrýt dvojče nebo relaci, klikněte na ně pravým tlačítkem v okně Grafu Dvojčat. Tím se zobrazí nabídka s možnostmi skrytí elementu nebo jiných souvisejících prvků.

Snímek obrazovky s panelem Azure Digital Twins Explorer Twins Twin Graph Je vybráno dvojče FactoryA a k dispozici je nabídka s možnostmi Skrýt vybrané, Skrýt vybrané + Podřízené položky, Skrýt všechny ostatní a Skrýt jiné než podřízené položky.

Více dvojčat nebo relací najednou můžete také skrýt pomocí kláves CTRL/CMD nebo SHIFT a vícenásobným výběrem několika prvků stejného typu v grafu. Odsud postupujte podle stejného procesu kliknutí pravým tlačítkem a zobrazte možnosti skrytí.

Pokud se chcete vrátit k zobrazení všech dvojčat po některých skrytých, použijte tlačítko Zobrazit vše . Pokud se chcete vrátit k zobrazení všech relací, použijte tlačítko Zobrazit všechny relace .

Snímek obrazovky s panelem Twin Graph v Azure Digital Twins Explorer. Tlačítka Zobrazit vše a Zobrazit všechny relace jsou zvýrazněna.

Filtrování a zvýraznění prvků grafu dvojčete

Dvojčata a relace, které se zobrazují v grafu, můžete filtrovat podle textu, a to výběrem této ikony filtru :

Snímek obrazovky s panelem Azure Digital Twins Explorer Twins Twin Graph Je vybrána ikona filtru textu zobrazující kartu Filtr, kde můžete zadat hledaný termín.

Dvojčata a vztahy, které se v grafu zobrazují, můžete také zvýraznit podle textu výběrem této ikony zvýraznění :

Snímek obrazovky s panelem Azure Digital Twins Explorer Twins Twin Graph Je vybrána ikona filtru textu zobrazující kartu Zvýraznění, kde můžete zadat hledaný termín.

Správa dvojčat a grafu

Azure Digital Twins Explorer nabízí několik způsobů, jak spravovat dvojčata a vztahy ve vaší instanci.

Tato část popisuje, jak provádět následující aktivity správy:

Pro informace o uživatelském zážitku z prohlížení dvojčat a vztahů si přečtěte kapitolu Prozkoumání dvojčat a grafu dvojčat.

Zobrazení plochého seznamu dvojčat a relací

Na panelu Dvojčata se zobrazí plochý seznam dvojčat a jejich přidružených vztahů. Dvojčata můžete vyhledat podle jména a rozbalit je pro zobrazení podrobnějších informací o jejich příchozích a odchozích vztazích.

Snímek obrazovky panelu dvojčat Azure Digital Twins Explorer. Jedno dvojče je zvýrazněno a jeho vztahy jsou zobrazeny.

Vytvoření dvojčat

Na panelu Modely můžete vytvořit nové digitální dvojče z jeho definice modelu.

Pokud chcete vytvořit dvojče z modelu, najděte ho v seznamu a zvolte tečky nabídky vedle názvu modelu. Pak vyberte Vytvořit dvojče. Zobrazí se výzva k zadání názvu nového dvojčete, které musí být jedinečné. Pak uložte dvojče, které se tím přidá do grafu.

Snímek obrazovky s panelem Modely Azure Digital Twins Exploreru Zvýrazní se tečky nabídky pro jeden model a zvýrazněná je také možnost nabídky Vytvořit dvojče.

Pokud chcete do dvojčete přidat hodnoty vlastností, podívejte se na Úprava vlastností dvojčete a relací.

Vytvoření vztahů

Pokud chcete vytvořit relaci mezi dvěma dvojčaty, začněte výběrem zdrojového dvojčete pro relaci v okně grafu dvojčat. Dále podržte stisknutou klávesu CTRL/CMD nebo SHIFT a vyberte druhé dvojče, které bude cílem relace.

Jakmile jsou dvě dvojčata současně vybrána, kliknutím pravým tlačítkem myši na cílové dvojče zobrazte nabídku s možností Přidat mezi nimi relace .

Snímek obrazovky panelu Azure Digital Twins Explorer graf dvojčat. Jsou vybrána dvojčata FactoryA a Consumer a v nabídce se zobrazí možnost Přidat relace.

Tím se zobrazí dialogové okno Vytvořit relaci naplněné zdrojovým dvojčem a cílovým dvojčem relace (můžete je také přepnout pomocí ikony Prohodit relaci ). K dispozici je rozevírací nabídka Relace , která obsahuje typy relací, které může mít zdrojové dvojče podle modelu DTDL. Vyberte možnost pro typ relace a uložte novou relaci.

Úprava vlastností dvojčat a relací

Pokud chcete zobrazit hodnoty vlastností dvojčete nebo relace, vyberte prvek v Twin Graph a pomocí tlačítka Přepnout inspektor vlastností rozbalte Vlastnosti Dvojčete nebo Vlastnosti Relace panel.

Snímek obrazovky s panelem Twin Graph v Azure Digital Twins Explorer. Je vybrána dvojice FactoryA a je rozbalen panel Vlastnosti dvojice, který ukazuje vlastnosti dvojice.

Tento panel můžete použít k přímé úpravě zapisovatelných vlastností. Aktualizujte jejich hodnoty přímo a vyberte tlačítko Uložit změny v horní části panelu. Po uložení aktualizace se na obrazovce zobrazí modální okno zobrazující operaci opravy JSON použitou rozhraním API pro aktualizaci.

Snímek obrazovky panelu Azure Digital Twins Explorer Twin Graph. Uprostřed obrazovky se zobrazuje modální okno s informacemi o cestě, které obsahuje kód opravy JSON.

Návod

Vlastnosti zobrazené na panelech Vlastnosti dvojčat a Vlastnosti relací jsou každá zobrazena s ikonou, která označuje typ pole z modelu DTDL. Další informace o ikonách typů najdete v tématu Ikony datového typu.

Odstranění dvojčat a relací

Pokud chcete odstranit dvojče nebo relaci, klikněte na něj pravým tlačítkem v okně grafu dvojčat. Tím se zobrazí nabídka s možností odstranit prvek.

Snímek obrazovky s panelem Azure Digital Twins Explorer Twins Twin Graph Je vybráno dvojče FactoryA a k dispozici je nabídka obsahující možnost odstranit dvojčata.

Více dvojčat nebo více relací najednou můžete odstranit pomocí kláves CTRL/CMD nebo SHIFT a vícenásobným výběrem několika prvků stejného typu v grafu. Odsud postupujte podle stejného procesu kliknutí pravým tlačítkem a odstraňte prvky.

Můžete také odstranit všechna dvojčata ve vaší instanci současně pomocí tlačítka Odstranit všechna dvojčata na horním panelu nástrojů.

Snímek obrazovky s Průzkumníkem služby Azure Digital Twins. Je vybrána ikona Odstranit všechny dvojníky.

Prozkoumání modelů a grafu modelů

Modely je možné zobrazit na panelu Modely na levé straně obrazovky Průzkumníka služby Azure Digital Twins a na panelu Graf modelů uprostřed obrazovky.

Panel Modely: Snímek obrazovky Průzkumníka služby Azure Digital Twins. Panel Modely je zvýrazněný.

Panel Graf modelu: Snímek obrazovky Azure Digital Twins Explorer. Je zvýrazněn panel Graf modelu.

Poznámka:

Azure Digital Twins Explorer v současné době plně podporuje modely DTDL v2 a podporuje omezené funkce pro modely DTDL v3.

Modely DTDL v3 lze zobrazit na panelu Modely a dvojčata vytvořená pomocí modelů DTDL v3 je možné zobrazit a upravit (včetně dvojčat s vlastnostmi pole). Modely DTDL v3 se ale nezobrazují na panelu Graf modelů a není možné importovat pomocí Průzkumníka služby Azure Digital Twins. K importu modelů DTDL v3 do vaší instance použijte jiné vývojářské rozhraní, jako jsou rozhraní API a sady SDK nebo Azure CLI.

Tyto panely můžete použít k zobrazení modelů.

Panel Graf modelů nabízí také několik možností přizpůsobení zobrazení grafu:

Zobrazení modelů

Plochý seznam modelů můžete zobrazit ve vaší instanci na panelu Modely . Tento seznam je možné prohledávat pomocí panelu hledání na panelu.

Pomocí panelu Graf modelů můžete zobrazit grafické znázornění modelů ve vaší instanci spolu s relacemi, dědičností a komponentami, které je vzájemně propojují.

Poznámka:

Azure Digital Twins Explorer v současné době plně podporuje modely DTDL v2 a podporuje omezené funkce pro modely DTDL v3.

Modely DTDL v3 lze zobrazit na panelu Modely a dvojčata vytvořená pomocí modelů DTDL v3 je možné zobrazit a upravit (včetně dvojčat s vlastnostmi pole). Modely DTDL v3 se ale nezobrazují na panelu Graf modelů a není možné importovat pomocí Průzkumníka služby Azure Digital Twins. K importu modelů DTDL v3 do vaší instance použijte jiné vývojářské rozhraní, jako jsou rozhraní API a sady SDK nebo Azure CLI.

Zobrazení definice modelu

Pokud chcete zobrazit úplnou definici modelu, vyhledejte tento model v podokně Modely a vyberte tečky nabídky vedle názvu modelu. Pak vyberte Zobrazit model. Tím se zobrazí modální zobrazení informací o modelu zobrazující nezpracovanou definici DTDL modelu.

Snímek obrazovky panelu Modely v Azure Digital Twins Exploreru. Ikony nabídky pro jeden model jsou zvýrazněny a zvýrazněna je také možnost Zobrazit model.

Úplnou definici modelu můžete zobrazit také tak, že ji vyberete v grafu modelu a pomocí tlačítka Přepnout podrobnosti modelu rozbalíte panel Podrobnosti modelu. Tento panel také zobrazí úplný kód DTDL modelu.

Snímek obrazovky s panelem Grafu modelu Azure Digital Twins Exploreru. Je vybrán model podlahy a panel Detailů modelu je rozbalen, zobrazující kód DTDL modelu.

Úprava rozložení grafu modelu

Modely můžete přeuspořádat do různých konfigurací tak, že na ně kliknete a přetáhnete je kolem obrazovky Graf modelů.

Můžete také použít jeden z několika algoritmů rozložení na graf modelu z možností v nabídce Zvolit rozložení .

Snímek obrazovky s panelem grafu modelu v Azure Digital Twins Explorer. Tlačítko

Filtrování a zvýraznění prvků grafu modelu

Můžete filtrovat typy odkazů na model, které se zobrazují v grafu modelu. Vypnutím jednoho z referenčních typů prostřednictvím přepínačů v této nabídce zabráníte zobrazení tohoto typu odkazu v grafu.

Snímek obrazovky panelu grafu modelu v Azure Digital Twins Explorer. Zvýrazněná je nabídka filtru pro relace, dědičnost a komponenty.

Modely a odkazy, které se zobrazují v grafu, můžete filtrovat také podle textu, a to tak, že vyberete tuto ikonu filtru :

Snímek obrazovky s panelem Graf modelu Azure Digital Twins Explorer. Ikona filtru textu je vybrána a zobrazuje kartu Filtr, kde můžete zadat hledaný termín.

Modely a odkazy, které se zobrazují v grafu, můžete zvýraznit podle textu tak, že vyberete tuto ikonu zvýraznění :

Snímek obrazovky panelu grafu modelu v Azure Digital Twins Exploreru. Je vybrána ikona textového filtru, což zobrazuje záložku Zvýraznění, kde můžete zadat hledaný termín.

Nahrání imagí modelu

Můžete nahrát vlastní obrázky, které představují různé modely v zobrazení Model Graph a Twin Graph. Můžete nahrát obrázky pro jednotlivé modely nebo pro několik modelů najednou.

Poznámka:

Tyto obrázky jsou uložené v místním úložišti prohlížeče. Místní úložiště prohlížeče znamená, že tyto obrázky nejsou dostupné v jiných prohlížečích než v prohlížečích, ve kterých jste je uložili. Obrázky uložené v místním úložišti prohlížeče zůstanou po neomezenou dobu, dokud se místní úložiště nevymaže.

Pokud chcete nahrát obrázek pro jeden model, najděte ho na panelu Modely a vyberte tečky nabídky vedle názvu modelu. Pak vyberte Nahrát obrázek modelu. V zobrazeném poli selektoru souborů přejděte na svém počítači k souboru obrázku, který chcete nahrát pro tento model. Zvolte Otevřít a nahrajte ho.

Snímek obrazovky panelu Modelů v Azure Digital Twins Exploreru. Zvýrazněné jsou tečky nabídky pro jeden model a také možnost nabídky Nahrát obrázek modelu.

Obrázky modelu můžete také nahrát hromadně.

Nejprve před nahráním nastavte názvy souborů obrázků pomocí následujících pokynů. Díky tomu může Průzkumník služby Azure Digital Twins po nahrání automaticky přiřadit obrázky správným modelům.

  1. Začněte hodnotou ID modelu (například dtmi:example:Floor;1)
  2. Nahraďte instance ":" za "_" (příklad se stane dtmi_example_Floor;1)
  3. Nahraďte instance ";" za "-" (příklad se stane dtmi_example_Floor-1)
  4. Ujistěte se, že soubor má příponu obrázku (příklad bude vypadat přibližně takto dtmi_example_Floor-1.png).

Poznámka:

Pokud se pokusíte nahrát obrázek, který se nenamapuje na žádný existující model podle předchozích kritérií, obrázek se nenahraje ani neuloží.

Potom k nahrání obrázků najednou použijte ikonu Nahrát obrázky modelu v horní části panelu Modely. V poli selektoru souborů zvolte, které soubory obrázků se mají nahrát.

Snímek obrazovky panelu Modelů Azure Digital Twins Exploreru. Ikona Nahrát obrázky modelu je zvýrazněná.

Správa modelů

Pomocí panelu Modely na levé straně obrazovky Průzkumníka služby Azure Digital Twins můžete provádět aktivity správy na celé sadě modelů nebo na jednotlivých modelech.

Snímek obrazovky Průzkumníka služby Azure Digital Twins, panel Modely je zvýrazněný.

Na tomto panelu můžete dokončit následující aktivity správy modelů:

Informace o možnosti zobrazení modelů najdete v tématu Prozkoumání modelů a Graf modelu.

Nahrajte modely

Modely můžete nahrát z počítače tak, že vyberete soubory modelu jednotlivě nebo nahrajete celou složku souborů modelu najednou. Pokud nahráváte jeden soubor JSON, který obsahuje kód pro mnoho modelů, nezapomeňte zkontrolovat omezení hromadného nahrávání modelu.

Poznámka:

Azure Digital Twins Explorer v současné době plně podporuje modely DTDL v2 a podporuje omezené funkce pro modely DTDL v3.

Modely DTDL v3 lze zobrazit na panelu Modely a dvojčata vytvořená pomocí modelů DTDL v3 je možné zobrazit a upravit (včetně dvojčat s vlastnostmi pole). Modely DTDL v3 se ale nezobrazují na panelu Graf modelů a není možné importovat pomocí Průzkumníka služby Azure Digital Twins. K importu modelů DTDL v3 do vaší instance použijte jiné vývojářské rozhraní, jako jsou rozhraní API a sady SDK nebo Azure CLI.

Pokud chcete nahrát jeden nebo více modelů, které jsou vybrané jednotlivě, vyberte ikonu Nahrát model s šipkou nahoru.

Snímek obrazovky s panelem Modelů průzkumníku Azure Digital Twins. Ikona Nahrát model je zvýrazněná.

V zobrazeném okně pro výběr souboru přejděte na svém počítači k modelům, které chcete nahrát. Můžete vybrat jeden nebo více souborů modelu JSON a vybrat Otevřít a nahrát je.

Pokud chcete nahrát složku modelů, včetně všeho, co je v ní, vyberte ikonu Nahrát adresář Modelů zobrazující složku se souborem.

Snímek obrazovky s panelem Modely Azure Digital Twins Exploreru. Ikona pro nahrání adresáře modelů je zvýrazněna.

V zobrazeném poli selektoru souborů přejděte na svém počítači do složky obsahující soubory modelu JSON. Výběrem možnosti Otevřít nahrajete tuto složku nejvyšší úrovně a veškerý její obsah.

Důležité

Pokud model odkazuje na jiný model v jeho definici, například při definování relací nebo komponent, musí být odkazovaný model v instanci k nahrání modelu, který ho používá. Pokud nahráváte modely jeden po druhém, znamená to, že byste měli nahrát model, na který se odkazuje, předtím, než nahrajete jakékoliv modely, které ho používají. Pokud nahráváte modely hromadně, můžete je vybrat ve stejném importu a Azure Digital Twins odvozuje pořadí jejich nahrání. Pokud ale nahráváte více než 50 modelů ve stejném souboru, podívejte se na omezení hromadného nahrávání modelu.

Omezení hromadného nahrání modelu

Omezení v této části platí pro modely obsažené v jednom souboru JSON, které se nahrávají do Průzkumníka služby Azure Digital Twins současně.

I když není nijak omezený počet modelů, které můžete zahrnout do jednoho souboru JSON, existují zvláštní aspekty pro soubory obsahující více než 50 modelů. Pokud nahráváte více než 50 modelů ve stejném souboru modelu, postupujte podle těchto tipů:

  • Pokud existují nějaké modely, které dědí z jiných modelů definovaných ve stejném souboru, umístěte je na konec seznamu.
  • Pokud existují nějaké modely, které odkazují na jiné modely definované ve stejném souboru jako komponenty, umístěte je na konec seznamu.
  • Ověřte, že všude, kde model odkazuje na jiný model definovaný ve stejném souboru (buď prostřednictvím dědičnosti, nebo jako komponenty), je model, který tento odkaz obsahuje, později v seznamu, než je definice odkazovaného modelu.

Následující tipy vám pomůžou zajistit, aby se během procesu nahrávání správně vyřešily závislosti modelu.

Odstranění modelů

Pomocí panelu Modely můžete odstranit jednotlivé modely nebo všechny modely ve vaší instanci najednou.

Pokud chcete odstranit jeden model, najděte ho v seznamu a vyberte tečky nabídky vedle názvu modelu. Pak vyberte Odstranit model.

Snímek obrazovky s panelem Modely Azure Digital Twins Explorer. Zvýrazní se tečky nabídky pro jeden model a zvýrazněná je také možnost nabídky Odstranit model.

Pokud chcete odstranit všechny modely ve vaší instanci najednou, zvolte v horní části panelu Modely ikonu Odstranit všechny modely .

Snímek obrazovky s panelem Modely Azure Digital Twins Exploreru Ikona Odstranit všechny modely je zvýrazněná.

Aktualizace modelů

Když otevřete Průzkumníka služby Azure Digital Twins, měl by se na panelu Modely automaticky zobrazit všechny dostupné modely ve vašem prostředí.

Kdykoli ale můžete panel aktualizovat ručně, abyste znovu načetli seznam všech modelů v instanci služby Azure Digital Twins. Uděláte to tak, že vyberete ikonu Aktualizovat modely .

Snímek obrazovky s panelem Modely Azure Digital Twins Exploreru Ikona Aktualizovat modely je zvýrazněná.

Graf importu a exportu

Na panelu Twin Graph máte možnosti importua exportu funkcí grafu.

Import grafu

Pomocí funkce importu můžete do instance přidat dvojčata, relace a modely. Tato funkce může být užitečná při vytváření mnoha dvojčat, relací a/nebo modelů najednou.

Poznámka:

Pokud soubor importu grafu obsahuje modely, podléhají omezením hromadného nahrání modelu.

Vytvoření importu souboru

Prvním krokem při importu grafu je vytvoření souboru představujícího dvojčata a relace, které chcete přidat.

Soubor importu může být v některém z těchto dvou formátů:

  • Formát založený na formátu JSON vygenerovaný při exportu grafu. Tento formát může obsahovat dvojčata, relace a/nebo modely.
  • Vlastní formát založený na Excelu, popsaný ve zbývající části této sekce. Tento formát umožňuje nahrát dvojčata a relace.
Vytvoření importu souboru v Excelu

Pokud chcete vytvořit vlastní graf v Excelu, který dokáže nahrát dvojčata a relace do Průzkumníka služby Azure Digital Twins, použijte následující formát.

Každý řádek představuje prvek k vytvoření: buď dvojče, vztah, nebo kombinaci dvojčete a odpovídajícího vztahu. K uspořádání dat o dvojčatech nebo vztazích použijte následující sloupce. Názvy sloupců je možné přizpůsobit, ale měly by zůstat v tomto pořadí.

ID modelu Průkaz totožnosti Vztah (zdroj) Název vztahu Inicializační data
(Nepovinné)
ID DTMI modelu, které se má použít pro nové dvojče. Tato definice modelu by již měla existovat v instanci.

Pokud chcete, aby tento řádek vytvořil pouze relaci (bez dvojčat), můžete tento sloupec ponechat prázdný pro řádek.
(Požadováno)
Jedinečné ID dvojčete.

Pokud se v tomto řádku vytváří nové dvojče, jedná se o ID nového dvojčete.
Pokud jsou v řádku informace o relaci, použije se toto ID jako cíl relace.
(Nepovinné)
ID dvojčete, které by mělo být zdrojovým dvojčem pro novou relaci.

Tento sloupec můžete nechat prázdný pro řádek, pokud chcete, aby tento řádek vytvořil pouze dvojče (žádné relace).
(Nepovinné)
Název nové relace, která se má vytvořit. Směr relace je ze dvojčete ve sloupci C k dvojčeti ve sloupci B.
(Nepovinné)
Řetězec JSON obsahující nastavení vlastností pro vytvoření dvojčete. Vlastnosti se musí shodovat s vlastnostmi definovanými v modelu ze sloupce A.

Tady je příklad .xlsx souboru, který vytvoří malý graf dvou podlaží a dvou místností.

Snímek obrazovky s daty grafu v Excelu Záhlaví sloupců odpovídají výše uvedeným polím v pořadí a řádky obsahují odpovídající datové hodnoty.

Tento soubor a další příklady grafu .xlsx můžete zobrazit v úložišti Azure Digital Twins Explorer na GitHubu.

Poznámka:

Vlastnosti a relace popsané v .xlsx se musí shodovat s definicemi modelu pro související dvojčata.

Import souboru do Azure Digital Twins Exploreru

Jakmile budete mít na počítači soubor, který je připravený k importu, vyberte na panelu Twin Graph ikonu Importovat graf .

Snímek obrazovky s panelem Azure Digital Twins Explorer Twins Twin Graph Tlačítko Importovat graf je zvýrazněné.

V zobrazeném poli selektoru souborů přejděte na svém počítači k souboru grafu (.xlsx nebo .json), který chcete nahrát, a zvolte Otevřít a nahrajte ho.

Azure Digital Twins otevře panel Import zobrazující náhled grafu, který se má importovat. Potvrďte to tak, že v pravém horním rohu panelu vyberete ikonu Uložit .

Pokud je import úspěšný, zobrazí se v modálním okně počet nahraných modelů, dvojčat a relací.

Snímek obrazovky s panelem Azure Digital Twins Explorer Twin Graph. Uprostřed obrazovky se zobrazí modální okno s textem Import úspěšný, zobrazující čtyři importované tvíny a dvě importované relace.

Export grafů a modelů

Funkci exportu můžete použít k exportu částečných nebo úplných grafů, včetně modelů, dvojčat a relací. Exportuje dvojčata a relace z nejnovějších výsledků dotazu a všechny modely v instanci do formátu založeného na formátu JSON, který si můžete stáhnout do počítače.

Začněte tím, že pomocí panelu Průzkumník dotazů spustíte dotaz, který vybere dvojčata a vztahy, které chcete stáhnout. Tím je naplníte na panelu Twin Graph.

Návod

Dotaz, který zobrazí všechna dvojčata a relace, je SELECT * FROM digitaltwins.

Jakmile se na panelu Twin Graph zobrazuje část grafu, kterou chcete stáhnout, vyberte ikonu Exportovat graf .

Snímek obrazovky s panelem Azure Digital Twins Explorer Twins Twin Graph Tlačítko Exportovat graf je zvýrazněné.

Tato akce povolí odkaz ke stažení v poli Twin Graph. Vyberte ho, pokud chcete stáhnout reprezentaci výsledku dotazu založenou na FORMÁTU JSON a všechny modely ve vaší instanci do počítače.

Návod

Tento soubor je možné upravit a znovu načíst do služby Azure Digital Twins prostřednictvím funkce importu .

Pokud chcete spolupracovat na práci, můžete sdílet odkaz na prostředí Azure Digital Twins Exploreru s ostatními. Tato část popisuje, jak vygenerovat odkaz na prostředí Azure Digital Twins Explorer, které může volitelně obsahovat konkrétní dotaz, který se má spustit při otevření odkazu. Tato část také popisuje, jaká oprávnění musí mít příjemce k interakci s daty dvojčete.

Požadavky na přístup příjemců

Aby příjemce mohl otevřít odkaz a zobrazit instanci v Průzkumníku služby Azure Digital Twins, musí se přihlásit ke svému účtu Azure a mít přístup ke službě Azure Digital Twins Data Reader k instanci (v zabezpečení si můžete přečíst další informace o rolích Azure Digital Twins).

Aby příjemce mohl provádět změny grafu a dat, musí mít v instanci roli Vlastník dat služby Azure Digital Twins.

Pokud chcete vygenerovat odkaz na prostředí Azure Digital Twins Exploreru, které obsahuje konkrétní dotaz, zadejte dotaz, který chcete zachytit v Průzkumníku dotazů, a pak výběrem tlačítka Sdílet zkopírujte celý odkaz.

Snímek obrazovky s panelem Průzkumníka dotazů Azure Digital Twins Text dotazu a tlačítko Odeslat jsou zvýrazněné.

V příkladu a dotazu na předchozím snímku obrazovky tlačítko Sdílet vytvoří tento odkaz: https://explorer.digitaltwins.azure.net/?query=SELECT%20*%20FROM%20digitaltwins%20T%20WHERE%20T.InFlow%20%3E%2070&tid=<tenant-ID>&eid=<Azure-Digital-Twins-instance-host-name>. Odkaz obsahuje ID tenanta a název hostitele instance služby Azure Digital Twins a formátovaný text dotazu.

Tuto adresu URL můžete sdílet, abyste někomu umožnili přístup k vaší instanci a tomuto dotazu. Když otevřou Průzkumníka služby Azure Digital Twins s odkazem, výsledky dotazu se automaticky vyplní na panelu Twin Graph .

Pokud chcete sdílet odkaz na prostředí Azure Digital Twins Explorer bez připojení konkrétního dotazu, začněte pomocí tlačítka Sdílet a zkopírujte odkaz na vaši instanci.

Snímek obrazovky s panelem Průzkumníka dotazů Azure Digital Twins Zvýrazněné je pouze tlačítko Odeslat.

Potom ručně odeberte parametr dotazu z výsledku.

Například tlačítko Sdílet na předchozím snímku obrazovky by vytvořilo tento odkaz: https://explorer.digitaltwins.azure.net/?query=SELECT%20*%20FROM%20digitaltwins&tid=<tenant-ID>&eid=<Azure-Digital-Twins-instance-host-name>. Můžete odebrat část query=SELECT%20*%20FROM%20digitaltwins&, abyste vytvořili adresu URL https://explorer.digitaltwins.azure.net/?tid=<tenant-ID>&eid=<Azure-Digital-Twins-instance-host-name>.

Pak tuto adresu URL nasdílejte, abyste někomu umožnili přístup k vaší instanci. Když otevřou Průzkumníka služby Azure Digital Twins s odkazem, připojí se k vaší instanci a neuvidí žádné předem vyplněné výsledky dotazu.

Přístupnost a upřesňující nastavení

Pro Azure Digital Twins Explorer můžete povolit několik upřesňujících nastavení pro přizpůsobení prostředí nebo jeho zpřístupnění.

Pomocí ikony Klávesové zkratky na panelu nástrojů vpravo nahoře můžete zobrazit seznam klávesových zkratek, které se dají použít k navigaci v Průzkumníku služby Azure Digital Twins.

Snímek obrazovky Průzkumníka služby Azure Digital Twins. Ikona klávesových zkratek je zvýrazněna na horním panelu nástrojů.

Na panelu nástrojů v pravém horním rohu je možné získat přístup k několika pokročilým funkcím:

  • Načítání s předstihem: Když dotaz vrátí dvojčata, která mají relace s jinými dvojčaty, jež nejsou součástí výsledků dotazu, tato funkce před vykreslením grafu načte "chybějící" dvojčata.
  • Ukládání do mezipaměti: Pokud je tato funkce povolená, Azure Digital Twins Explorer uchovává místní mezipaměť relací a modelů v paměti, aby se zlepšil výkon dotazů. Tyto mezipaměti jsou vymazány u všech operací zápisu na příslušných prvcích a také při aktualizaci prohlížeče. Tato funkce je ve výchozím nastavení vypnutá.
  • Konzola: Tato funkce umožňuje zobrazit okno konzoly, které umožňuje používat jednoduché funkce prostředí pro práci s grafem.
  • Výstup: Tato funkce umožňuje zobrazit okno výstupu, které zobrazuje diagnostické trasování operací.
  • Vysoký kontrast: Tato funkce změní barvy Průzkumníka služby Azure Digital Twins tak, aby se zobrazovaly s větším kontrastem.

Rozložení panelu můžete přizpůsobit úpravou pozic panelů, které tvoří Průzkumníka služby Azure Digital Twins (Průzkumník dotazů, dvojčata, modely, graf dvojčat, graf modelů). Pokud chcete panel přesunout do jiného umístění, klikněte na název panelu a podržte ho a přetáhněte ho na nové požadované místo.

Snímek obrazovky s Průzkumníkem služby Azure Digital Twins. Zvýrazněny jsou názvy panelů Průzkumník dotazů, Průzkumník modelů, Dvojitý graf a Graf modelů.

Pozice panelu se resetují po aktualizaci okna prohlížeče.

Další kroky

Další informace o psaní dotazů pro graf dvojčat Azure Digital Twins: