Rychlý start: Vytváření pracovních postupů automatizované integrace pomocí azure Logic Apps s více tenanty a sady Visual Studio

Platí pro: Azure Logic Apps (Consumption)

V tomto rychlém startu se dozvíte, jak navrhovat, vyvíjet a nasazovat automatizované pracovní postupy, které integrují aplikace, data, systémy a služby napříč podniky a organizacemi pomocí azure Logic Apps a sady Visual Studio s více tenanty. I když tyto úlohy můžete provádět v Azure Portal, Visual Studio umožňuje přidávat aplikace logiky do správy zdrojového kódu, publikovat různé verze a vytvářet šablony Azure Resource Manager pro různá prostředí nasazení. Další informace o modelu s více tenanty a modelu s jedním tenantem najdete v tématu Jednoklient a prostředí integrační služby s více tenanty.

Pokud s Azure Logic Apps teprve začínáte a chcete jenom základní koncepty, vyzkoušejte rychlý start pro vytvoření pracovního postupu aplikace logiky v Azure Portal. Návrhář pracovních postupů funguje podobně jak v Azure Portal, tak i v sadě Visual Studio.

V tomto rychlém startu vytvoříte stejný pracovní postup aplikace logiky se sadou Visual Studio jako v Azure Portal rychlém startu. Můžete se také naučit vytvořit ukázkový pracovní postup aplikace logiky v editoru Visual Studio Code a vytvářet a spravovat pracovní postupy aplikací logiky pomocí Azure CLI. Tento pracovní postup aplikace logiky monitoruje informační kanál RSS webu a odesílá e-maily pro každou novou položku v tomto informačním kanálu. Dokončený pracovní postup aplikace logiky vypadá jako následující pracovní postup vysoké úrovně:

Snímek obrazovky znázorňující pracovní postup vysoké úrovně dokončeného pracovního postupu aplikace logiky

Požadavky

Nastavení sady Visual Studio pro Azure Government

Visual Studio 2017

Můžete použít rozšíření Azure Environment Selector Sady Visual Studio, které si můžete stáhnout a nainstalovat z Webu Visual Studio Marketplace.

Visual Studio 2019

Pokud chcete pracovat s předplatnými Azure Government v Azure Logic Apps, musíte do sady Visual Studio přidat koncový bod zjišťování pro Azure Government Cloud. Před přihlášením k sadě Visual Studio pomocí účtu Azure Government ale musíte přejmenovat soubor JSON, který se vygeneruje po přidání koncového bodu zjišťování pomocí následujícího postupu:

  1. Zavřete Visual Studio.

  2. Najděte vygenerovaný soubor JSON s názvem Azure U.S. Government-A3EC617673C6C70CC6B9472656832A26.Configuration v tomto umístění:

    %localappdata%\.IdentityService\AadConfigurations

  3. Přejmenujte soubor JSON na AadProvider.Configuration.json.

  4. Restartujte Visual Studio.

  5. Pokračujte podle kroků pro přihlášení pomocí svého účtu Azure Government.

Pokud se chcete vrátit k tomuto nastavení, odstraňte soubor JSON v následujícím umístění a restartujte Visual Studio:

%localappdata%\.IdentityService\AadConfigurations\AadProvider.Configuration.json

Vytvoření projektu skupiny prostředků Azure

Začněte vytvořením projektu skupiny prostředků Azure. Další informace o skupinách prostředků a prostředcích Azure.

  1. Spusťte Visual Studio. Přihlaste se pomocí svého účtu Azure.

  2. V nabídce Soubor vyberte Nový>Projekt. (Klávesnice: Ctrl + Shift + N)

    Snímek obrazovky zobrazující nabídku Soubor sady Visual Studio s vybranou možností Nový > projekt

  3. V části Nainstalováno, vyberte Visual C# nebo Visual Basic. Vyberte cloudovou>skupinu prostředků Azure. Pojmenujte svůj projekt, například:

    Snímek obrazovky znázorňující, jak vytvořit projekt skupiny prostředků Azure

    Poznámka

    Názvy skupin prostředků můžou obsahovat pouze písmena, číslice, tečky (.), podtržítka (_), spojovníky (-) a závorky ((, )), ale nemůžou končit tečkami (.).

    Pokud se cloud nebo skupina prostředků Azure nezobrazí, ujistěte se, že jste nainstalovali sadu Azure SDK pro Visual Studio.

    Pokud používáte Visual Studio 2019, postupujte takto:

    1. V poli Vytvořit nový projekt vyberte projekt skupiny prostředků Azure pro Visual C# nebo Visual Basic. Vyberte Další.

    2. Zadejte název skupiny prostředků Azure, kterou chcete použít, a další informace o projektu. Vyberte Vytvořit.

  4. V seznamu šablon vyberte šablonu aplikace logiky . Vyberte OK.

    Snímek obrazovky znázorňující vybranou šablonu Aplikace logiky

    Jakmile sada Visual Studio vytvoří projekt, otevře se Průzkumník řešení, ve kterém se zobrazí vaše řešení. V řešení soubor LogicApp.json nejen ukládá definici aplikace logiky, ale také šablonu Azure Resource Manager, kterou můžete použít k nasazení.

    Snímek obrazovky znázorňující Průzkumník řešení s novým řešením aplikace logiky a souborem nasazení

Vytvoření prázdné aplikace logiky

Pokud máte projekt skupiny prostředků Azure, vytvořte aplikaci logiky pomocí šablony Prázdná aplikace logiky .

  1. V Průzkumník řešení otevřete místní nabídku souboru LogicApp.json. Vyberte Otevřít pomocí Návrháře aplikace logiky. (Klávesnice: Ctrl + L)

    Snímek obrazovky znázorňující návrháře pracovního postupu se souborem .json otevřené aplikace logiky

    Tip

    Pokud tento příkaz v sadě Visual Studio 2019 nemáte, zkontrolujte, jestli máte nejnovější aktualizace pro Visual Studio.

    Visual Studio vás vyzve k zadání předplatného Azure a skupiny prostředků Azure k vytvoření a nasazení prostředků pro aplikaci logiky a připojení.

  2. Jako předplatné vyberte své předplatné Azure. V části Skupina prostředků vyberte Vytvořit nový a vytvořte jinou skupinu prostředků Azure.

    Výběr předplatného Azure, skupiny prostředků a umístění prostředků

    Nastavení Příklad hodnoty Description
    Uživatelský účet Fabrikam
    sophia-owen@fabrikam.com
    Účet, který jste použili při přihlášení k sadě Visual Studio
    Předplatné Průběžné platby
    (sophia-owen@fabrikam.com)
    Název vašeho předplatného Azure a přidruženého účtu
    Skupina prostředků MyLogicApp-RG
    (USA – západ)
    Skupina prostředků Azure a umístění pro ukládání a nasazování prostředků aplikace logiky
    Umístění Stejné jako skupina prostředků Typ umístění a konkrétní umístění pro nasazení aplikace logiky Typ umístění je buď oblast Azure, nebo existující prostředí integrační služby (ISE).

    Pro účely tohoto rychlého startu ponechte typ umístění nastavený na Oblast a umístění na stejné jako skupina prostředků.

    Poznámka: Po vytvoření projektu skupiny prostředků můžete změnit typ umístění a umístění, ale jiný typ umístění ovlivňuje vaši aplikaci logiky různými způsoby.

  3. Návrhář pracovního postupu otevře stránku s úvodním videem a běžně používanými triggery. Posuňte se dolů za video a triggery do šablon a vyberte prázdnou aplikaci logiky.

    Snímek obrazovky znázorňující vybranou prázdnou aplikaci logiky

Sestavení pracovního postupu aplikace logiky

Dále přidejte trigger RSS, který se aktivuje, když se zobrazí nová položka informačního kanálu. Každá aplikace logiky začíná triggerem, který se aktivuje při splnění konkrétních kritérií. Pokaždé, když se trigger aktivuje, vytvoří modul Azure Logic Apps instanci aplikace logiky, která spouští váš pracovní postup.

  1. V návrháři pracovního postupu pod vyhledávacím polem vyberte Vše. Do vyhledávacího pole zadejte "rss". V seznamu triggerů vyberte tuto aktivační událost: Při publikování položky informačního kanálu

    Snímek obrazovky znázorňující návrháře pracovního postupu s vybranou aktivační událostí RSS

  2. Jakmile se trigger zobrazí v návrháři, dokončete sestavení aplikace logiky podle kroků pracovního postupu v Azure Portal rychlém startu a pak se vraťte do tohoto článku. Jakmile budete hotovi, vaše aplikace logiky bude vypadat jako v tomto příkladu:

    Snímek obrazovky znázorňující dokončený pracovní postup aplikace logiky

  3. Uložte řešení sady Visual Studio. (Klávesová zkratka: Ctrl + S)

Nasazení aplikace logiky do Azure

Než budete moct aplikaci logiky spustit a otestovat, nasaďte ji do Azure ze sady Visual Studio.

  1. V Průzkumník řešení v místní nabídce projektu vyberte Nasadit>nový. Pokud se zobrazí výzva, přihlaste se pomocí svého účtu Azure.

    Snímek obrazovky zobrazující nabídku projektu s vybranou možností Nasadit > novou

  2. Pro toto nasazení ponechte výchozí předplatné Azure, skupinu prostředků a další nastavení. Vyberte Nasadit.

    Snímek obrazovky zobrazující pole nasazení projektu s vybranou možností Nasadit

  3. Pokud se zobrazí okno Upravit parametry , zadejte název prostředku pro vaši aplikaci logiky. Uložte nastavení.

    Snímek obrazovky s polem Upravit parametry s názvem prostředku pro aplikaci logiky

    Po zahájení nasazování se v okně Výstup sady Visual Studio zobrazí stav nasazení vaší aplikace. Pokud se stav nezobrazí, otevřete seznam Zobrazit výstup z a vyberte svou skupinu prostředků Azure.

    Snímek obrazovky s oknem Výstup s výstupem stavu nasazení

    Pokud vybrané konektory vyžadují vstup od vás, otevře se okno PowerShellu na pozadí a zobrazí výzvu k zadání potřebných hesel nebo tajných klíčů. Po zadání těchto informací bude nasazení pokračovat.

    Snímek obrazovky s oknem PowerShellu s výzvou k zadání přihlašovacích údajů pro připojení

    Po dokončení nasazení se vaše aplikace logiky nachází v Azure Portal a spouští se podle zadaného plánu (každou minutu). Pokud trigger najde nové položky informačního kanálu, aktivuje se trigger a vytvoří instanci pracovního postupu pracovního postupu aplikace logiky. Pracovní postup odesílá e-maily pro každou novou položku. V opačném případě, pokud trigger nenajde nové položky, trigger se neaktivuje a "přeskočí" instanci pracovního postupu. Pracovní postup čeká před kontrolou do dalšího intervalu.

    Tady jsou ukázkové e-maily, které tento pracovní postup odesílá. Pokud neobdržíte žádné e-maily, zkontrolujte složku s nevyžádanými e-maily.

    Outlook odešle e-mail za každou novou položku RRSS

Blahopřejeme, úspěšně jste vytvořili a nasadili pracovní postup aplikace logiky pomocí sady Visual Studio. Pokud chcete spravovat pracovní postup aplikace logiky a zkontrolovat její historii spuštění, přečtěte si téma Správa aplikací logiky pomocí sady Visual Studio.

Přidání nové aplikace logiky

Pokud máte existující projekt skupiny prostředků Azure, můžete do projektu přidat novou prázdnou aplikaci logiky pomocí okna osnovy JSON.

  1. V Průzkumník řešení otevřete <logic-app-name>.json soubor.

  2. V nabídce Zobrazení vyberte Dalšíosnova JSONsystému Windows>.

  3. Pokud chcete přidat prostředek do souboru šablony, vyberte Přidat prostředek v horní části okna osnovy JSON. Nebo v okně osnovy JSON otevřete místní nabídku prostředků a vyberte Přidat nový prostředek.

    Snímek obrazovky s oknem Osnova JSON

  4. V dialogovém okně Přidat zdroj v vyhledávacím poli vyhledejte logic appa vyberte Aplikaci logiky. Pojmenujte prostředek aplikace logiky a vyberte Přidat.

    Snímek obrazovky znázorňující kroky pro přidání prostředku

Vyčištění prostředků

Až budete hotovi s aplikací logiky, odstraňte skupinu prostředků, která obsahuje vaši aplikaci logiky a související prostředky.

  1. Přihlaste se k webu Azure Portal pomocí stejného účtu, který jste použili k vytvoření své aplikace logiky.

  2. V nabídce Azure Portal vyberte skupiny prostředků nebo vyhledejte a vyberte skupiny prostředků z libovolné stránky. Vyberte skupinu prostředků aplikace logiky.

  3. Na stránce Přehled vyberte Odstranit skupinu prostředků. Jako potvrzení zadejte název skupiny prostředků a vyberte Odstranit.

    Snímek obrazovky s vybranou možností Skupiny prostředků > – Přehled > – Odstranit skupinu prostředků

  4. Odstraňte řešení sady Visual Studio ze svého místního počítače.

Další kroky

V tomto článku jste vytvořili, nasadili a spustili pracovní postup aplikace logiky pomocí sady Visual Studio. Další informace o správě a provádění pokročilých nasazení pro aplikace logiky pomocí sady Visual Studio najdete v těchto článcích: